Right side directionals not working - Road Glide Forums
Do-IT-Yourself For all those Do-it-yourself ideas that will save you some bucks

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-02-2012, 12:19 PM Thread Starter
Prospect
 
crazyredneck's Avatar
 
Join Date: Jun 2012
Location: Mass
Posts: 208
Right side directionals not working

Ok so my right side running lights and directionals aren't working. I took the bike apart to install new speakers and now they don't work. I'm sure I unplugged something I shouldn't have. Can anyone trouble shoot this for me?

2012 RG gloss black. Part of the 26" club now.
2008 fat boy. Loved her but had to let her go for the glide I've been eyeing for a while now.
crazyredneck is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-03-2012, 10:56 AM
Hangaround
 
ejones642's Avatar
 
Join Date: Apr 2011
Location: NC
Posts: 86
You stated you installed new speakers...which obviously requires fairing removal. Ok, so this is what I've noticed when removing my RGC fairing vs my SG fairing...

1. First check your bulb and be sure the filament isn't blown. If the filament isn't blown then the next step will probably be your last and fix the issue.

2. Loosen the bracket of the turn signal that isn't working. Once you have it loosened, turn the switch and turn signal on and while it's on(you'll know its on in the dash) either gently feed some of the turn signal wire back into the fairing through the guide notched in the fairing for the wire OR gently pull some out. The running light should come on and the turn signal should blink again once you've got the wire in a 'non-pinched/kinked' position. Re-install bracket mount and you're done. Hope this helps.

After removing and reinstalling mine I've noticed this happens sometimes. First time it happened, I freaked out thinking I've got an exposed wire shorting so I pulled the outer fairing and saw NONE of the turn wires were skinned or exposed. Thats when noticed that the signal wasn't working because the feed of the wire was bending or folding over when you stuff too much...causing lessened flow of current I suppose. This fixes mine whenever the blinker acts up after removal/reinstallation of outer fairing.

Last edited by ejones642; 07-03-2012 at 03:20 PM.
ejones642 is offline  
post #3 of 3 (permalink) Old 07-03-2012, 09:01 PM Thread Starter
Prospect
 
crazyredneck's Avatar
 
Join Date: Jun 2012
Location: Mass
Posts: 208
Thanks. I'll have to check that out

2012 RG gloss black. Part of the 26" club now.
2008 fat boy. Loved her but had to let her go for the glide I've been eyeing for a while now.
crazyredneck is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Right side 7.25 left side 5.25... Trak350 Audio 3 06-09-2014 09:28 PM
Right turn signals not working roadglidecali Troubleshooting for Road Glides 7 12-16-2011 11:24 AM
right handlebar controls and radio not working (02 e/glide classic convert r/glide) criio1 Troubleshooting for Road Glides 1 07-16-2011 05:34 PM
Brakes not working right!?!?!?! BlackBetty11 Road Glide Specific Discussions 12 04-29-2011 02:58 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome