Monotubes failures - Road Glide Forums
Suspensions Discuss all you Suspension needs and wants here!
Sponsored by: JRI Shocks

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 11-17-2014, 06:32 AM Thread Starter
Grey beard
 
SmokeyJoe's Avatar
 
Join Date: Apr 2012
Location: Jackson, MS
Posts: 972
Monotubes failures

Not sure how many failures are actually documented, but here is my experience. I noticed an improvement immediately after installation. I also noticed a gradually progressive decline in performance to the point it was down right dangerous. To get to the dangerous point I would say it was 5k miles or so.

So tthey were less than a year old so I contacted Progressive to send them back. It was a major pain in my a$$ to get an RMA number out of them. Multiple phone calls and many unanswered emails, but persistence paid off in the end.

So they are fixed now and on there way back home. I asked what happened and he said they had an old style seal in them. The old seal allowed some contaminant in and somehow F them up... Whatever sounds like BS to me anyway. The important thing is they said they fixed them and they are sending them back.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2012 CVO Skunk - Jackpot header, Jackpot Pro-Touring, Power Vision, Ohlins all around, KlockWerks Shield and RSD Clarity line

Last edited by SmokeyJoe; 11-17-2014 at 06:45 AM.
SmokeyJoe is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 11-17-2014, 06:38 AM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,286
Garage
I have the early ones, no problems, but that doesn't mean I don't believe it exist, nobody's perfect.

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
post #3 of 17 (permalink) Old 11-17-2014, 10:17 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
My Progressive Monotubes been in my bike for 3 years with no problems at all. This is the first time I heard or read of the Mono tubes from progressive having a problem so it must not be a common issue.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
 
post #4 of 17 (permalink) Old 11-17-2014, 04:37 PM
Prospect
 
1extremeskier's Avatar
 
Join Date: Sep 2013
Posts: 230
Mine bounces on really bad freeway suncups. Has a sloshing sound, is that normal? No real clunking. Tempted to drive over next week and have them drive my bike since they are somewhat local

2013 Candy Orange, MGS True Duals, SE A/C, Handlebar Lee 18" Cordovas, 21" Primo "CALI" Wheel, KW Level 21" fender, Progressive 444 & Monotubes, Kenwood KDC-X998, Biketronics BT4180, 7.1 PRO, 6X 9 in lids
Blacked out with some chrome for accent
1extremeskier is offline  
post #5 of 17 (permalink) Old 11-17-2014, 05:05 PM
Member
 
RoadGlideGary's Avatar
 
Join Date: Feb 2011
Location: Golden Colorado
Posts: 462
Just put mine in a few months ago so not enough mile or use on mine to say anything other than they make the bike feel like it is nailed to the road. No issues picking a line and riding it like the stock had. I feel your pain with the removal and re-install. Not hard but all the same a PIA!

08' FLTR - Customized!!! (Check my Albums)
05' SuperGlideCustom - sold
RoadGlideGary is offline  
post #6 of 17 (permalink) Old 11-17-2014, 05:10 PM
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
I love mine. This is the first I've heard of anyone having a problem with them.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
post #7 of 17 (permalink) Old 11-17-2014, 06:06 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,131
Garage
Close to 15 K on mine and no problems. Standard height monotubes .

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #8 of 17 (permalink) Old 11-17-2014, 06:42 PM
tmd
Grey beard
 
Join Date: Oct 2010
Location: San Angelo, TX
Posts: 1,477
Mine are 2 years old and have about 10k miles on them. No issues and this is the first thread I've ever noticed where someone did have a problem. Good to know they covered them too.

2011 RGU with more money then sence in it.
Oh and its black because blacks faster.
tmd is offline  
post #9 of 17 (permalink) Old 11-17-2014, 07:32 PM
Prospect
 
1extremeskier's Avatar
 
Join Date: Sep 2013
Posts: 230
I have std height and removed both C clips due to my low weight

2013 Candy Orange, MGS True Duals, SE A/C, Handlebar Lee 18" Cordovas, 21" Primo "CALI" Wheel, KW Level 21" fender, Progressive 444 & Monotubes, Kenwood KDC-X998, Biketronics BT4180, 7.1 PRO, 6X 9 in lids
Blacked out with some chrome for accent
1extremeskier is offline  
post #10 of 17 (permalink) Old 11-17-2014, 08:56 PM
Grey beard
 
Bull_Duck's Avatar
 
Join Date: May 2011
Location: N FL USA. 86 miles south of GA
Posts: 941
Quote:
Originally Posted by SmokeyJoe View Post
Not sure how many failures are actually documented, but here is my experience. I noticed an improvement immediately after installation. I also noticed a gradually progressive decline in performance to the point it was down right dangerous. ....
When did you purchase? Date of manuf. would help.mSerial number.

I bought mine about 1.5 years ago and am delighted thus far with their performance along with the JRI in the rear. All standard height for an '08. Cannot express how much better the ride is on the R Glide.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Bull_Duck is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failures at 5500 Miles? HarleyArcher Engine Related 4 08-11-2017 10:54 PM
progressive monotubes THEMASTERDESTROYER Suspensions 0 03-03-2012 06:27 PM
Installing progressive monotubes how to?? jbrawkus Suspensions 6 12-12-2011 05:16 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome