Monotube issue - Road Glide Forums
Suspensions Discuss all you Suspension needs and wants here!
Sponsored by: JRI Shocks

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 52 (permalink) Old 11-27-2013, 08:58 PM Thread Starter
Prospect
 
Stag556's Avatar
 
Join Date: Jun 2013
Posts: 286
Monotube issue

I just completed my install of many upgrades, one being monotubes. I opted to go with the -2" up front.

Here's my issue. As soon as I backed the bike off the lift and went over the hump to exit the garage, I hear and feel a clunk up front.

I put it back on the lift and rechecked every bolt for tightness. I'm very tedious and went very slow with my install. I didn't use any c-clips and used the two springs on the monotubes, as the instructions stated.

I can't for the life of me figure out what could be wrong. Anyone had this issue or have any tips. I'm dreading takin this thing apart again.


Sent from Motorcycle.com Free App
Stag556 is offline  
Sponsored Links
Advertisement
 
post #2 of 52 (permalink) Old 11-29-2013, 05:53 PM Thread Starter
Prospect
 
Stag556's Avatar
 
Join Date: Jun 2013
Posts: 286
Anyone with any insight?


Sent from Motorcycle.com Free App
Stag556 is offline  
post #3 of 52 (permalink) Old 11-29-2013, 06:24 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,131
Garage
Are you sure you installed right ? I cant speak for the lowering kit Mono tubes ,but the orginal height Mono tubes that I installed a year ago, work great. No thump.

There's also a sequence on re tighting everything back up on the forks &Tripple trees and torque is very important.

also ,you might want to share what your working on. 98s are a lot different than a 13s.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.

Last edited by Big_gary; 11-29-2013 at 06:27 PM.
Big_gary is offline  
 
post #4 of 52 (permalink) Old 11-29-2013, 08:12 PM
Newbie
 
JsGlide's Avatar
 
Join Date: Nov 2011
Location: West Virginia
Posts: 42
You have to install the c-clips. I had the same issue. I tore them down sent them back to be checked. Progressive told me to install the c-clips. I installed all the clips and have not had an issue yet.
JsGlide is offline  
post #5 of 52 (permalink) Old 11-29-2013, 08:44 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,131
Garage
I only installed one clip per side. Progressive told me it was okay to not use any if I wanted a less firm ride . I did have the oem height kit tho, not the lowering one.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #6 of 52 (permalink) Old 11-29-2013, 09:14 PM Thread Starter
Prospect
 
Stag556's Avatar
 
Join Date: Jun 2013
Posts: 286
Quote:
Originally Posted by JsGlide View Post
You have to install the c-clips. I had the same issue. I tore them down sent them back to be checked. Progressive told me to install the c-clips. I installed all the clips and have not had an issue yet.
Really? Well that could explain a lot. Their instructions say for a -2" drop, use both springs and no c clips. I tried contacting progressive today but they are closed for the holiday so I'll give them a shout Monday.

Sorry, it's a '13 RGC.


Sent from Motorcycle.com Free App
Stag556 is offline  
post #7 of 52 (permalink) Old 11-29-2013, 11:35 PM
Life Member
 
mjsdouble's Avatar
 
Join Date: May 2012
Location: West Covina, CA
Posts: 2,617
I only have about a 100 miles on mine. I'm at -2 without any clips per instructions. I haven't noticed any problems at all. I hope you get it worked out quickly.

2012 RGC aka Black Sassy, Vivid Blk, 12" Drk Wind Splitter, V&H Chrome Pro Pipe 2-1, SE AC, TTS, Drago 580 cams, WO612 Outlawz, CM 21/17 Raiders, Monotubes -2 and 444's 11.5". Willie G Theme
SWIII, SWIV, SWV, SWVI, SWVII, SWVIII & SWIX

Last edited by mjsdouble; 11-29-2013 at 11:41 PM.
mjsdouble is offline  
post #8 of 52 (permalink) Old 11-30-2013, 12:09 AM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,286
Garage
I have over 20k miles on mine.... -2" no C clips, no problems. Do you know the manufactured date on your kit? Just asking, I remember some people had issues with a clunk when the lowered kits first hit the market, I don't know what Progressive did to solve the problem.

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
post #9 of 52 (permalink) Old 11-30-2013, 12:49 AM Thread Starter
Prospect
 
Stag556's Avatar
 
Join Date: Jun 2013
Posts: 286
I'm seriously puzzled. I've been very thorough assembling these forks. Can't imagine what could be wrong.

Just have to wait until Monday to talk to progressive.


Sent from Motorcycle.com Free App
Stag556 is offline  
post #10 of 52 (permalink) Old 11-30-2013, 08:25 PM
Newbie
 
JsGlide's Avatar
 
Join Date: Nov 2011
Location: West Virginia
Posts: 42
When I called Progressive they said they got the clunk fixed and it came from the shocks leaking. They said that was not the case with mine or any of the new shocks. They asked me if I was a big guy which I am 270 pounds. They said the shock is bottoming out. I put the clips in didn't notice any difference in height. The shocks are a little stiffer but beats that clanking sound.
JsGlide is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Progressive monotube story BLACKHAWK Suspensions 1 11-07-2011 12:42 AM
progressive monotube cartridge system THEMASTERDESTROYER Suspensions 3 09-25-2011 09:57 PM
Progressive monotube on RGU jupiter Suspensions 11 09-08-2011 09:58 PM
Progressive Monotube bigbrainbob Suspensions 12 04-23-2011 04:32 PM
Proggressive Suspension Monotube Kit akjeff *General Road Glide Discussions/Pictures 6 07-30-2010 10:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome