Wtf - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-22-2014, 08:51 PM Thread Starter
Prospect
 
jaysrgu's Avatar
 
Join Date: May 2013
Location: kelowna bc
Posts: 290
Wtf

okay my radio stuff got here today,head unit is the alpine 149bt,amp is soundstream 4.5 and speakers are focal 6.5 ca1 model,i get deck and speakers in and hook up one speaker just to hear it,i plug my iphone into it and turned it on,it sounded distorted as all beat hell,tried playing with the bass and treble and several different songs and it all sounded distorted,am I doing something wrong here? I cant seem to imagine running thru the amp as it would make it even worse no?
jaysrgu is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-22-2014, 08:57 PM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,704
silly question. Are you sure you have the polarity to that speaker hooked up correctly?

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is offline  
post #3 of 8 (permalink) Old 01-22-2014, 09:10 PM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
Unless you have pics or can go into more detail, it's really hard to diagnose your problem. Did you try another speaker, did you try another channel on the head unit, is it hooked up correctly? Really hard to tell unless you can be just a little more specific, and do some trouble shooting.

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
 
post #4 of 8 (permalink) Old 01-22-2014, 10:33 PM Thread Starter
Prospect
 
jaysrgu's Avatar
 
Join Date: May 2013
Location: kelowna bc
Posts: 290
never thought about the polarity,i just did a quick hook up to hear it,ill chek it out in the morning thanxs
jaysrgu is offline  
post #5 of 8 (permalink) Old 01-22-2014, 11:21 PM
Life Member
 
torqu's Avatar
 
Join Date: Jun 2012
Location: southern Michigan
Posts: 2,610
Slow down. Double check everything. You got this.

Owns " One of those big wheel baggers" you can't ride
torqu is offline  
post #6 of 8 (permalink) Old 01-23-2014, 05:24 AM
Life Member
 
stripclub's Avatar
 
Join Date: Apr 2013
Location: Warren, Ohio
Posts: 1,989
I had a bad patch cord once between my mp3 and the head unit, it would play music, but sounded just as you described.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stripclub is offline  
post #7 of 8 (permalink) Old 01-25-2014, 08:01 PM Thread Starter
Prospect
 
jaysrgu's Avatar
 
Join Date: May 2013
Location: kelowna bc
Posts: 290
okay got the amp mounted,yeah that was fun making the bracket,1st attempt it was to low and hit the outter lol,made another and the fit is awesome.now amp on with stereo the speakers don't sound good,very distorted and unable to take bass at 1/2 way on bass selector,so I called sidecar cycles and they are suggesting pulling out the new focals as the ones I got are entry level and there not gonna take the abuse,there recommending hawg wired speakers,has anyone used these speakers? looking for feedback,they told me these will handle hours of loud pumping hard rock without blowing up..
jaysrgu is offline  
post #8 of 8 (permalink) Old 01-25-2014, 08:56 PM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
I like Hawgwired, I have 4 of their amps and have previously used their speakers and amps, but I have to disagree with what you were told. I have Focal speakers, before I had my present set up I was using the CAs, yes they are entry level, but they're a good speaker, I was using them with the RF PBR amp and had to have the volume pretty high before they distorted. Have you tried hooking one of your OEM speakers up to see how it sounds?

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Batt & Low Fuel light came on WTF Cotton Hill Troubleshooting for Road Glides 1 10-17-2011 07:50 PM
No Cruise Control WTF Cotton Hill Troubleshooting for Road Glides 12 08-15-2011 06:35 PM
Wtf ??? OldNerdGuy *General Road Glide Discussions/Pictures 9 08-06-2011 07:39 PM
Wtf Whatever01 Troubleshooting for Road Glides 19 06-09-2011 12:46 PM
wife said no ........ wtf ? groupw Road Glide Specific Discussions 50 02-25-2011 03:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome