Newly installed Polk 6.5'a - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 03-02-2014, 05:44 AM Thread Starter
Prospect
 
BILBO's Avatar
 
Join Date: Nov 2013
Location: Savannah, Ga.
Posts: 271
Newly installed Polk 6.5'a

I'm new to touring bikes, and bikes with stereos, so I'm completely lost when it comes to upgrading mobile audio. Please excuse my ignorance.BUT.... I recently installed some speakers (no aMP at this time) I soldered the connections, GOT EVERYTHING put back together after listening to then to "make sure" the connections were good... But when I went for a test ride, the sound coming from the speakers sounded like it was being played on a record. There was piping and cracking (like static). The ironic thing is, it only happens while riding. Never when it's just sitting there...

Any opinions on what I need to do... Check?

I'm not ANYWHERE familiar with mobile audio, as I am with Home Audio...

Any help would be Greatly Appreciated!

Jay

Sent from Motorcycle.com Free App
BILBO is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 03-02-2014, 06:15 AM
Member
 
Venomized's Avatar
 
Join Date: Apr 2013
Location: Rome, GA
Posts: 672
Whats the speaker model? What source are you using (CD/AUX/RADIO)? Did you ceck your connections to make sure theyre correct polarity and not loose? Youll get a "hallway effect" if ones correct polarity and the others not. The static sound could be a loose coonection.

If all you changed was speakers then the speakers have to be the culprit.

'07 Pewter Pearl
Road Glide or No Ride!
Venomized is offline  
post #3 of 25 (permalink) Old 03-02-2014, 07:50 AM
Life Member
 
rlaf75's Avatar
 
Join Date: Sep 2011
Location: East Hartford CT
Posts: 7,176
+1 with the check connections and polarity. I have the stock radio, polk 6.5 and no amp and its a vast improvement over the stock speakers. I can hear clearly up to about 80mph. Granted its not as good as it could be with an amp but definately better than stock speakers

09 Mirage Orange Pearl

Some people just need a high-five. In the head. With a chair
rlaf75 is offline  
 
post #4 of 25 (permalink) Old 03-02-2014, 09:05 AM Thread Starter
Prospect
 
BILBO's Avatar
 
Join Date: Nov 2013
Location: Savannah, Ga.
Posts: 271
DXI 650

Sent from Motorcycle.com Free App
BILBO is offline  
post #5 of 25 (permalink) Old 03-02-2014, 09:15 AM Thread Starter
Prospect
 
BILBO's Avatar
 
Join Date: Nov 2013
Location: Savannah, Ga.
Posts: 271
It doesn't matfer if I listen to Radio,CD, Aux, via Bluetooth for Music off of my phone.... I KNOW the connections are secure....on the speaker end, but I extended the wires and butt connected at that point.
The speakers are ALL that I changed...
My question is.... Why does it only have "static and popping sounds" with riding..... If it were "wrong" shouldn't it do it ALL of the time.... If all I do is turn the switch on, and listen to radio, cd, our aux... It doesn't make the sound....
Stock head unit
No amp



Sent from Motorcycle.com Free App
BILBO is offline  
post #6 of 25 (permalink) Old 03-02-2014, 12:51 PM
Hangaround
 
Join Date: Jul 2013
Location: Indianapolis
Posts: 156
Quote:
Originally Posted by BILBO View Post
DXI 650

Sent from Motorcycle.com Free App
These are 4 ohm speakers and depending on the year of your Bike the Harley system is 2 ohm. You will need to get an amp to run these speakers or change the speakers to the Polk MM651 model. These are 2.7 Ohms. The Rockford Fosgate PBR300X2 would be a great start with either speaker. To fully enjoy your speakers at speed you will need an amp. The HK unit doesn't have a strong enough signal to push 4 ohm speakers.

Last edited by Gannicus; 03-02-2014 at 12:55 PM.
Gannicus is offline  
post #7 of 25 (permalink) Old 03-02-2014, 12:55 PM Thread Starter
Prospect
 
BILBO's Avatar
 
Join Date: Nov 2013
Location: Savannah, Ga.
Posts: 271
My bike is an'03 with stock HK Head Unit.
Thanks for the info..

Sent from Motorcycle.com Free App
BILBO is offline  
post #8 of 25 (permalink) Old 03-02-2014, 01:05 PM
Hangaround
 
Join Date: Jul 2013
Location: Indianapolis
Posts: 156
Quote:
Originally Posted by BILBO View Post
My bike is an'03 with stock HK Head Unit.
Thanks for the info..

Sent from Motorcycle.com Free App
Not completely sure if the 03 system is 2 ohm or 4 ohm. I'd give Tony a call at Iron cross audio tomorrow he would know for sure. http://www.ironcrossaudio.com
Gannicus is offline  
post #9 of 25 (permalink) Old 03-02-2014, 05:08 PM
Member
 
Venomized's Avatar
 
Join Date: Apr 2013
Location: Rome, GA
Posts: 672
Wont matter if theyre 4 ohm or 2 ohm. The reason its doing it only while riding is that at one of your points of connection its loose. Its losing connection with the vibration of the bike.

'07 Pewter Pearl
Road Glide or No Ride!
Venomized is offline  
post #10 of 25 (permalink) Old 03-02-2014, 05:19 PM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
Quote:
Originally Posted by Venomized View Post
Wont matter if theyre 4 ohm or 2 ohm. The reason its doing it only while riding is that at one of your points of connection its loose. Its losing connection with the vibration of the bike.
I agree, the OP said he used butt connectors to extend the wires, that's the first place I'd be looking.

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newly aquainted to no red sunglasses piggs *General Road Glide Discussions/Pictures 4 07-08-2013 09:38 AM
My Newly Painted Mean Mug Bezel Andyman Aftermarket Accessories 17 05-02-2013 06:28 PM
Newly installed 13" Windvest dgfltru Windshields 3 07-24-2012 08:46 PM
2011 CVO RG has newly designed handlebars DED HD Controls & Handlebars 2 08-16-2010 03:54 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome