Problem with Biketronics controller - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-15-2014, 11:49 PM Thread Starter
Newbie
 
Join Date: Jun 2013
Posts: 19
Problem with Biketronics controller

Anyone else have this problem? I cut and paste this email I sent to Biketronics.
Hello,

I purchased a Sony CDX-GT575UP, BT1002 kit, BT 67 and a generic harness. After the install , when I first powered it up, it turned off after a few seconds. It did this for a few times. I checked all the connections, and same thing. I unplugged the remote wire in the back, and the unit stayed on. Configured the clock and station memory. Plugged the remote wire back in, and the unit turned off.
So, I unplugged everything again, to see if it was a sequence thing. Plugged the remote wire in the back with wire pointing upright, plugged in the back of unit, connected the white harness, and finally the 23 pin harness. Turned on the unit and it stayed on. The handle bar controls worked, went to set clock, and stations, and adjusted volume with the unit dial, it didnít work, and the handlebar one didnít either.
Iím baffelled !!!
I tried calling number 1-800-735-2419 and it says I canít dial that number from my area. (Hawaii).

Thanks for any help you can provide.
Hawaiian Turbo is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-22-2014, 03:20 PM Thread Starter
Newbie
 
Join Date: Jun 2013
Posts: 19
Well, I found the harness on the Module to have a loose connection. Biketronincs is sending me a new module. Great customer service !!!!!!
Hawaiian Turbo is offline  
post #3 of 4 (permalink) Old 04-24-2014, 11:28 PM
Hangaround
 
Nchoman's Avatar
 
Join Date: Jun 2012
Location: Andover, KS
Posts: 69
Nice, good to hear it worked out for you. I will be breaking my system down soon to try and chase a loose connection. My issue is the volume will adjust to max on its own and I often lose handlebar radio switch control in conjunction with it. Will be soldering everything this time.

12' BBP RGUltra, dual dragulas, tman tq555's, tmax, zippers air, daymakers, 12.5 apes, odds and ends

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Nchoman is offline  
 
post #4 of 4 (permalink) Old 04-25-2014, 07:32 AM
Grey beard
 
RGUrider's Avatar
 
Join Date: Aug 2011
Location: Murfreesboro TN by way of Freeburg IL, Naples Italy, Oscoda MI, Ramstein AB GE, and Dover PA
Posts: 875
Garage
My biketronics experience was a bad module where it would not pass the signal through for right side speakers (this was right out of the box install). Called them, they sent a replacement, so good customer service. I bypassed their module and went straight to HU. I occassionally have issues with handlebar controls not responding, this is usually right after it gets wet (rain or washing bike), dries out and works. Have to shut down radio because it cranks volume to full. Don't think I will use biketronics in the future nor recommend them to anyone.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 RGU/Black - Rinehart True Duals, SERT, K&N Filter, RF PBR300X2,
Hawgwired ZX's, Pioneer G1644R, J&M Hidden Antenna, Sony HU
RGUrider is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Biketronics right speaker volume problem Arthur Audio 9 06-09-2016 10:03 AM
Looking for a rear run-turn-brake controller for my '12 FLTRX modot66 Lighting 6 07-13-2012 11:04 AM
iPod Controller CVO Joel Aftermarket Accessories 5 11-22-2011 08:53 PM
Dynatek FI Controller jon06 ECM/Fuel Management systems 0 03-14-2011 07:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome