Disappointed: JM Rokker XX, Soundstream 350D, Alpine 149bt - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 04-09-2014, 02:57 PM Thread Starter
Member
 
hometoast's Avatar
 
Join Date: Aug 2013
Location: 18707
Posts: 714
Garage
Disappointed: JM Rokker XX, Soundstream 350D, Alpine 149bt

I have to say, I'm disappointed. It's not about volume so much, because it's ear bendingly loud compared to the stock setup. But myself, and the wife to a greater extent, can't hear the radio. It's like the vocals are almost missing. I know I won't hear much thumping or anything like that. But wife claims she can hear the old system better.

It's strange. Definitely loud. Definitely harder to hear at the same time. The audio is shrill/tinny/whatever you might call it.

And I've tried different sources, different tracks, different settings (treble, bass up and down both directions).

And the speaker grills with the tweeter and midranges... I can tell nearly zero difference with them connected vs not. Right now the grills sit disconnected.



Any advice? Perhaps my hopes got too high? But how can then the wife claim it was easier to hear the radio from the factory?

2013 Candy Orange FLTRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hometoast is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 04-09-2014, 03:02 PM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
Do you by any chance have another set of speakers laying around?

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
post #3 of 13 (permalink) Old 04-09-2014, 03:31 PM Thread Starter
Member
 
hometoast's Avatar
 
Join Date: Aug 2013
Location: 18707
Posts: 714
Garage
Quote:
Originally Posted by dbell66253 View Post
Do you by any chance have another set of speakers laying around?

Sent from my SPH-L710
Just the stock pair

2013 Candy Orange FLTRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hometoast is offline  
 
post #4 of 13 (permalink) Old 04-09-2014, 03:50 PM
Member
 
OKBigD's Avatar
 
Join Date: Apr 2013
Location: Oklahoma
Posts: 516
I have a very similar setup except using Polm MM651's... Bass, Mid, Treble adjustments were worthless... make your sound adjustments on the BT149 using the built in 9 band parametric EQ... It takes longer to set up but the response is 10x better then the simple Bass, Mid, Treble adjustments....
OKBigD is offline  
post #5 of 13 (permalink) Old 04-09-2014, 03:52 PM
Member
 
OKBigD's Avatar
 
Join Date: Apr 2013
Location: Oklahoma
Posts: 516
Next question is did you use the HP crossover on the SS amp? I set my amp to full range and I'm using the X-over on the alpine 149bt front and rear along with the parametric eq..... My sound kinda sucked at first when I had it set to High pass...
OKBigD is offline  
post #6 of 13 (permalink) Old 04-09-2014, 04:13 PM Thread Starter
Member
 
hometoast's Avatar
 
Join Date: Aug 2013
Location: 18707
Posts: 714
Garage
BigD: I have the amp xover to full. The JM speakers have their own builtin cross over (I think they're set to 80hz?).

I was using bass/treble adjustment on the alpine... I had no idea it had a 9-band EQ on there too! I'll try messing with that.

2013 Candy Orange FLTRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hometoast is offline  
post #7 of 13 (permalink) Old 04-09-2014, 04:15 PM
Member
 
OKBigD's Avatar
 
Join Date: Apr 2013
Location: Oklahoma
Posts: 516
Quote:
Originally Posted by hometoast View Post
BigD: I have the amp xover to full. The JM speakers have their own builtin cross over (I think they're set to 80hz?).

I was using bass/treble adjustment on the alpine... I had no idea it had a 9-band EQ on there too! I'll try messing with that.
I set my fronts to 80hz with the alpine so that should be ok.... Play around with the parametric eq, it definitely makes a difference.... Mine is so loud now that no one I ride with can hear a word I say..... LOL....
OKBigD is offline  
post #8 of 13 (permalink) Old 04-09-2014, 04:31 PM Thread Starter
Member
 
hometoast's Avatar
 
Join Date: Aug 2013
Location: 18707
Posts: 714
Garage
Quote:
Originally Posted by OKBigD View Post
I set my fronts to 80hz with the alpine so that should be ok.... Play around with the parametric eq, it definitely makes a difference.... Mine is so loud now that no one I ride with can hear a word I say..... LOL....
I owe you, sir, a beer! Or a coffee or whatever.

I actually started with the factory EQ preset settings. Funny enough, rock sounds great under "Classical"! This thing is NOW sounding like I imagined it would!

When I selected the Factory EQ the first time, It was on "flat", so I scrolled down to pop or whatever it was and it was immediately better. when I scrolled back up to flat, it STILL sounded better. I'm thinking the EQ came shipped to a really shitty setting.

2013 Candy Orange FLTRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by hometoast; 04-09-2014 at 04:48 PM.
hometoast is offline  
post #9 of 13 (permalink) Old 04-10-2014, 07:51 AM
Member
 
OKBigD's Avatar
 
Join Date: Apr 2013
Location: Oklahoma
Posts: 516
Quote:
Originally Posted by hometoast View Post
I owe you, sir, a beer! Or a coffee or whatever.

I actually started with the factory EQ preset settings. Funny enough, rock sounds great under "Classical"! This thing is NOW sounding like I imagined it would!

When I selected the Factory EQ the first time, It was on "flat", so I scrolled down to pop or whatever it was and it was immediately better. when I scrolled back up to flat, it STILL sounded better. I'm thinking the EQ came shipped to a really shitty setting.
and you can still tweak each of the 9 eq bands and it will sound even better... Kinda a learning process though.... not the easiest to navigate
OKBigD is offline  
post #10 of 13 (permalink) Old 04-10-2014, 09:07 AM Thread Starter
Member
 
hometoast's Avatar
 
Join Date: Aug 2013
Location: 18707
Posts: 714
Garage
Quote:
Originally Posted by OKBigD View Post
and you can still tweak each of the 9 eq bands and it will sound even better... Kinda a learning process though.... not the easiest to navigate
Definitely, I'm sure I can tweak quite a bit more. But for "out of the box" this is incredible.

I know all it took was you mentioning "9-band eq" to fix it, but thanks again.

2013 Candy Orange FLTRX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by hometoast; 04-10-2014 at 09:11 AM.
hometoast is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
alpine 149bt jaysrgu Audio 6 04-16-2014 09:20 AM
Question about Alpine CDE 149BT. Shasta3 Audio 4 04-02-2014 10:09 PM
alpine 149bt jaysrgu Audio 4 03-21-2014 03:03 PM
Alpine 149bt handlebar control ? sharknose10 Audio 4 02-16-2014 10:54 AM
Boom vs JM Rokker XX AndyM Audio 11 02-12-2014 02:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome