Burning smell, and amp shorting out. Any ideas why? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-11-2014, 09:51 PM Thread Starter
Hangaround
 
Bubba's Avatar
 
Join Date: Jun 2011
Location: Memphis area
Posts: 90
Burning smell, and amp shorting out. Any ideas why?

I've been using a Rockford PBR 300x2 and Polk mm651's for about two years now. Today I washed my bike and went for a ride. After a few minutes I started to smell a burning smell then my left speaker let out a little smoke. I pulled the fairing off and the speaker is fried. The weird thing is the other channel of the amp and other speaker is fine. And I tried the channel that messed up on an old speaker and it shoots sparks when it's connected or if I brush the wires together. Just can't figure out if it was just this amps time to go, or if I did something wrong? The only thing I can think go that I could of done wrong would be, I just did the Monroe shock project and had a ground problem so I had to unhook the positive side of the battery two or three times. Just really frustrated.


Sent from Motorcycle.com Free App
Bubba is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-11-2014, 09:55 PM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
You brushed the wires together for the output of the amp? If so, you might have fried it then.......

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
post #3 of 7 (permalink) Old 04-11-2014, 10:22 PM Thread Starter
Hangaround
 
Bubba's Avatar
 
Join Date: Jun 2011
Location: Memphis area
Posts: 90
No the output for the channel that had already fried. It was throwing sparks when I hooked it to the old speakers, so I was curious and figured it was already junk anyway.


Sent from Motorcycle.com Free App
Bubba is offline  
 
post #4 of 7 (permalink) Old 04-11-2014, 10:41 PM
Administrator
 
dbell66253's Avatar
 
Join Date: Feb 2011
Location: South Florida
Posts: 12,263
Garage
Two years. .... I guess that means warranty is gone. Replace it with a class D amp like the Sound Stream, you'll like it, also might want to try a set of Infinity Kappa since you're going to have to get speakers also...... system will cost less and I'm sure you'll be happy with it. That's just my opinion.

Sent from my SPH-L710

2010 FLTRX With Plenty of extras, goes by the name "Hardeshia"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Also not pictured 2016 FLTRXS and 2017 FLTRXS, you never can have too many SHARKS......
dbell66253 is offline  
post #5 of 7 (permalink) Old 04-11-2014, 11:00 PM
Member
 
glide1's Avatar
 
Join Date: Oct 2012
Location: Daytona Beach Fl.
Posts: 336
You said you washed the bike, Maybe some water got into the Fairing and shorted out the Amp??
glide1 is offline  
post #6 of 7 (permalink) Old 04-12-2014, 12:20 AM
Gray Beard
 
lundboy1's Avatar
 
Join Date: Jan 2013
Location: Eastern Idaho
Posts: 1,521
Garage
I've had amps and speakers give trouble free service for years and then traded up or sold the vehicle, I'd retrace my steps through you last mod. Just to be sure, but it's not likely with just one blown channel.


Sent from Motorcycle.com App

" wishin' my knees were in the breeze!!!"
lundboy1 is offline  
post #7 of 7 (permalink) Old 04-12-2014, 06:24 AM Thread Starter
Hangaround
 
Bubba's Avatar
 
Join Date: Jun 2011
Location: Memphis area
Posts: 90
I thought the same thing Glide1, but when I pulled it apart it was dry inside. I had also made my mind up on the infinity speakers, I was looking at the 6211.i , but honestly I was thinking of going back with the Rockford amp mine worked just fine for two years under pretty harsh conditions for an amp I figured, and it just now gave me the first problem.


Sent from Motorcycle.com Free App
Bubba is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any ideas on get the most $ out of my total FLTRX vontoughguy *General Road Glide Discussions/Pictures 6 08-07-2017 05:14 PM
Smell oil burning help WOOSAB Fluids and Lubricants 4 07-08-2016 11:17 PM
STRONG gas smell. Any ideas?? RGCBandit Troubleshooting for Road Glides 33 01-04-2014 12:56 PM
How to get the smell out? Brando Clothing 23 03-16-2012 06:41 PM
Why? Why? Why? CMS *General Road Glide Discussions/Pictures 16 04-11-2011 01:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome