Anyone ever blow a Biketronics Titan II speaker - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-19-2014, 05:08 PM Thread Starter
Life Member
 
HellInABucket's Avatar
 
Join Date: Nov 2012
Location: SE Michigan
Posts: 1,815
Anyone ever blow a Biketronics Titan II speaker

Had the fairing off, I noticed the left one was muffled and distorted. Swapped wires same thing, so I figure its blown.

Anyone else? Lifetime warranty, so I'm not terribly concerned but for the inconvenience.

2020 FLTRK - Roll away the dew...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HellInABucket is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-16-2014, 02:28 PM
Newbie
 
Join Date: Apr 2014
Location: North Texas
Posts: 13
i think that i may have blown one this past weekend, going to pull the faring tonigh to check. How did yours turn out, i see that you posted this 2 months ago.
sjohn1024 is offline  
post #3 of 5 (permalink) Old 06-16-2014, 02:35 PM Thread Starter
Life Member
 
HellInABucket's Avatar
 
Join Date: Nov 2012
Location: SE Michigan
Posts: 1,815
Quote:
Originally Posted by sjohn1024 View Post
i think that i may have blown one this past weekend, going to pull the faring tonigh to check. How did yours turn out, i see that you posted this 2 months ago.
Oops, sorry! I had the fairing off to install an oil temp gauge. I took the speaker and the underlying support frame off because I was considering putting a speaker cone on it, but decided not to, and reinstalled the speaker. Thats when I noticed it sounded horrible, and assumed it was blown.

When I got the replacement speaker, I saw that I had not put a screw from the mounting bracket all the way back in, and also a plastic washer had squished out such that they were touching the speaker.

I dremeled a bit off the washer and tightened down the screw and it was all good.

Sent the new speaker back.

2020 FLTRK - Roll away the dew...

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HellInABucket is offline  
 
post #4 of 5 (permalink) Old 06-16-2014, 08:09 PM
Newbie
 
Join Date: Apr 2014
Location: North Texas
Posts: 13
Thanks for the reply, I pulled my faring this evening and found both my speakers are blown. Going to call biketronics tomorrow. Did a little testing and found that everything was hooked up correctly, I unhooked both speakers and hooked up a pair of alpine 5x7's I had on the shelf and it sounded good. Will see what comes of the warranty. Only had these speakers for a few months.
sjohn1024 is offline  
post #5 of 5 (permalink) Old 06-17-2014, 07:30 AM
Member
 
Join Date: Feb 2012
Location: Austin Texas
Posts: 341
Blew 2 sets, first set was a easy replacement and I havnt sent back the second set yet.
Jims79FLH is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
BT471 Biketronics Titan II 6.5" speaker upgrade kit. WestTexasRanger Parts for Sale 0 02-19-2016 09:58 PM
FS: Biketronics Titan II 6.5" Speakers Garemlin Sold 7 03-03-2013 01:51 PM
Biketronics 6.5" Titan II's anyone??? Dfwhockey17 Audio 9 11-06-2012 10:23 AM
RF PBR 300X2 / Biketronics's Titan II JadaGlide Audio 5 08-31-2012 11:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome