Audio quit. - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-26-2014, 09:27 AM Thread Starter
Newbie
 
Join Date: Feb 2012
Location: Huntersville, NC
Posts: 16
Audio quit.

My stereo went out after an aggressive wash job Saturday. Needed to get her clean for the year and I needed the therapy. It was a 3 beer project. It actually ran for a while after I finished but then stopped. I let it sit for 2 days to make sure it was dried out. First I changed the fuses (4 & 5). I checked the error messages and got nothing and I am getting some power to the unit because I can put a CD in and take it out. Currently I am running stock head unit, arc mini amp and hertz speakers. Any thoughts on if this is shot. Or is it too hard to tell from just this limited info?
jefflew is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-26-2014, 10:12 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,059
Garage
Sounds like the amp my be gone. Did you check the fuse for the amp ? It should be close to the battery. If its good ,Take the fairing off and bypass the amp.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #3 of 4 (permalink) Old 05-26-2014, 10:55 AM Thread Starter
Newbie
 
Join Date: Feb 2012
Location: Huntersville, NC
Posts: 16
Thanks Gary, that is what I suspected, but if the CD player is operating. I thought I would get some readout on the head unit. I can't even get the HD logo. The fuse is attached to the amp on my amp (ARC KS Mini 125.2 Mini) so I will be pulling the ferring and working from there.
jefflew is offline  
 
post #4 of 4 (permalink) Old 05-26-2014, 12:34 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,059
Garage
Sounds like there could still water in there then. I once got water in my amp on an old ultra, when they put them under the tour pack. It took over a month for it to dry out. Ever since , I never spray water with any pressure directly at anything on the bike.
I'd still pull the fairing to run a few checks.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wife quit smoking jack6hd Healthy Living 23 02-10-2014 07:36 PM
Headlights quit working dirtyb Troubleshooting for Road Glides 11 07-09-2012 12:42 PM
Air temp gauge quit working garvin90 Tech Area 14 06-22-2012 01:07 PM
Finally quit dragging my feet! Radioactive *General Road Glide Discussions/Pictures 9 03-31-2012 01:32 PM
Tach quit?? pte359 Troubleshooting for Road Glides 0 06-18-2011 04:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome