Radio backlight not working - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 06-01-2014, 08:00 AM Thread Starter
Hangaround
 
Join Date: Mar 2013
Location: Naperville IL.
Posts: 80
Radio backlight not working

I just noticed the backlight on the radio not working last night. I really don't ride that much at night so I'm not sure how long its been this way. Is there a possible loose connection or something I can do? I am planning a trip next week and I really don't want to take it into the dealer right now. Who knows when I'll get it back.
Thanks


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2013 BBP RGC
NorbJ is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 06-01-2014, 08:58 AM
Member
 
sportyguy69's Avatar
 
Join Date: Jun 2010
Location: York, South Carolina
Posts: 400
Prob just a bad connection. Take your finger and push on the display window and see if it comes on. The display on my 07 goes out every now and then I just push on the display and it comes back on. Check out this write up also.
http://www.v-twinforum.com/forums/el...ay-repair.html

If your going to do something give it all you got, might be the last time you ever do it !!!
sportyguy69 is offline  
post #3 of 10 (permalink) Old 06-01-2014, 09:38 AM Thread Starter
Hangaround
 
Join Date: Mar 2013
Location: Naperville IL.
Posts: 80
Smile

Thanks for the info.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2013 BBP RGC
NorbJ is offline  
 
post #4 of 10 (permalink) Old 06-01-2014, 09:52 AM
Life Member
 
rlaf75's Avatar
 
Join Date: Sep 2011
Location: East Hartford CT
Posts: 7,176
Mine goes out too. The radio still works just no display. I'm waiting for it to completely stop working then I will go with a nice aftermarket unit.

09 Mirage Orange Pearl

Some people just need a high-five. In the head. With a chair
rlaf75 is online now  
post #5 of 10 (permalink) Old 06-01-2014, 10:01 AM
Life Member
 
ironmark's Avatar
 
Join Date: Dec 2010
Posts: 6,528
Did you go to the display function on the radio and adjust the backlight. The backlight may be adjusted to where it is off.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
08 FLTR candy red sunglo,with 2015 103 HO, V&H Dresser Duals with Monster Rounds, Power Vision tuner, Willy Shiny Wheels and Forks and a bunch of other stuff.
ironmark is offline  
post #6 of 10 (permalink) Old 06-01-2014, 10:35 AM
Member
 
sportyguy69's Avatar
 
Join Date: Jun 2010
Location: York, South Carolina
Posts: 400
Quote:
Originally Posted by rlaf75 View Post
Mine goes out too. The radio still works just no display. I'm waiting for it to completely stop working then I will go with a nice aftermarket unit.
I had the same problem till I did this repair. No more problems.

http://www.v-twinforum.com/forums/el...ay-repair.html

If your going to do something give it all you got, might be the last time you ever do it !!!
sportyguy69 is offline  
post #7 of 10 (permalink) Old 06-01-2014, 03:17 PM Thread Starter
Hangaround
 
Join Date: Mar 2013
Location: Naperville IL.
Posts: 80
Quote:
Originally Posted by ironmark View Post
Did you go to the display function on the radio and adjust the backlight. The backlight may be adjusted to where it is off.
Interesting. I know you can adjust the display. But that only adjusted the darkness of the display it has nothing to do with the backlight. I have looked at the manual not unless I am missing something. Please correct me if I'm wrong.
Always willing to learn. The backlight is the orange/red background.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2013 BBP RGC
NorbJ is offline  
post #8 of 10 (permalink) Old 06-01-2014, 05:15 PM
Gray Beard
 
lundboy1's Avatar
 
Join Date: Jan 2013
Location: Eastern Idaho
Posts: 1,521
Garage
You lost an led on the circuit board

ImageUploadedByMO Free1401660693.452501.jpg

This is what they look like in the hk deck pushing on the face will only damage the LCD face , these leds are soldered in series so if the first one burns out you loose the rest

Iron cross audio does these repairs as well as a couple of other forum members , depending on you dealer they may be able to swap you out a unit fairly quick which is their SOP


Sent from Motorcycle.com Free App

" wishin' my knees were in the breeze!!!"
lundboy1 is offline  
post #9 of 10 (permalink) Old 06-02-2014, 05:36 AM
Hangaround
 
Join Date: Oct 2011
Posts: 82
Quote:
Originally Posted by lundboy1 View Post
You lost an led on the circuit board

Attachment 124025

This is what they look like in the hk deck pushing on the face will only damage the LCD face , these leds are soldered in series so if the first one burns out you loose the rest

Iron cross audio does these repairs as well as a couple of other forum members , depending on you dealer they may be able to swap you out a unit fairly quick which is their SOP


Sent from Motorcycle.com Free App
LEDs on that board are in paired series. If you loose one, you just loose its pair, not all of them.
racer-x is offline  
post #10 of 10 (permalink) Old 06-02-2014, 08:20 AM
Gray Beard
 
lundboy1's Avatar
 
Join Date: Jan 2013
Location: Eastern Idaho
Posts: 1,521
Garage
See that missed info given elsewhere can always be corrected here thank you x


Sent from Motorcycle.com Free App

" wishin' my knees were in the breeze!!!"
lundboy1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
Neutral light on cruise not working and gear indicator not showing Xman247 Tools and Garages 7 08-11-2018 11:09 AM
stock stereo backlight color chris636 Lighting 3 07-06-2014 10:16 PM
How to change Radio Backlight to Blue? cpo_roadglide Lighting 3 06-25-2013 05:17 AM
HK Stereo Backlight flicker? dspencer Audio 6 04-29-2012 09:16 PM
right handlebar controls and radio not working (02 e/glide classic convert r/glide) criio1 Troubleshooting for Road Glides 1 07-16-2011 05:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome