Radio jumping functions - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-02-2014, 10:34 PM Thread Starter
Member
 
Punishher7's Avatar
 
Join Date: Apr 2013
Location: Pacific NW
Posts: 399
Radio jumping functions

So while on a 2000 mile trip to New Orleans and FL my radio started acting funny. It would randomly change stations and even jump from FM to WB to AM and so forth. It happens every few seconds and wouldn't stop. I installed cycle vision +2's 13000+ miles ago and this problem just started. I pulled apart the right side switches and found that the wire cover was slightly torn but the wires look fine though. The only thing I could narrow it down to so far was that it only does it when it is humid. I searched around and couldn't find anything. Anyone dealt with thus before? Any help would be great!

2013 RGC
Punishher7 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-02-2014, 10:48 PM
Member
 
Shemp's Avatar
 
Join Date: Dec 2011
Location: Northern Colorado
Posts: 713
Did it by chance get rained on? Some seem to have issues, mine included, if they get wet. I think it's more the head unit than switches.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 RGU Merlot/Sunglo, Daymakers, 13" Madstad dark grey windshield, LED tourpac lights, SE RT/SE AC, Bassani Road Rage 2/1 pipes, Wild 1 10" mini apes, Street Glide fascia.
Miles of twisting mountain roads with no guardrails!
Shemp is offline  
post #3 of 6 (permalink) Old 06-03-2014, 04:16 AM
Hangaround
 
Join Date: Oct 2011
Posts: 82
Quote:
Originally Posted by Punishher7 View Post
So while on a 2000 mile trip to New Orleans and FL my radio started acting funny. It would randomly change stations and even jump from FM to WB to AM and so forth. It happens every few seconds and wouldn't stop. I installed cycle vision +2's 13000+ miles ago and this problem just started. I pulled apart the right side switches and found that the wire cover was slightly torn but the wires look fine though. The only thing I could narrow it down to so far was that it only does it when it is humid. I searched around and couldn't find anything. Anyone dealt with thus before? Any help would be great!
Switch or harness. Probably not the head unit.
Test to see if the defect exists without the bike running.
If not, you have a wire hitting ground or a defective switch, either reacting to vibration
racer-x is offline  
 
post #4 of 6 (permalink) Old 06-03-2014, 06:56 AM Thread Starter
Member
 
Punishher7's Avatar
 
Join Date: Apr 2013
Location: Pacific NW
Posts: 399
I forgot to say that I can only get it to do it while rolling. Even revving in neutral won't make it do it. And yes the bike has seen its fair share of rain however when it started it was only humid out. When everything warmed up and dried out it stopped but once humid again it started acting up.

2013 RGC
Punishher7 is offline  
post #5 of 6 (permalink) Old 06-03-2014, 08:23 AM
Hangaround
 
Join Date: Jul 2012
Location: Bellmawr, NJ
Posts: 89
I had the same problem after a heavy rain - jumping from IPOD to AM or weather band but it stopped when it dried out.
wingman05 is offline  
post #6 of 6 (permalink) Old 06-03-2014, 08:51 AM Thread Starter
Member
 
Punishher7's Avatar
 
Join Date: Apr 2013
Location: Pacific NW
Posts: 399
Quote:
Originally Posted by wingman05 View Post
I had the same problem after a heavy rain - jumping from IPOD to AM or weather band but it stopped when it dried out.

The frustrating thing for me was it started before it even started to rain. It was just early morning and humid. And it had been months prior that it was in any rain. I hate throwing parts at it but I'm thinking about just replacing the right side switches to eliminate the cheapest possibility first. I'm having trouble finding a PN. Anyone have it?

2013 RGC
Punishher7 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jumping back into the MadStad club - the review! Methos1979 Windshields 12 07-08-2015 12:45 PM
Jumping back into the MadStad club Methos1979 Windshields 11 06-26-2015 08:28 AM
Jumping in the Shark pond tOSUSteve New Members Welcome Area 59 05-06-2013 01:22 PM
Finally jumping into a thread SharknoseScott New Members Welcome Area 33 05-07-2012 05:23 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome