Kenwood - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-16-2014, 10:55 PM Thread Starter
Grey beard
 
pipe3214's Avatar
 
Join Date: Feb 2014
Location: Bridger Montana
Posts: 985
Kenwood

Anyone using a kenwood
KMR-M308BT. If so what do ya think about it and how good is it? I also got the adapter for thumb controls and is now sopose to be plug and play with Sirius XM and bluetooth.


Sent from Motorcycle.com Free App
pipe3214 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-18-2014, 10:01 PM
Hangaround
 
otis2013's Avatar
 
Join Date: Oct 2012
Location: Bend Oregon, Mountains rivers and 300 days of sunshine
Posts: 117
I'm looking at the Kenwood and the JVC marine media receiver on crutchfield for $109 ea. Side by side there is no difference. Talk with the guys at hawgwired and I'm looking at spending and additiional $250 for their instal kit. I'm also loking at their remote amp tuner....trying to tune the freq and gain on my amp is a real PITA...have to remove the fairing to get to the amp. Good luck on your upgrade!

2013 RG, Dragos True Duals with Dragula mufflers, PV tuner, big Sucker, Vented Lowers, 19"boards and stuff....
otis2013 is offline  
post #3 of 7 (permalink) Old 06-18-2014, 10:23 PM Thread Starter
Grey beard
 
pipe3214's Avatar
 
Join Date: Feb 2014
Location: Bridger Montana
Posts: 985
I bought the mating Kenwood with install kit from 702 motoring out a Vegas. They pre wired it for me. Works great and all functions work with the thumb controls. Only thing I had to do was cut the pink and white volume wire from handle bar and ground it. I paid $308 delivered and complete. Even got a front cover for it that I'll never use. Jmo ya cNt ever go wrong with kenwood or alpine :-)


Sent from Motorcycle.com Free App
pipe3214 is offline  
 
post #4 of 7 (permalink) Old 06-18-2014, 10:28 PM Thread Starter
Grey beard
 
pipe3214's Avatar
 
Join Date: Feb 2014
Location: Bridger Montana
Posts: 985
Oops. Mounting and install kit.


Sent from Motorcycle.com Free App
pipe3214 is offline  
post #5 of 7 (permalink) Old 06-19-2014, 11:18 AM
Grey beard
 
StephenRG's Avatar
 
Join Date: Dec 2011
Location: Stony Plain, AB, Canada
Posts: 946
pipe3214,

I just ordered a mounting and thumb control kit from 702 and was going to post and see if anyone had used them or if there were any issues.

I was a bit leery about doing any hard wiring as I'd seen with other kits. Seems you had no issues?

I'm matching it with a Kenwood KMR 355U receiver and J & B speakers. Looking forward to hearing the new sound.

Receiver and kit are costing me about $250. Called the dealership, they wanted $1,372.96 for a new receiver with half the functionality.

'10 RG "Black Betty"
HQ 103"
HQ 575 cam
SEPRT
16" TRSSC Cee Bailey Windshield
Sancho's Wings
Mustang Seat
J & M Speakers
Drago's True Duals
Apparently not as black as I thought...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
StephenRG is offline  
post #6 of 7 (permalink) Old 06-24-2014, 01:59 PM
Newbie
 
BLammers's Avatar
 
Join Date: Jan 2013
Location: Missouri, USA
Posts: 12
I just finished installing a Kenwood marine unit with install kit and thumb control unit from 702. I did all of the wire splicing myself which was simple. You just match color for color, solder and tape, cut the pink and white wire and attach to black ground wire, then turn on, hold the volume up switch on the left handlebar control and the auto program is set.

Much better than the stock HK unit that harley uses and is bluetooth so no more wires for my ipod and phone. I have this hooked to a pair of J&M speakers with J&M amp and the sound is wonderful.

2013 Big Blue Pearl
HD installed stage IV upgrade
Vance & Hines 2 into 1
BLammers is offline  
post #7 of 7 (permalink) Old 06-24-2014, 04:59 PM Thread Starter
Grey beard
 
pipe3214's Avatar
 
Join Date: Feb 2014
Location: Bridger Montana
Posts: 985
Found out my problem wasn't even remotely associated with the stereo swap. Was the throttle by wire the dealership installed 9 months ago rubbed a hole in. The dealership is fixing it for free :>



Sent from Motorcycle.com Free App
pipe3214 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New install, Kenwood / JL / Kicker, take a look Husky13 Audio 42 08-05-2015 09:08 PM
Trouble with install of kenwood headunit and kenwood amp. Shuts off... Mikie Audio 0 08-03-2015 11:24 AM
Kenwood KMU-100U media receiver Slammed Audio 2 02-10-2014 11:22 AM
help!! I need to make hog wired hsa150 with kenwood rxfox3 Audio 0 06-08-2012 09:22 PM
Anybody running a Kenwood KDC-BT948HD? sprint12 Audio 9 05-07-2011 10:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome