Possible start of a problem - stock head unit? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 06-30-2014, 07:55 AM Thread Starter
Hangaround
 
toogood8p's Avatar
 
Join Date: Dec 2012
Location: North Jersey
Posts: 195
Possible start of a problem - stock head unit?

So yesterday I was riding and listening to the cd player on the stock head unit on my 13 fltrx. The entire radio would just randomly reset. Happened about 5 or 6 times throughout the day, but not with any hard bumps or rough road surfaces.

Any ideas? Is this an indicator of something starting to go wrong?



Sent from Motorcycle.com Free App

Bear, Prez, Kindred MC
13 FLTRX - Candy Orange - Daymakers, Custom Dynamics - LED turn signals, Kuryakyn Scythe mirrors, Iron Aces bracket, X-grip, floor board extensions, custom sundowner seat, black KW 8", PCV, auto tune, Stage 1 AC, Drago H-pipe, 4" Dragula mufflers.
toogood8p is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-30-2014, 08:48 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,059
Garage
Seems like after that tsunami in Japan in 2010, these radios started having all kind of problems.
Take it back for a warranty replacement.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
post #3 of 11 (permalink) Old 06-30-2014, 11:25 AM
Member
 
Redbeard77's Avatar
 
Join Date: Jul 2013
Location: Northwest Louisiana
Posts: 593
That's what warranty is for. I had mine replaced on my '13 a couple of months ago because it wouldn't respond to any of the buttons or bar controls.

Happiness is a warm motorcycle.
Redbeard77 is offline  
 
post #4 of 11 (permalink) Old 06-30-2014, 11:30 AM
Member
 
usraptor's Avatar
 
Join Date: Mar 2014
Location: Utah
Posts: 372
I agree. I seem to remember reading that this is not an un-common problem with these radios and several owners have had to have them replaced under warranty.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2013 RGU, Vance and Hines Prop pipe and Fuel pak, SE AC, Wild One Chubby bars, Mean City Cycle Seat, Bright Ass tail light and LED turn signals, plus lots of chrome billet parts!
usraptor is offline  
post #5 of 11 (permalink) Old 07-03-2014, 01:44 PM Thread Starter
Hangaround
 
toogood8p's Avatar
 
Join Date: Dec 2012
Location: North Jersey
Posts: 195
I scheduled an appointment with the stealership. They said they will remove the radio and send it out for radio. If they find nothing wrong, I have to pay $50

Sent from Motorcycle.com Free App

Bear, Prez, Kindred MC
13 FLTRX - Candy Orange - Daymakers, Custom Dynamics - LED turn signals, Kuryakyn Scythe mirrors, Iron Aces bracket, X-grip, floor board extensions, custom sundowner seat, black KW 8", PCV, auto tune, Stage 1 AC, Drago H-pipe, 4" Dragula mufflers.
toogood8p is offline  
post #6 of 11 (permalink) Old 07-04-2014, 11:18 PM
Member
 
glide1's Avatar
 
Join Date: Oct 2012
Location: Daytona Beach Fl.
Posts: 336
If they find nothing wrong with the radio, You have to pay 50 Bucks?? Thats incredible!! Do yourself a big favor and get an aftermarket Unit in there and tell them to Ram that Thing,,,You will "NOT" regret it.
glide1 is offline  
post #7 of 11 (permalink) Old 07-05-2014, 05:10 AM
Hangaround
 
Join Date: Oct 2011
Posts: 82
Quote:
Originally Posted by glide1 View Post
If they find nothing wrong with the radio, You have to pay 50 Bucks?? Thats incredible!! Do yourself a big favor and get an aftermarket Unit in there and tell them to Ram that Thing,,,You will "NOT" regret it.
You're assuming it's the radio...
racer-x is offline  
post #8 of 11 (permalink) Old 07-05-2014, 08:11 AM
Life Member
 
hook's Avatar
 
Join Date: Jan 2014
Location: PNW
Posts: 1,582
That's a warranty issue. $50 is BS.

I had a problem with all four speakers cutting in and out last week on my 2011 RGU with stock audio. Power stayed on, but audio from all inputs (AM, FM, XM, etc.) was intermittent. I pulled the fairing and moved all the wiring around while the radio was on. Of course it was working properly while I was trying to diagnose the problem. Then I pulled and reconnected every wire connecter up front. Put it all back together, and all is well now. I suspect there was a bad connection in one of the wire harness connecters.

My problem was audio after the preamp. Sounds like you have a problem in the amp or more likely, power going to the amp or tuner. I would check all the connecters, including the two large ones at the back of the radio.

2011 RGU
hook is offline  
post #9 of 11 (permalink) Old 07-05-2014, 11:14 PM Thread Starter
Hangaround
 
toogood8p's Avatar
 
Join Date: Dec 2012
Location: North Jersey
Posts: 195
I will bring it in... If they start blowing smoke up my butt... I will pay the $50 and sell the replacement radio on eBay, then buy a new radio from the 21st century that has Bluetooth

Sent from Motorcycle.com Free App

Bear, Prez, Kindred MC
13 FLTRX - Candy Orange - Daymakers, Custom Dynamics - LED turn signals, Kuryakyn Scythe mirrors, Iron Aces bracket, X-grip, floor board extensions, custom sundowner seat, black KW 8", PCV, auto tune, Stage 1 AC, Drago H-pipe, 4" Dragula mufflers.
toogood8p is offline  
post #10 of 11 (permalink) Old 07-06-2014, 09:19 AM
Grey beard
 
RGUrider's Avatar
 
Join Date: Aug 2011
Location: Murfreesboro TN by way of Freeburg IL, Naples Italy, Oscoda MI, Ramstein AB GE, and Dover PA
Posts: 875
Garage
DO NOT PAY THE $50. Mine the display would disappear randomly, every time I took it in it worked fine. Give you the short version, dealer was telling me the same thing, take it out send it to HK, 2-3 weeks. I said fine, put the fairing back on and give me the bike, they said they would have to charge me labor for 2nd fairing removal and install when they get new unit. I took the bike as is, wrote MOCO when they asked me for feedback on my experience. Told'em it sucked. dealer Mgr calls says bring the bike in we'll get you a new unit, they pulled HU to get serial number, put it back together with old HU, called 2 weeks later saying new (refurbed) unit is in, took bike in and they replaced it. Detailed bike. No charge. Bottom line these HUs are known to have these issuess, I blame MOCO for buying the crap and reselling and hold them accountable for it under warranty, don't care if mech can get it to do it while they have it, it still does it while I (the customer) have it. Day after I got bike back, I iyanked the refurbed unit and put in aftermarket. refurned unit still in a box in my shop.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 RGU/Black - Rinehart True Duals, SERT, K&N Filter, RF PBR300X2,
Hawgwired ZX's, Pioneer G1644R, J&M Hidden Antenna, Sony HU
RGUrider is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible ABS ECU Problem ptdog Troubleshooting for Road Glides 4 09-05-2015 10:36 AM
Problem Installing New Head Unit RedDogNC Audio 9 02-13-2014 08:32 PM
WTB Stock Head Unit From 99-05 RG adrenilinecrash Wanted! (Buy or Trade) 0 04-09-2012 10:48 PM
J&P Possible Problem DOOFUS Web Sites We Like! 8 03-02-2012 11:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome