Stereo Changes Mode Automatically - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-30-2014, 01:15 PM Thread Starter
Newbie
 
Join Date: May 2012
Location: San Antonio, Texas
Posts: 5
Stereo Changes Mode Automatically

I apologize if this has been addressed elsewhere, If so, I could not find it.

I have a 2012 FLTRX with a stock stereo unit. The unit has been working flawlessly until recently when the stereo automatically changes mode (CD to radio - radio to aux) in the middle of listening to the radio/CD. It does not seem to have any pattern but is happening more and more. I googled this issue and have found lots of examples of this happening but NOTHING on the fix. My only thought now is to send the radio off to Iron Cross Radio. Does anyone have any ideas?

I also ran the radio diagnostics and found no error codes. I also have the latest version of firmware.

Thanks.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Jeff York

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jeffman is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-30-2014, 02:20 PM
Grey beard
 
TLWiz's Avatar
 
Join Date: Oct 2011
Location: Bluegrass Region
Posts: 1,270
Warranty? Does it only happen when playing a CD? If so, is it one particular CD? If it is Justin Beiber then your radio is just trying to help.

I have seen issues with CDs that I have burned in my computer, even CDs without Beiber "music".


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by TLWiz; 06-30-2014 at 03:21 PM.
TLWiz is offline  
post #3 of 8 (permalink) Old 06-30-2014, 02:27 PM
Member
 
Lucky D's Avatar
 
Join Date: Feb 2013
Location: Fort Worth / Dallas TX MetroMess
Posts: 692
Quote:
Originally Posted by TLWiz View Post
Warranty? Does it only happen when playing a CD? If so, is it one particular CD? If it is Justin Beiber then your radio is just trying to help.
LOL!
Good one!!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

... Chrome?? We donneeedno stiinnkinng chrome.
Lucky D is offline  
 
post #4 of 8 (permalink) Old 06-30-2014, 02:29 PM
PGR
GONE BUT NOT FORGOTTEN
 
PGR's Avatar
 
Join Date: Aug 2010
Location: Western Illinois
Posts: 2,338
Garage
Could also be the handlebar switch that doesn't like your Bieber music. Take a rubber mallet and tap the top of the switch housing and see if it changes modes.








......................
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ron..........................


........2011 Cool Blue Pearl FLTRX........
.............RoboGlide .............


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by PGR; 06-30-2014 at 02:40 PM. Reason: BIEBER SUCKS
PGR is offline  
post #5 of 8 (permalink) Old 06-30-2014, 07:37 PM
Hangaround
 
Join Date: Dec 2010
Posts: 72
Jeffman, You mention that your radio switches to aux mode. Usually you can only access aux when something is plugged into the front input. (Unless you modified it internally) When my radio started doing the same thing, unplugging the aux input solved the problem. Good luck.
WEBHNTN is offline  
post #6 of 8 (permalink) Old 06-30-2014, 07:50 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,044
Garage
Quote:
Originally Posted by PGR View Post
Could also be the handlebar switch that doesn't like your Bieber music. Take a rubber mallet and tap the top of the switch housing and see if it changes modes.
If its beiber music, use a sledge hammer.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #7 of 8 (permalink) Old 06-30-2014, 08:37 PM
Member
 
Punishher7's Avatar
 
Join Date: Apr 2013
Location: Pacific NW
Posts: 399
My 13 FLTRX does the exact same thing and it drives me nuts. I already had the dealer swap out the toggle switch with neg results. I'm turning it in tomorrow so they can dig deeper to diagnose. My biggest concern right now is time. My bike ships to HI on the 10th... I really hope it's a quick fix.

2013 RGC
Punishher7 is offline  
post #8 of 8 (permalink) Old 07-02-2014, 03:23 PM
Member
 
Punishher7's Avatar
 
Join Date: Apr 2013
Location: Pacific NW
Posts: 399
Update. I received a phone call from the dealer telling me my bike is fixed. He said there were two damaged wires in the wiring harness. Warranty picked it up as there was no way I could have caused it. I hope this helps you get yours fixed. I know it was driving me nuts!

2013 RGC
Punishher7 is offline  
Reply

Tags
mode , stereo

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
changes brought changes. pauld Troubleshooting for Road Glides 3 05-11-2016 08:44 PM
Right turn signal comes on automatically ROADGLIDE-JUAN Troubleshooting for Road Glides 1 04-05-2016 07:51 PM
Wheel changes = ride changes eldridgetom Wheels and Tires 3 09-22-2013 11:06 AM
Parade mode (EITMS) Big_gary *General Road Glide Discussions/Pictures 16 05-24-2012 01:31 PM
Another parade mode question x52gnr *General Road Glide Discussions/Pictures 6 05-13-2011 06:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome