Electric antenna issues - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-20-2014, 08:13 AM Thread Starter
Newbie
 
Join Date: Jan 2013
Posts: 41
Electric antenna issues

Installed the HD electric antenna to clean up the look. Problem seems to be radio reception and sound quality is down the tubes! This is a CVO RG, and I already sold the shorty antenna that came on the bike or I would be putting it back on. Is there a way to make the antennas work better, or should I be buying a new stock system?
bowtech40 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-20-2014, 01:33 PM
Hangaround
 
Join Date: Sep 2012
Location: Saint Peters, MO
Posts: 138
I have this antenna installed in my CVO RG. It works pretty well.
inferno1976 is offline  
post #3 of 7 (permalink) Old 07-20-2014, 02:07 PM
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
May sound like a dumb question, but when you installed it did you make sure the red LED light, on the center part of antenna, came on when you turned the radio on? It could be a power or ground issue.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
 
post #4 of 7 (permalink) Old 07-20-2014, 03:09 PM
Hangaround
 
Join Date: Dec 2012
Location: Louisiana
Posts: 192
Depends on the area you live in mine worked great in more metropolitan areas but in outlying rural areas its performance was abysmal. There has been many post about hidden antennas with mixed results sorry I don't know how to increase performance or range.
cbumdumb is offline  
post #5 of 7 (permalink) Old 07-20-2014, 07:15 PM Thread Starter
Newbie
 
Join Date: Jan 2013
Posts: 41
The light does comes on, it is more like what was stated in the last post. It works ok in the metro and gets worse the farther you get out. The stock antenna was not this way.
bowtech40 is offline  
post #6 of 7 (permalink) Old 07-20-2014, 07:26 PM
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
My bad.. i did not read it thoroughly. I have the antenna also. I really use the radio but it clearly pick up stations whenever I turn it on. Double check how you routed the antenna wire on in the inner fairing wall.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
post #7 of 7 (permalink) Old 07-21-2014, 12:26 AM
Member
 
Lucky D's Avatar
 
Join Date: Feb 2013
Location: Fort Worth / Dallas TX MetroMess
Posts: 692
Botech,
I have the same HD antenna and it works good around town but doesn't have much range. Loose strong stations pretty quick when traveling.
I had a 'Tune Trapper' internal antenna on my last bike and it worked WAY better than the HD one plus it doesn't require any external power. Here's a link to one I found on eBay
http://www.ebay.com/itm/like/250897098433?lpid=82
Think I got mine from Dennis Kirk.
I'll probably swap mine out one of these days ... Just haven't gotten around to it..


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

... Chrome?? We donneeedno stiinnkinng chrome.
Lucky D is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Remove Rear Antenna- Add Hidden Antenna- Hurt Reception? scottrgs Audio 4 09-06-2017 10:34 AM
Electric Windshield Beachjeep *General Road Glide Discussions/Pictures 40 11-17-2011 06:09 PM
Wiring for your Electric garage door opener - DreamRider General Off-Topic Discussions 3 03-27-2011 05:53 PM
2010 electric glide stock seat GLYDDN11 Seating: seats, backrests 2 02-18-2011 09:58 AM
Electric Bike DreamRider *General Road Glide Discussions/Pictures 5 10-19-2010 04:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome