Anyone using the Jensen HD1BT audio? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 29 (permalink) Old 08-08-2014, 09:35 AM Thread Starter
Newbie
 
jprider4life's Avatar
 
Join Date: Feb 2012
Location: Elizabeth NJ
Posts: 47
Anyone using the Jensen HD1BT audio?

I'm thinking of upgrading my stock 04 radio, came across the Jensen hd1bt radio, looks and seems good for a replacement but would like more info on it and see if anyone has or knows anyone that's using one.
jprider4life is offline  
Sponsored Links
Advertisement
 
post #2 of 29 (permalink) Old 08-08-2014, 12:53 PM
Hangaround
 
Join Date: Aug 2014
Posts: 82
I spend a lot of time on another forum, that one has a couple of guys that have them and they like them a lot. Only complaint I heard was the RCA Pre-Amp outs are a little "fragile". Otherwise they all seem happy. Its not actually made by Jensen, its made by a company that makes radios for tractors and heavy equipment, its supposedly built like a tank.
usg436o likes this.
Kave Dweller is offline  
post #3 of 29 (permalink) Old 08-08-2014, 04:13 PM
Hangaround
 
eme56's Avatar
 
Join Date: Aug 2012
Location: St. Louis, MO
Posts: 137
I just installed this week. My stock radio quit. A circuit board split. So I ordered the Jensen and the auxiliary adapter. The installation was easy. It does bolt right in. The only catch was I had to do a little wire rerouting. The plug is on the opposite side of the radio, so it took a little time to make sure everything reached and wasn't stretched. The handle bar controls work fine. The unit sounds great as well. I have a Hogtunes 140 watt amp, 5x7 speakers, and tweeter pod. I did have to turn off the "Loudness" setting. With it on, the sound distorted just above 1/2 volume. Off, I can almost full volume (38 out of 40) with high quality (320) MP3 files off a USB drive. I couldn't go past 12 bars without distortion on the old Radio Sound unit on a clean CD file (CDA not MP3). I cut a 1.5" hole is the back of the left glove box and mounted the auxiliary connector there. It is also waterproof with a rubber front cover. That gives me Aux and USB inputs to the unit (they are rear mounted). It will be nice to have control of the flash drive from the bars instead of using an MP3 player through the front panel input on the old radio. I also has a remote amp turn on, so my amp won't be on while the bike is starting or sitting with ignition or accessory on.

I haven't had time yet and it's been raining, so I can't give you an "on the road review" yet. The screen is bright and is adjustable for brightness and contrast, so it should be ok in sunlight. I can tell you my neighbor thought is sounded great. I was in my garage which is in my basement with the garage door down and he was in his front yard trimming bushes. He was stunned when I told him that was my bike radio.

I did snap a couple pics before I finished up the wiring and put the fairing back on.

I did look at the Hawg Wired control interface and the V-Twin Audio mounting kit w/waterproof cover, but then I was at around $300 before even looking at an Alpine CDE-HD149BT radio.

If you want, I can give a better report and pics from the dash side after this weekend, if it ever quits raining.
Attached Images
File Type: jpg 188.jpg (91.6 KB, 311 views)
File Type: jpg 190.jpg (83.6 KB, 295 views)

2005 FLTRI Black Cherry, 95" Big Bore, Thundermax w/Auto Tune, V&H Dresser Duals w/Klock Werks SS, Andrews 26 Cams, SE Stage 1 intake, SE OD/6 Speed, Wards FCS cooling fans, Krome Werks Stretch Heritage +2 bars, Progressive Monotubes, 444's, & Touring Link, Michelin Commander II's, 14.5" Madstad, Lowers with Classic Motorcycle Vents, detachable King Tour Pack, Daymakers
eme56 is offline  
 
post #4 of 29 (permalink) Old 08-08-2014, 08:56 PM
Newbie
 
Join Date: Sep 2011
Location: Arthur Ontario Canada
Posts: 16
Love it
Attached Images
File Type: jpg radio.jpg (92.9 KB, 346 views)
Hayabusa1967 is offline  
post #5 of 29 (permalink) Old 08-08-2014, 10:58 PM
Member
 
glide1's Avatar
 
Join Date: Oct 2012
Location: Daytona Beach Fl.
Posts: 336
Quote:
Originally Posted by Hayabusa1967 View Post
Love it
Hey busa, Where did you get that "Road Glide" Cover thingy for your gas Tank Cowling? I like it..
glide1 is offline  
post #6 of 29 (permalink) Old 08-09-2014, 06:33 AM
Hangaround
 
Join Date: Oct 2011
Posts: 82
We had a customer bring one by and asked us to install.
We were not impressed.
Features were fine, but audio quality was lacking.
No AVC...which was a bit misleading because the manual shows the AVC circuit in the harness.
Week later he was back...lost right channel...bad RCA connector.
He took that opportunity to return it and install a Sony from Biketronics...much happier.
racer-x is offline  
post #7 of 29 (permalink) Old 08-09-2014, 06:49 AM
Member
 
piggs's Avatar
 
Join Date: Apr 2013
Location: Hobe Sound, Florida
Posts: 520
i too put one in last week. relatively easy install. upgraded the speakers and amped it too. BUT.. the radio didn't fit the stock hole 'exactly' so I had to fill gaps with sillycone (black).. 2 days later the volume control (at the grip) stopped working and also 2 days later (probably related) when the left turn signal is on, it disturbs the sound with static, on off, on off..
and the red face light isn't working either.

it isn't easy to see whats on the display from riding position..

will take it apart again rewire and change handle bars (again) at the same time. so my opinion is not yet in.. when it worked (for 2 days) it sounded good but haven't had it out at 80mphs to draw a solid conclusion..

the main reasons I bought it was : hand controls like stock (well almost) and the Sirius feature and did put in the stuff so it will work but have not subscribed yet and the USB input feature (right glove box)..

OH.. and the volume does not increase and decrease as one goes faster and slower like the stock unit.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Piggs, SemperFi
2013 FLTRX Denim

Last edited by piggs; 08-09-2014 at 07:07 AM.
piggs is offline  
post #8 of 29 (permalink) Old 08-09-2014, 03:00 PM
Hangaround
 
AtomiCapricorn's Avatar
 
Join Date: Jan 2014
Location: SCV, SoCal
Posts: 177
I just put one in as well. Idiotically simple to install. Bluetooth and iPod controls work well, and these are the two reasons I installed this head unit (HK iPod interface started acting hinky). No road test yet because I'm also installing a Hawg Wired CS300, 14" apes, and a hydraulic clutch. Hoping to have it done by tomorrow.

Oh yeah, the Jensen USB/Aux interface plug is also incredibly easy to install in either glovebox with a 1.5" hole saw. The leads are really, really long. You could damn near install it in a saddlebag.

Seriously, I should have waited another month or so to dig in to all of this. I'm doing it all in my gravel driveway (no garage; see sig pic) in hot ass Acton/Agua Dulce, California. It's 95 out right now. Yeesh. Rant over.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'13 FLTRX, BBP, Vivid Black painted inner fairing, 9" Windsplitter, 14" W1 Chubbys, Get-A-Grips, Daymakers, ABS, Cruise, Security, 4 Speaker HW/Jensen HD1BT System, Fuel Moto Jackpot Header/Nightstick Exhaust, Powervision, Fueling 543 cams (95HP/104TQ). Yay, me!!
AtomiCapricorn is offline  
post #9 of 29 (permalink) Old 08-11-2014, 09:44 AM
Hangaround
 
Join Date: Aug 2014
Posts: 82
Quote:
Originally Posted by racer-x View Post
We had a customer bring one by and asked us to install.
We were not impressed.
Features were fine, but audio quality was lacking.
No AVC...which was a bit misleading because the manual shows the AVC circuit in the harness.
Week later he was back...lost right channel...bad RCA connector.
He took that opportunity to return it and install a Sony from Biketronics...much happier.
How bad was the audio quality lacking? is it worse then the HK? I was thinking about it just for the Pre-Amp outs, as long as that signal is fairly clean, I think I'd be fairly happy with the other features (Bluetooth and skipping Pandora songs is my real goal).
Kave Dweller is offline  
post #10 of 29 (permalink) Old 08-11-2014, 11:59 AM
Prospect
 
Eshaw301's Avatar
 
Join Date: Oct 2011
Location: ATL G.A. by way of Wash. D.C.
Posts: 264
Quote:
Originally Posted by Kave Dweller View Post
How bad was the audio quality lacking? is it worse then the HK? I was thinking about it just for the Pre-Amp outs, as long as that signal is fairly clean, I think I'd be fairly happy with the other features (Bluetooth and skipping Pandora songs is my real goal).
You'd be better off and a whole lot cheaper sending it to Iron Cross Audio. Google em....

"DUDE!...Your exhaust is making the ground shake!" Circa March 2014, Born Losers MC, Atlanta.
Eshaw301 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jensen HD1BT, can you run google maps through it chevjerico Audio 1 01-06-2017 06:59 AM
Thundermax autotune, Jensen HD1BT Sirius XM tuner, Edge Cut latches, docking station daryl_db Parts for Sale 6 03-18-2015 08:56 AM
Jensen HD1BT won't hold clock setting and other issues? chevjerico Audio 10 02-16-2015 07:02 AM
Can Google maps or mapquest play through a Jensen HD1BT? chevjerico Audio 0 01-31-2015 12:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome