Hertz 165XL Fairing Install Trouble - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-23-2015, 11:00 PM Thread Starter
Hangaround
 
Join Date: Apr 2013
Location: Portland, OR
Posts: 98
Hertz 165XL Fairing Install Trouble

I just finished installing a set of the Hertz 165XL speakers I bought from a fellow forum member here. I've had the fairing on and off several times now, so generally this is no big deal; but, I'm having a bugger of a time with these new speakers.

I know others have installed these speakers successfully. I'm reusing 6.5" adapters I had with thinner speakers that are about 1 1/8" deep; are folks using something thinner maybe ?

Think I'll knock off for tonight and see what wisdom comes in; try again tomorrow.

Thanks.
sifugumba is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-24-2015, 07:09 AM
Life Member
 
neverdone's Avatar
 
Join Date: May 2013
Location: Marengo Ohio
Posts: 1,517
I had a hell of a time getting my faring back on when I switched to hertz. Just keep turning the adapters. It will fit. For mine I ended up with the thickest part of the adapter on top.
neverdone is offline  
post #3 of 6 (permalink) Old 03-24-2015, 08:42 AM
Grey beard
 
mmfinn's Avatar
 
Join Date: May 2013
Location: St. Louis, MO
Posts: 1,420
Yes they will fit, that is what I used. Just keep trying they will fit. Probably need to change the orientation.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2013 RGC Candy Orange, 2005 Deuce (Traded), 1991 Sportster (sold),1948 Pan Head Hard Tail (sold and wish I didn't),1971 Honda 500 Four (original owner), Too many more to mention
mmfinn is offline  
 
post #4 of 6 (permalink) Old 03-24-2015, 09:11 AM Thread Starter
Hangaround
 
Join Date: Apr 2013
Location: Portland, OR
Posts: 98
Thanks guys. I'll try that after work this evening.
sifugumba is offline  
post #5 of 6 (permalink) Old 03-26-2015, 04:48 PM
Life Member
 
neverdone's Avatar
 
Join Date: May 2013
Location: Marengo Ohio
Posts: 1,517
Well?
neverdone is offline  
post #6 of 6 (permalink) Old 03-26-2015, 10:32 PM Thread Starter
Hangaround
 
Join Date: Apr 2013
Location: Portland, OR
Posts: 98
Sorry. Yes that worked. I had the adapters rotated outward, which worked on the thinner Focal's I had. I tried down; didn't work. All the way inward was the ticket. I really thank you guys. Obvious though it was it might not have occurred to me.

So I replaced my $130 Focals with the Hertz XL's. It sounds night and day better (base, clarity, volume) even though I'm still using the PBR300x4 I had. That's the next thing to be upgraded; just looking for a good deal on a Biketronics or Hawg Wired amp.

Now I'm struggling that POS Kuryakyn windshield trim; but, that's a story for a different forum area

Last edited by sifugumba; 03-26-2015 at 10:37 PM.
sifugumba is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble putting fairing back on with new speakers. garbage cannon Audio 0 06-04-2018 04:22 PM
Trouble with install of kenwood headunit and kenwood amp. Shuts off... Mikie Audio 0 08-03-2015 11:24 AM
Hertz HSK 165XL NEW RichieRich Parts for Sale 2 12-18-2014 02:58 PM
New install.. Hertz/Rockford OHGlider Audio 10 07-27-2013 07:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome