HELP -- Why does my audio setup suck? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 05-01-2015, 03:51 PM Thread Starter
Newbie
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 7
HELP -- Why does my audio setup suck?

Installed J&M Rockers 6.65 in the fairing & Hogtunes 200W 4 channel amp in my 2015 RG.
It is louder but my speakers get distorted when I turn it up 1/2 way.

Spent a good amount of money & I am pretty disappointed at this point..

I plan to add speaker lids in the not too distant future, I hope that helps...

Any comments or advice would be very much appreciated.
Rycap is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 05-01-2015, 03:55 PM
Life Member
 
09Sharknose's Avatar
 
Join Date: May 2011
Location: Fort Bragg, NC
Posts: 2,098
So are the j&m speakers the only set of speakers you have installed? Jmjohn is on the forum and may be able to help you out. It may just be a matter of flashing your radio or tuning your amp. Good luck.

At any rate, there are some serious audio dudes on this forum and eventually they'll nail it down for you.


Sent from Motorcycle.com Free App
09Sharknose is offline  
post #3 of 16 (permalink) Old 05-01-2015, 04:10 PM Thread Starter
Newbie
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 7
Yes, the J&M's are the only speakers that are in the bike currently.
Rycap is offline  
 
post #4 of 16 (permalink) Old 05-01-2015, 04:37 PM
Grey beard
 
pipe3214's Avatar
 
Join Date: Feb 2014
Location: Bridger Montana
Posts: 985
My J&M sound great. I can't complain at all. They will help you out and your gonna be happy once its dialed in :-)


Sent from Motorcycle.com Free App
pipe3214 is offline  
post #5 of 16 (permalink) Old 05-01-2015, 04:55 PM
Hangaround
 
Banshee451's Avatar
 
Join Date: Dec 2014
Location: San Diego, CA
Posts: 67
Flash the head unit - that should solve the distortion issue. The flash settings are in a sticky for this topic.
Banshee451 is offline  
post #6 of 16 (permalink) Old 05-01-2015, 05:32 PM Thread Starter
Newbie
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 7
There are two separate Flash posts.
I have the Hogtunes Amp.
After reading it appears I would follow post #1 with 594 views - correct?
Rycap is offline  
post #7 of 16 (permalink) Old 05-01-2015, 06:23 PM
Hangaround
 
Banshee451's Avatar
 
Join Date: Dec 2014
Location: San Diego, CA
Posts: 67
Quote:
Originally Posted by Rycap View Post
There are two separate Flash posts.
I have the Hogtunes Amp.
After reading it appears I would follow post #1 with 594 views - correct?
Yes, that should make a big difference. I installed a PBR300 amp and Infiniti Kappa speakers. All was good but when cranking it up I had a lot of distortion. I printed out the post and the images, taking it with me to the dealer to show exactly what is needed. After the flash, I can crank it to a point it's hurting my ears without distortion.

Last edited by Banshee451; 05-01-2015 at 06:30 PM.
Banshee451 is offline  
post #8 of 16 (permalink) Old 05-01-2015, 06:34 PM
Grey beard
 
pipe3214's Avatar
 
Join Date: Feb 2014
Location: Bridger Montana
Posts: 985
I just took off my outer fairing and cut the pink and white wire and grounded it out and now my bluetooth and volume control both work. 702 motoring in Vegas set me up last summer and I'm more then happy with there products and service:-)


Sent from Motorcycle.com Free App
pipe3214 is offline  
post #9 of 16 (permalink) Old 05-01-2015, 06:59 PM Thread Starter
Newbie
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 7
Thank you. Will give it a shot & post an update once flashed.
Rycap is offline  
post #10 of 16 (permalink) Old 05-13-2015, 02:59 PM Thread Starter
Newbie
 
Join Date: Sep 2013
Location: Minneapolis
Posts: 7
Got the radio flashed & it is much better - Thank you.
For the money I spent it still doesn't sound as good as I think it should..
Hopefully after the lid speakers go in, it will sound that much better.
Rycap is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How Bad Does This Suck? dvanlue General Off-Topic Discussions 24 07-12-2014 12:44 PM
I need help with my audio setup jeffreyjjc Audio 2 04-28-2013 10:57 PM
Why? Why? Why? CMS *General Road Glide Discussions/Pictures 16 04-11-2011 01:46 PM
Why does the 2011 RG deserve there own section ironmark *General Road Glide Discussions/Pictures 2 02-01-2011 11:37 PM
Why does HD have to use Chinese Parts on an American Motorcycle? BillyBob *General Road Glide Discussions/Pictures 41 01-27-2011 10:07 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome