I cant figure out all the sound complaints?? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-08-2015, 03:25 PM Thread Starter
Prospect
 
Join Date: Jul 2013
Location: Derry NH
Posts: 253
Garage
I cant figure out all the sound complaints??

Ive seen so many posts on here about how crappy the audio is with the stock shield and stock deck etc..etc.. When I got my 15, I wanted no issues at all so I immediately pulled the stock speakers and replaced them with Focal speakers and a Focal amp. This past Saturday night, I rode into work at in the middle of the night for 35-40 miles on the highway. I had time to do some testing.

My results? At 50 MPH, I can CLEARLY hear my stereo at a bit less than half volume with a full face helmet on. At 70 MPH, I kicked the volume up 2 clicks and again, clear as spring water. At 95MPH (I was testing ) I was at 3/4 volume with no issues at all.

I don't understand what I'm missing here? I have the stock shield and deck. Am I looking for less quality sound than anyone else? I don't think I am.

I'm really not looking to start a battle with anyone and maybe I just got lucky but please someone tell me what is so bad about this bike's audio system?

Never marry an ugly woman, it just takes the energy right out of you.
Major99 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-08-2015, 04:22 PM
Newbie
 
hdbaggerdave's Avatar
 
Join Date: May 2015
Location: Syracuse NY
Posts: 32
I think the problem is with the totally stock speakers and amp, cause mine sucks. If you don't mind me asking where you got the amp and speakers and how much? Was the install difficult? Thanks in advance.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Free your mind and your ass will follow
hdbaggerdave is offline  
post #3 of 6 (permalink) Old 06-08-2015, 06:45 PM
Life Member
 
09Sharknose's Avatar
 
Join Date: May 2011
Location: Fort Bragg, NC
Posts: 2,098
Quote:
Originally Posted by Major99 View Post
Ive seen so many posts on here about how crappy the audio is with the stock shield and stock deck etc..etc.. When I got my 15, I wanted no issues at all so I immediately pulled the stock speakers and replaced them with Focal speakers and a Focal amp. This past Saturday night, I rode into work at in the middle of the night for 35-40 miles on the highway. I had time to do some testing.



My results? At 50 MPH, I can CLEARLY hear my stereo at a bit less than half volume with a full face helmet on. At 70 MPH, I kicked the volume up 2 clicks and again, clear as spring water. At 95MPH (I was testing ) I was at 3/4 volume with no issues at all.



I don't understand what I'm missing here? I have the stock shield and deck. Am I looking for less quality sound than anyone else? I don't think I am.



I'm really not looking to start a battle with anyone and maybe I just got lucky but please someone tell me what is so bad about this bike's audio system?

You went immediately to one of the best sound companies on the market. Most get there by frustration! Lol!


Sent from Motorcycle.com Free App
09Sharknose is offline  
 
post #4 of 6 (permalink) Old 06-08-2015, 07:06 PM
Hangaround
 
jpeesy's Avatar
 
Join Date: Jan 2013
Location: San Antonio
Posts: 96
Sharknose is spot on!
jpeesy is offline  
post #5 of 6 (permalink) Old 06-08-2015, 07:19 PM
Member
 
TLKurtz's Avatar
 
Join Date: Apr 2012
Location: Las Vegas, NV
Posts: 593
Garage
Send a message via Skype™ to TLKurtz
You didn't post what flash is in your HU or what the settings are set to. The real frustration is that the HU is basically a computer with apps and the flash and setup have a lot to do with that. On top of that, much like identical computers that don't act exactly the same, it's possible to have what appears to be identical HU setups with very different results. "THAT" is what all of the frustrations are about.

Consider yourself one of the lucky ones and if you every update (flash) your HU cross your fingers and hope that the other shoe doesn't drop.

-TLKurtz (Mr. Wizard) - Blackhorse Cavalry Nomads VMG member (2/11 CAV - East/West German Border)
2015 RGS - Vivid Black and loads of fun.
Reside in Vegas. I keep cold beer in the fridge for all visitors.
TLKurtz is offline  
post #6 of 6 (permalink) Old 06-09-2015, 07:05 AM Thread Starter
Prospect
 
Join Date: Jul 2013
Location: Derry NH
Posts: 253
Garage
the HU flash was just to shut off the internal amp. I didn't activate the rear speakers allowing fade since I don't have any rear speakers and the possibility of them is pretty far off in the future. I got the components from a friend locally and the cost was about $700 with wiring and fuses.

I have the Focal FD4.350 amp and Focal AC165 speakers.

The update thing makes sense. I haven't done anything with those since the first one. (I think there has been one or two more since)

Never marry an ugly woman, it just takes the energy right out of you.
Major99 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey all. why did I not figure this out sooner. RFG7680 New Members Welcome Area 24 07-27-2015 09:54 PM
Cant figure out how to instal my 6 1/2" speakers. Gasitman Audio 17 03-08-2014 04:40 PM
So i cant adj bass treb and balance cant start in gear with clutch in milkman48 Controls & Handlebars 1 02-26-2013 10:11 AM
Can't figure out why... Fat CDN General Off-Topic Discussions 5 02-11-2012 10:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome