Can a weak battery make your sound system distorted? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-16-2015, 01:33 PM Thread Starter
Grey beard
 
kyle31490's Avatar
 
Join Date: Feb 2014
Location: Bradford, PA
Posts: 1,428
Can a weak battery make your sound system distorted?

Short backstory:

Bike - 2010 RG custom.
Amp - Hogtunes 24.2 two channel in fairing.
Speakers - Hogtunes 572.22-AA 5x7's.
Ground - Battery.

System has been in bike for a long time. About a week ago, The quality of the sound is now bad, but only while the bike is moving and over half volume. It sounds like an FM station that is not getting good reception even when its on aux or cd. It is worse when bass hits. Does not do it while sitting still. Does it 90% of the time at driving speeds.


-----------------------------------------

As most of you know, Im having one of my usual un-diagnosable issues. I have been in contact with hogtunes customer support, and they assure it is not an amp issue like I suspected. Their tech says if the battery is getting weak, it can make the distorted sounds I get over half volume because the battery acts as a filter for the sound.

I don't understand this but was wondering if anyone else knows anything about this?

Any other ideas are appreciated as well. I have checked and cleaned the speaker connections and that did not help.

2010 FLTRX Denim Black -AKA The infamous $4200 Leak...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kyle31490 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-16-2015, 01:40 PM Thread Starter
Grey beard
 
kyle31490's Avatar
 
Join Date: Feb 2014
Location: Bradford, PA
Posts: 1,428
Also, I doubt it matters but the stator was changed about a month ago.

2010 FLTRX Denim Black -AKA The infamous $4200 Leak...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kyle31490 is offline  
post #3 of 8 (permalink) Old 06-16-2015, 02:08 PM
Life Member
 
Join Date: Jun 2012
Location: Pac NW
Posts: 4,096
But your bike starts up just fine? Everytime
reds4 is offline  
 
post #4 of 8 (permalink) Old 06-16-2015, 02:16 PM Thread Starter
Grey beard
 
kyle31490's Avatar
 
Join Date: Feb 2014
Location: Bradford, PA
Posts: 1,428
Yup. Everytime. I would have no clue that anything "could" be wrong with the battery. No signs pointing to a bad battery. Volt meter good, lights are bright, etc etc.

2010 FLTRX Denim Black -AKA The infamous $4200 Leak...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kyle31490 is offline  
post #5 of 8 (permalink) Old 06-16-2015, 03:44 PM
Newbie
 
Join Date: Apr 2015
Location: Ball Ground, GA
Posts: 41
I would point back to the stator replacement and possibly a connection has worked slightly loose. The noise you are describing reminds me of the feedback I used to get on an old jeep. I would get noise back through the radio that increased with RPM. I had to install a filter adapter on the connection to the alternator to get rid of the noise. It wasn't as bad on FM as it was on AM, but you could hear it go up with RPM increase going through the gears.
Not a 100% guarantee, but I would start troubleshooting there.
slbaker232 is online now  
post #6 of 8 (permalink) Old 06-17-2015, 07:46 AM Thread Starter
Grey beard
 
kyle31490's Avatar
 
Join Date: Feb 2014
Location: Bradford, PA
Posts: 1,428
Quote:
Originally Posted by slbaker232 View Post
I would point back to the stator replacement and possibly a connection has worked slightly loose. The noise you are describing reminds me of the feedback I used to get on an old jeep. I would get noise back through the radio that increased with RPM. I had to install a filter adapter on the connection to the alternator to get rid of the noise. It wasn't as bad on FM as it was on AM, but you could hear it go up with RPM increase going through the gears.
Not a 100% guarantee, but I would start troubleshooting there.
Volt meter on bike is now running at 14-14.2 when riding. It's only around 11.5 with the key on engine off.

I also now have an ABS light on and some codes.

I'm trying to figure out if if could be the battery, voltage regulator, stator, a combination, or other.

2010 FLTRX Denim Black -AKA The infamous $4200 Leak...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kyle31490 is offline  
post #7 of 8 (permalink) Old 06-17-2015, 07:54 AM
Prospect
 
Scoop's Avatar
 
Join Date: Apr 2011
Location: Milford, CT
Posts: 296
Garage
It's probably a blown speaker coil, you would have problems with the bike running bad if the charging system was below 13+ volts when riding. It might be a bad ground wire or loose speaker wire, but with my experience being a musician for 40 years, speakers sometimes crap out! Improper ohm balance or pairing will burn out the voice coil and make them sound like a kazoo!

Just my opinion.

Scoop

2011 FLTRU Fullsac Sportpipe, SE Breather/air cleaner, SEPRT Smart-tune, Corbin, Madstad 13", Gold Top Fork Emulators & Springs & JRI B shocks. 2003 XLHS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Scoop is offline  
post #8 of 8 (permalink) Old 06-17-2015, 08:14 AM Thread Starter
Grey beard
 
kyle31490's Avatar
 
Join Date: Feb 2014
Location: Bradford, PA
Posts: 1,428
I will start with speakers after I figure out electric issue and eliminate that

2010 FLTRX Denim Black -AKA The infamous $4200 Leak...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kyle31490 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Full SE vs VH Exhaust System w/ Stage 2 Sound System RoadWolf1172 Intake and Exhaust 23 12-26-2017 01:33 PM
Can someone make this sig pics sized. And not distorted. RFG7680 *General Road Glide Discussions/Pictures 11 04-05-2017 09:51 PM
new speakers sounding distorted....advice?? droz_io Audio 9 07-13-2015 05:13 AM
LED replacement for weak FLTRX signals mffi497 Lighting 23 04-18-2013 01:33 AM
Help me make a Sound System complete shopping list! erikdsn Audio 27 05-21-2012 02:46 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome