can't find a straight answer. - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-23-2015, 07:28 AM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 34
can't find a straight answer.

Didn't upgrade my radio to the new 1.19.

PBR300X2 and Kappas coming tomorrow. Installing them myself Thursday.

1) I need a flash, correct? Not the old amp 1&2 off, 8 speakers, fader on flash?


2) what's the correct flash to get?


3) should i update my head unit to 1.19.0 before i go for a flash?


3) do I flash before I iinstall?


4) do I need the remote wire wired in?
seethesvt is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-23-2015, 03:35 PM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 34
Harley dealer says they're familiar with the process, but I'm skeptical. Would like to know from here so I can be sure. Also, they say I gotta install first, then get the flash after. Is this correct?
seethesvt is offline  
post #3 of 6 (permalink) Old 06-23-2015, 06:06 PM
Member
 
Join Date: Dec 2014
Location: westford mass.
Posts: 590
Seethevst.i had the same problem. I didn't have any faith in my local dealer to perform this program correctly. Bought a line leveler(magic box)from sounds audio it is doing the trick so far. As for the remote wire on your set up I'm not sure. If your amp has a blue wire (remote)I would say yes. Good luck!
dozer23 is offline  
 
post #4 of 6 (permalink) Old 06-23-2015, 06:08 PM Thread Starter
Newbie
 
Join Date: Feb 2015
Posts: 34
Not gonna use the magic box. If I don't get a flash, I don't need a remote wire, but I've heard mixed reviews on if I need one after the flash.
seethesvt is offline  
post #5 of 6 (permalink) Old 06-24-2015, 11:58 AM
Member
 
TLKurtz's Avatar
 
Join Date: Apr 2012
Location: Las Vegas, NV
Posts: 593
Garage
Send a message via Skype™ to TLKurtz
Answers Below:

Quote:
Originally Posted by seethesvt View Post
Didn't upgrade my radio to the new 1.19.

PBR300X2 and Kappas coming tomorrow. Installing them myself Thursday.

1) I need a flash, correct? Not the old amp 1&2 off, 8 speakers, fader on flash?

To the best of my knowledge, when an external amp (any of them) is hooked up you need to set amps 1 & 2 to off. I literally just looked at my settings a little while ago (today) at the dealership. I don't have an 8-speaker option, only 4, which mine is set to because I have 4 speakers. I'm running an RF 400/4 amp with Hertz & RF speakers and the sound is really nice.


2) what's the correct flash to get?

Is this the same as question #1? See answer above.


3) should i update my head unit to 1.19.0 before i go for a flash?

I installed the 1.19.0 update and my sound got completely wacked out. I rolled it back to the 1.18.3 update and it is perfect. IMO, keep a copy of the 1.18.3 update and try the 1.19.0. If it is okay, then leave it, but give yourself a way to go back to the previous update if things get goofy. I will do this going forward - always try the new update but I will have a copy of what was working just in case. Also, the update should not change the flash (settings) that have been set in the computer / radio.


3) do I flash before I iinstall?

Either way *should* be same result, but I would get the flash set then try the update to the 1.19.0. That way you will know if there is a difference and can roll back to previous update if required.


4) do I need the remote wire wired in?


No clue here - maybe the instructions or an audio "expert" can help.

-TLKurtz (Mr. Wizard) - Blackhorse Cavalry Nomads VMG member (2/11 CAV - East/West German Border)
2015 RGS - Vivid Black and loads of fun.
Reside in Vegas. I keep cold beer in the fridge for all visitors.
TLKurtz is offline  
post #6 of 6 (permalink) Old 06-24-2015, 11:56 PM
Hangaround
 
Banshee451's Avatar
 
Join Date: Dec 2014
Location: San Diego, CA
Posts: 67
I agree about the rollback to v. 18.3. I'm running Infiniti Kappas with a RF PBR300 amp. The difference between stereo performance from 18.3 to 19.0 is mind-boggling. AVC worked again with 19.0, but the volume was much lower than under 18.3 post flash. Rolling back to 18.3 had me back to only turning the volume up to just over half when at 70+ mph. With 19.0 I could barely hear the tunes with volume on full at speed. The BS with this Boom 6.5 for the cost of these bikes is ridiculous.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2015 RGS - Vivid Black Stage 1 w/ SE Street Cannons : 12" Bad Seed Bars : ARC Moto 600.4 amp w/ Arc 602 & Hertz Mille Pro Speakers : All LED lighting : removable tour pak : saddle bag ghost lights
Banshee451 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I Can't Wait I Can't Wait I Can't Wait......The Outdoors SteadyEddie General Off-Topic Discussions 15 05-19-2017 02:57 PM
Straight answer Paddywagon Controls & Handlebars 26 03-30-2016 02:58 PM
Why can't I get a straight answer? Brianu1 ECM/Fuel Management systems 10 06-16-2014 06:00 PM
Dumb question deserves an answer pisssed Windshields 2 02-01-2011 05:46 AM
Why are handlebar vendor measurements so unreliable? The ANSWER! 4getNo1 Controls & Handlebars 3 07-09-2010 01:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome