Boom2, bass distortion - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 11-22-2015, 10:46 AM Thread Starter
Newbie
 
joeyultra's Avatar
 
Join Date: Feb 2012
Location: phoenix arizona
Posts: 38
Boom2, bass distortion

I just bought a 2016 road glide ultra and up grated to the boom2 stereo system. It sounds so good on the bike in the dealer ship. Mine sounds not even 1/2 as good. They replaced the rear speakers but it's doing the same thing. When ever the bass hits its distorted. I have the bass turned to the 1/2 way mark and it's still distorted. Dealership really don't know what it is. Does anyone have this system and having the same problem? Any help would be great.
joeyultra is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 11-22-2015, 11:08 AM
Grey beard
 
Spazz's Avatar
 
Join Date: Aug 2015
Location: Reno, NV
Posts: 1,213
Garage
The flash that the dealerships do via Digital Technician have EVERYTHING to do with how your system will sound after upgrades... Boom or aftermarket. If the tech doing the flash forgets one check in the box, or adds a check where it shouldn't be during the process or inadvertently selects the incorrect option... your system will not be optimal.

The bad part about it... you can't tell them if they missed something... you have to take their word for it or push back and ask if they have a tech that is well-versed in Digital Tech to take a look at it and double-check it for you. Sometimes you get a fresh Tech that may not 'know' what to do correctly.... it happens.


For the money you spent on the Boom II... you could have done SOOOOO much better going aftermarket... sorry... but that's the truth.
jpeesy likes this.

2015 RGS 120ST | D&D Boss Boarzilla | 4.5" Topshop Ass | Soundz SS4.100 amp, HD-DSP ,(4) Carbon 65's and Iron 69.2's
RENO BAGGER AUDIO

Last edited by Spazz; 11-22-2015 at 11:11 AM.
Spazz is online now  
post #3 of 11 (permalink) Old 11-22-2015, 11:26 AM Thread Starter
Newbie
 
joeyultra's Avatar
 
Join Date: Feb 2012
Location: phoenix arizona
Posts: 38
Any info and truth works for me. Thank you
joeyultra is offline  
 
post #4 of 11 (permalink) Old 11-22-2015, 11:40 AM
Newbie
 
Join Date: Nov 2014
Location: Independence, MO
Posts: 49
I've seen multiple speaker failures were the magnet becomes loose in the housing, causing distortion. If that checks out ok have them recheck for proper flash of the system.
15fltrxs is offline  
post #5 of 11 (permalink) Old 11-22-2015, 12:01 PM
Grey beard
 
Spazz's Avatar
 
Join Date: Aug 2015
Location: Reno, NV
Posts: 1,213
Garage
Quote:
Originally Posted by 15fltrxs View Post
I've seen multiple speaker failures were the magnet becomes loose in the housing, causing distortion. If that checks out ok have them recheck for proper flash of the system.
Good point on the speakers.... forgot about that...

2015 RGS 120ST | D&D Boss Boarzilla | 4.5" Topshop Ass | Soundz SS4.100 amp, HD-DSP ,(4) Carbon 65's and Iron 69.2's
RENO BAGGER AUDIO
Spazz is online now  
post #6 of 11 (permalink) Old 11-22-2015, 02:15 PM
Hangaround
 
Join Date: Sep 2015
Location: Central CT and Lakes Region, NH
Posts: 73
One way to see if it is the speakers is to change sides. I have this problem now but it is localized to just the left side and to just bass. I'm going to get a flash tomorrow or Tuesday to see if that fixes the problem.
Jhl192 is offline  
post #7 of 11 (permalink) Old 11-23-2015, 12:09 PM
Member
 
bless0's Avatar
 
Join Date: Feb 2015
Location: Tampa, FL
Posts: 472
Garage
Check the speakers themselves to see if they are defective. My buddy installed the BOOM 2 on his street glide fairing and saddle bag speakers. One of his fairing speakers broke after a few weeks of use. The Dealership replaced it under warranty.
bless0 is offline  
post #8 of 11 (permalink) Old 11-23-2015, 01:02 PM Thread Starter
Newbie
 
joeyultra's Avatar
 
Join Date: Feb 2012
Location: phoenix arizona
Posts: 38
The rear speakers where replaced and it made it 10% better still sounds bad.
joeyultra is offline  
post #9 of 11 (permalink) Old 12-01-2015, 09:54 AM Thread Starter
Newbie
 
joeyultra's Avatar
 
Join Date: Feb 2012
Location: phoenix arizona
Posts: 38
Update on my problem. Every part was changed including the radio and over lay harness. Dealer is saying it's the whole main harness.
joeyultra is offline  
post #10 of 11 (permalink) Old 12-05-2015, 12:34 AM
Hangaround
 
Join Date: Jun 2015
Location: Reno, Nevada
Posts: 79
Are you still waiting to get it back? I'm just curious if that actually fixed the problem or not.
CashMoney is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
speaker distortion WOOSAB Audio 4 09-02-2014 02:44 PM
Distortion question... Johnzz1420 Audio 8 06-13-2014 03:47 PM
Hawgwired 6.5" distortion problems.... rageglide Audio 14 10-08-2012 03:57 PM
High speed distortion mc glide J&M 4 06-05-2012 02:44 PM
More bass needed, whats the combo? Sincecrazy Audio 21 03-20-2011 09:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome