HawgWired customer service is lacking - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 6Likes
  • 1 Post By Eagle
  • 1 Post By 09Sharknose
  • 1 Post By SurlyBoy
  • 1 Post By dnschmpn
  • 1 Post By tj316
  • 1 Post By direwolf
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-18-2016, 04:40 PM Thread Starter
Member
 
Join Date: Feb 2012
Location: Austin Texas
Posts: 341
HawgWired customer service is lacking

I have had a noise interface with my Hawg Wired Six pack system that developed just a few months after purchasing a year and a half ago. So I pulled the stereo and Amp fuse and went with out a radio for the next 6+ months. Last year in perpetration for my 10 day trip over Labor day I decided to look into the problem. When I first called them one of their techs sat on the phone with me going through troubleshooting it, which I greatly appreciated. I was told that it was not a problem with their Amp or Speakers and it was a problem with the head unit. So I went out and purchased a new head unit and tried to get it up and working before the trip. Problem still continued, so I called them back and they said that it most be the Biketronics controller. At this point I was leaving the next day on the bike to Colorado for my trip so I removed the controller and the new head unit, and returned the head unit to Bestbuy and the controller to Biketronics. Biketronics promptly sent me a new new one but I waited to install it tell after Christmas. Guess what that didn't fix it. Next I mocked up a different amp just to see and it no longer had a "white noise" in the speakers or a whine with engine. With this info HawgWired told me to send in the Amp and they will take a look at it but I would have to cover parts and labor because now the Amp is out of warranty and I can't find the receipt after we moved. I asked how long to expect for repairs and was told they would have it repaired and sent back within a week if it was something that could be fixed in house but if it went back to the manufacturer it would take a little longer. Rich also explianed that it would go to level 1 techs and if they could not fix it, it would move to level 2 tech and than onto engineering at the manufacturer if level 2 techs could not fix it.

I sent the Amp out and according to the traking number it was deliverd on New Years Eve. Of course I didn't expect them to start on it tell the next week. Looked on their website and noticed that it said that they had not received the Amp so I followed up on the 5th just to verify that they received it and was told they did and would start right away and level 1 techs would update the status by the next day. After no updates I called and spoke with Rich on the 7th he said he would check and call me back. Rich called back about in hour later saying level 1 techs just looked at it and was moving to level 2 techs. Still have no updates or return calls after calling on the 15th and today.

I am irritated that they are taking so long and seem to only check it out when I call. I blame myself for not being more proactive in fixing it while it was under warranty and do not expect them to cover it(lesson learned). I feel they should be a little more expedient on trouble shooting and repairs being we are at a point after 2+ weeks that they said should take less than a week.
Jims79FLH is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-18-2016, 05:27 PM
Member
 
Join Date: Oct 2009
Location: Eastern Ohio
Posts: 483
I would see if they have record of your original call and complaint when the amp would have still been under warranty , they sent you on a wild hunt for a problem which took you until warranty had expired , if they had looked at it originally when you called it should have been covered, I would push them for a warranty repair since you did report the problem while still in your warranty period.
Jims79FLH likes this.

2001 Road Glide Jade Sunglo , carb and stock
Eagle is offline  
post #3 of 10 (permalink) Old 01-18-2016, 06:17 PM
Life Member
 
09Sharknose's Avatar
 
Join Date: May 2011
Location: Fort Bragg, NC
Posts: 2,098
Definitely out of character for them. In my experience with them, I've had awesome customer service. A couple of months ago, they replaced one of my amps (almost two years old). Because of ......wait for it......a funny whining noise when I used RCA input. Good luck.


Sent from Motorcycle.com Free App
Jims79FLH likes this.
09Sharknose is offline  
 
post #4 of 10 (permalink) Old 01-18-2016, 06:35 PM
Member
 
SurlyBoy's Avatar
 
Join Date: Jun 2012
Location: Central MA
Posts: 498
Any time I've called them with questions, even about the parts I bought used, they've been nothing but helpful
Jims79FLH likes this.

2012 Palladium Silver Road Glide Ultra Vance&Hines Power Duals w/ 4" Twin Slash, FP3, Progressive Monotubes- Touring Link-444's, LED headlights/turns/brake, Hawg-Wired Four-In-The-Face, Enforcer Wheels, Rushmore Bags, Madstad, Detachable Tour Pak, Air Horns

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SurlyBoy is offline  
post #5 of 10 (permalink) Old 01-18-2016, 06:54 PM
Life Member
 
dnschmpn's Avatar
 
Join Date: Jul 2012
Location: Fort Mill, SC
Posts: 1,645
My experience has been the exact opposite. Their customer service has been great and very helpful.
Jims79FLH likes this.

Enjoy the Ride!
2013 RGU in Big Blue Pearl
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
S&S Power Tune Duals w/V&H Slash Cuts, TTS Mastertune, Daymaker Headlights, Hawg Wired RS 400 amps, J&M Rokker speakers, AN Big Sucker, Corbin Dual Touring Saddle, Madstad, Progressive Monotubes, JRI Shocks, All LED lights, & several Chrome Goodies.
dnschmpn is offline  
post #6 of 10 (permalink) Old 01-19-2016, 03:44 PM
Life Member
 
tj316's Avatar
 
Join Date: Nov 2010
Location: Sunny Florida
Posts: 1,651
I've ran their products for years and always received great service , they've warrantied things out of warranty and talked me out of spending more money on upgrades they said weren't worth it.
Jims79FLH likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 FLTRX 120ST , CR-630i cams , Zipper's air cleaner, TTS tuner , Dragula2 pipe , Biketronics amp/speakers/tweeter grills , custom Corbin seat, LRS 12" , Dakota Digital Gauges , BR 1 1/2" Sweeping Beater Bars , True Track Stabilizer, Ohlins shocks / Ohlins forks, Jagg Fan Assisted 10 row oil cooler & so much more TJ Sunny Florida
tj316 is online now  
post #7 of 10 (permalink) Old 01-19-2016, 04:02 PM
Life Member
 
direwolf's Avatar
 
Join Date: Mar 2011
Location: Jacksonville FL
Posts: 2,556
Garage
I have had like two issues so far and both were taken care of at no cost to me. First one was under warranty an second one was four months after my warranty expired. Nothing but excellent service so far.
Jims79FLH likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
...2009 SERG...Last of the Hand Built's..
direwolf is offline  
post #8 of 10 (permalink) Old 01-20-2016, 05:48 PM Thread Starter
Member
 
Join Date: Feb 2012
Location: Austin Texas
Posts: 341
Quote:
Originally Posted by Eagle View Post
I would see if they have record of your original call and complaint when the amp would have still been under warranty , they sent you on a wild hunt for a problem which took you until warranty had expired , if they had looked at it originally when you called it should have been covered, I would push them for a warranty repair since you did report the problem while still in your warranty period.
They had no record of it. I should have been more proactive.
Jims79FLH is offline  
post #9 of 10 (permalink) Old 01-20-2016, 05:51 PM Thread Starter
Member
 
Join Date: Feb 2012
Location: Austin Texas
Posts: 341
Quote:
Originally Posted by 09Sharknose View Post
Definitely out of character for them. In my experience with them, I've had awesome customer service. A couple of months ago, they replaced one of my amps (almost two years old). Because of ......wait for it......a funny whining noise when I used RCA input. Good luck.


Sent from Motorcycle.com Free App
Funny you say that because they are telling me that they have never heard of this problem before. Thanks for the info!
Jims79FLH is offline  
post #10 of 10 (permalink) Old 02-02-2016, 08:23 PM
Grey beard
 
thedude's Avatar
 
Join Date: Oct 2009
Location: Neponset IL
Posts: 903
I have to agree with whoever said this is out of character. I called them yesterday about a used amp i got on ebay. The figured out my problem right away and actually talked me out of spending more money with them when I explained what I wanted to get out of my system. I have had Hawg Wired in three bikes over the last five years and have called their techs three different times with stupid mistakes by me and they always helped me and did not make fun of my stupid mistakes. Nobody is perfect. My advice is give them another shot. They will probably get it right.
thedude is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
FYI: 25% off at HawgWired.com 13-FLTRX Audio 1 12-19-2012 10:41 PM
hawgwired zx 6.5 come in red? Fleshwound Audio 5 10-10-2012 06:30 PM
Hawgwired 6.5" distortion problems.... rageglide Audio 14 10-08-2012 03:57 PM
J&M vs Hawgwired vs HD Boom THEMASTERDESTROYER Audio 62 06-21-2012 10:14 PM
HD Boom Speaker + Hawgwired/Hogtuens etc... jbrawkus Audio 2 06-17-2011 08:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome