Blown JBL GTO638 - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-26-2016, 09:53 AM Thread Starter
Hangaround
 
Join Date: Jan 2011
Posts: 103
Blown JBL GTO638

Well, I installed my PBR 300X2 amp last night. I guess I left the gain to high, and also forgot to turn off the AVC on the stereo. Got on the freeway this morning and poof no fronts. Came home, pulled the fairing off, and turned the system back on. I had fronts, but 1 was terrible, it's blown. I turned the gain down, just to play with the other and it seems fine now.

So my question:
If 1 speaker blows will the amp cut out both speakers?

For a period of time, the sound would come in an out, but wouldn't stay on. After turning the bike off and removing the fairing, there was the 1 good speaker.

I just want to make sure that the blown speaker is the problem and something else isn't going on, I don't have any excess heat anywhere, so I'm thinking it's just the speaker. Will try and get more today and see.
SquirtRGU is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-26-2016, 05:27 PM
Hangaround
 
Posse07's Avatar
 
Join Date: Mar 2013
Location: Carlsbad, New Mexico
Posts: 89
I had the same issue last Saturday with the same setup. Followed recommended settings and it still blew out the left speaker. Right is working good still. Put some used speakers in and it sounded good again.
Posse07 is offline  
post #3 of 5 (permalink) Old 02-26-2016, 05:29 PM
Hangaround
 
Posse07's Avatar
 
Join Date: Mar 2013
Location: Carlsbad, New Mexico
Posts: 89
That was actually the first time I used the setup on the road and was not impressed with the loudness.
Posse07 is offline  
 
post #4 of 5 (permalink) Old 02-26-2016, 06:26 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,022
Garage
It might be the auto protection kicking in on the amp. I had a similar problem with the pbr 300x2. If I played it too loud it would shut off momentary. I never did figure out why, I just moved on to the Soundstream Nano.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #5 of 5 (permalink) Old 02-27-2016, 08:06 PM Thread Starter
Hangaround
 
Join Date: Jan 2011
Posts: 103
Well I installed a new set and turned everything down, so hopefully I'll be ok... We'll see.

The Kappa won't be here until the 8th, I'll put those in and move the JBLs to the rear (Un amped).
SquirtRGU is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Jbl gto638 Willy_B Parts for Sale 1 06-22-2018 12:43 PM
JBL GTO638 6.5-Inch 3-Way Speakers tlottman Audio 176 01-06-2018 05:48 PM
GTO638, Kappa 62.11i - What is the difference? zigzag930 Audio 3 11-06-2016 08:20 PM
JBL GTO638 and Sound Stream PN4.520 D Questions GRider Audio 21 04-04-2016 02:15 PM
JBL GTO638 GTO Speakers Gary R Parts for Sale 7 12-02-2015 07:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome