AM/FM radio problem - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 4Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 02-28-2016, 03:08 AM Thread Starter
Newbie
 
Rottweiler's Avatar
 
Join Date: Sep 2015
Location: Close to Calgary, Alberta, Canada
Posts: 8
Garage
AM/FM radio problem

I purchased a 2009 Road Glide. The previous owner upgraded just about everything including having a Hawg Wired system put in. The speaker select switch no longer does anything. A powered antenna was also installed.

The problem I am having is everything works fine except the AM/FM radio. It's a stock Harley radio. The CD and AUX works fine when the bike is on. The AM/FM radio is just static. When I turn the ignition to ACC, the AM/FM radio works???? It's all fine and good except I can't really ride down the road with the ignition in ACC.

As far as I can tell, the main radio harness was not cut.

Any ideas??????
Rottweiler is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 02-28-2016, 04:14 AM
Life Member
 
RGKen's Avatar
 
Join Date: May 2012
Location: Jax, FL
Posts: 3,896
Garage
Are the headlights HID's by chance? HID's are known for radio interference but if it's not that look for another source of electrical interference. I would say that the antenna was not hooked up properly but since you said it works on ACC it may not be that.
Big_gary likes this.

2018 FLTRXS
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RGKen is online now  
post #3 of 12 (permalink) Old 02-28-2016, 05:53 AM
Member
 
teejay's Avatar
 
Join Date: May 2010
Location: Yorkville, IL
Posts: 413
Is there any chance that the powered antenna is only getting power with the switch in the ACC position?

tom
teejay is offline  
 
post #4 of 12 (permalink) Old 02-28-2016, 07:09 AM
Member
 
Join Date: Mar 2012
Posts: 421
Are all your accessory switches on? I have seen people use one of those switches for an amp or antennae?
thealien is offline  
post #5 of 12 (permalink) Old 02-28-2016, 08:01 AM
Member
 
Join Date: Jul 2015
Location: Vacaville, CA
Posts: 317
I have the exact same issue. I have the LED headlights that drop in place of the old bulbs. They have fans driving to cool things down. I am thinking the two might be related but so far nothing found. HD just rubs their chins and say HUM???. I'll be watching this thread closely in case a solution is found. Headlights come on in "Ignition" position, but are off in "Access" position. Was thinking of pulling the Headlight fuse and see if the radio changes any
Big_gary and Tailbreaker like this.
Diverrick is offline  
post #6 of 12 (permalink) Old 02-28-2016, 10:46 AM Thread Starter
Newbie
 
Rottweiler's Avatar
 
Join Date: Sep 2015
Location: Close to Calgary, Alberta, Canada
Posts: 8
Garage
Am/fm

Yes, I have the upgraded lights as well. On a hunch, I pulled the headlight fuse and **boom**, it works as advertised. I see the ballast for the lights is a small unit they mounted on either side of the radio. I'm going to try re-locating them to see what happens...
RGKen likes this.
Rottweiler is offline  
post #7 of 12 (permalink) Old 02-28-2016, 06:59 PM Thread Starter
Newbie
 
Rottweiler's Avatar
 
Join Date: Sep 2015
Location: Close to Calgary, Alberta, Canada
Posts: 8
Garage
Am/fm

Ok...if I pull the headlight fuse, the radio works. If I put the fuse back in and move all the headlight related stuff, the radio does not work on either run or acc???

If I put all the light stuff back, I get radio back only in the acc position again.

Also, if I turn off the radio, as soon as I turn to run, i get static and a faint beep beep beep beep sound over the speakers, on acc, only quiet static???

Dear God.....shoot me now...
Rottweiler is offline  
post #8 of 12 (permalink) Old 03-06-2016, 10:21 AM
Life Member
 
madmat's Avatar
 
Join Date: Jun 2012
Location: Mass
Posts: 4,128
Garage
subscribed


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

18 RGS Bonneville Salt Pearl
madmat is online now  
post #9 of 12 (permalink) Old 01-24-2017, 12:00 PM Thread Starter
Newbie
 
Rottweiler's Avatar
 
Join Date: Sep 2015
Location: Close to Calgary, Alberta, Canada
Posts: 8
Garage
I give...

So......I went all last season without using my radio. I have my scoot ripped apart for the winter and tackled this again.

I took apart the entire front end and stretched out ALL the headlight wires, components etc. With all the headlight crap 4 feet out in front of the bike, and the headlight system not grounded, radio works fine. As soon as I attach the grounds, even using a separate wire away from the bike all the way back to the neg on the battery, the radio goes all static...

The only wire/wires running anywhere near the stereo system is the power. I am wondering if shielded power wires are the answer????

I guess it's another season of iPod.....
Rottweiler is offline  
post #10 of 12 (permalink) Old 01-24-2017, 01:12 PM
Prospect
 
WTFranz's Avatar
 
Join Date: Jan 2016
Location: Arizona
Posts: 224
Garage
Might check at a vehicle radio install place. There are several isolation products that are cheap and work if you know what to use. I had a similar problem with my boat and less than $50 later I had an isolation transformer and a coil suppressor that solved all my issues. What they technically do I have no idea, but the tunes now flow so life is good.
WTFranz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio always starts on AM, or FM adown Audio 4 04-06-2014 09:57 AM
Harmon Kardon CD,AM/FM RADIO/ RCX pipes pat123 Parts for Sale 10 04-25-2013 07:56 PM
'04 AM/FM/CD/WB Radio w/mp3 input NFDLtE3 Sold 3 02-08-2012 11:37 AM
04 Harley cd/fm/am/weather for sale. schnid72 Audio 0 03-16-2011 10:20 PM
AM FM Antenna for 2006 Road Glide. kimmer127 Aftermarket Accessories 1 07-17-2010 10:04 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome