Amp(s) & Electrical Issues ??? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 02-14-2013, 06:26 PM Thread Starter
Grey beard
 
Join Date: Jan 2013
Location: The Redneck Riviera
Posts: 1,390
Amp(s) & Electrical Issues ???

Do adding amp(s) lead to issues with the electrical / charging systems on the '09 and up SERGs / CVOs ?

What~if anything~is required to remedy the issues ?

'Am in process to install J&M 7.25 Rokker XT kit in vented fairing lowers to go with the 7.25 Rokkers already in the fairing.

'Thinking about the J&M 250w Rokker Amp? Does anyone have any input on this setup, good~bad?? Does anybody have any other amp recommendations?

Thanks,
Ed

"I've read dozens of books about heros and crooks, and learned much from both of their styles"

'09 SERG 117/DD7 "THE SHORT BUS"
HeatWave is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 02-14-2013, 07:10 PM
Member
 
bpt-bagger's Avatar
 
Join Date: Nov 2011
Location: Bpt,CT
Posts: 367
im running a rokker 500, xt 7.25 and 6x9s love it and no electrical problems here.
bpt-bagger is offline  
post #3 of 7 (permalink) Old 02-14-2013, 07:46 PM Thread Starter
Grey beard
 
Join Date: Jan 2013
Location: The Redneck Riviera
Posts: 1,390
Quote:
Originally Posted by bpt-bagger View Post
im running a rokker 500, xt 7.25 and 6x9s love it and no electrical problems here.
How long~how many miles have you had the amp?

"I've read dozens of books about heros and crooks, and learned much from both of their styles"

'09 SERG 117/DD7 "THE SHORT BUS"
HeatWave is offline  
 
post #4 of 7 (permalink) Old 02-14-2013, 07:51 PM
Member
 
bpt-bagger's Avatar
 
Join Date: Nov 2011
Location: Bpt,CT
Posts: 367
Quote:
Originally Posted by HeatWave View Post
How long~how many miles have you had the amp?
one year 13k miles.
bpt-bagger is offline  
post #5 of 7 (permalink) Old 02-15-2013, 09:24 AM
Prospect
 
UltraNutZ's Avatar
 
Join Date: Feb 2013
Location: Cypress, TX
Posts: 209
Quote:
Originally Posted by HeatWave View Post
Do adding amp(s) lead to issues with the electrical / charging systems on the '09 and up SERGs / CVOs ?

What~if anything~is required to remedy the issues ?

'Am in process to install J&M 7.25 Rokker XT kit in vented fairing lowers to go with the 7.25 Rokkers already in the fairing.

'Thinking about the J&M 250w Rokker Amp? Does anyone have any input on this setup, good~bad?? Does anybody have any other amp recommendations?

Thanks,
Ed
Thing you need to pay attention to is the class of the amp. Classes A through C are the ones you want to stay away from as they will tax your limited charging system on these bikes and will ultimately lead to one of two things happening 1.) changing audio systems 2.) replacing stock stator with more suitable stator for the electrical load.

J&M amps are Glass G so they're safe for use on stock electrical systems. Anything above Class C are good. A lot you will find are Class D and Class H.
UltraNutZ is offline  
post #6 of 7 (permalink) Old 02-15-2013, 10:59 AM
Life Member
 
DED HD's Avatar
 
Join Date: Jun 2010
Location: Iowa City
Posts: 4,022
Chainsaw has your exact set up. both Rokker 7.25" speakers in the fairing and fairing lowers with a 250 watt J&M Amp.
I initially had Rokker 7.25s in the fairing and fairing lowers, and J&M 500 watt amp, and my battery went dead. I called J&M and realized i didn't have my amp ground wire in the right place. Getting a good ground for the amp is key, and J&M recommends putting the amp ground wire where the battery's negative cable is grounded. Since then, no problems at all, and i have added Rokker saddlebag subwoofers.

'10 Red Custom:
check out my build thread for pix and mods
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DED HD is offline  
post #7 of 7 (permalink) Old 02-15-2013, 11:28 AM
Life Member
 
Q-Hog's Avatar
 
Join Date: Jan 2011
Location: Georgia
Posts: 7,280
Re: Amp(s) & Electrical Issues ???

I have a JL 600/6 pushing multiple speakers w/no problem w/stock electrical system.

Sent from my PG86100 using Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
To the GREAT white North! and Join us for SharkWeekVI Eh!
August 2-3-4 2016 - For registration information click
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Q-Hog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2015 Electrical issues RodeGlide Troubleshooting for Road Glides 11 10-30-2018 12:24 PM
Electrical issues. Need Help!!! Kooljay Engine Related 6 07-07-2017 12:23 PM
electrical issues bigdoug1130 Troubleshooting for Road Glides 11 06-02-2017 10:12 AM
Recurring theme: electrical issues following 14" Malo bar install slowride Troubleshooting for Road Glides 15 12-01-2015 12:23 PM
Possible Electrical Charging issues??? paco ritter Troubleshooting for Road Glides 5 10-05-2012 09:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome