Rockford Fosgate - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 13Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 08-18-2017, 10:29 AM Thread Starter
Newbie
 
VPshaq's Avatar
 
Join Date: Aug 2017
Posts: 2
Rockford Fosgate

I just installed the RG RF kit on my 2012 RG. I took it for a 20 min ride and noticed i wasn't getting any FM stations. I then pulled the fairing off and noticed the metal back covers on the speakers were melting off. System was installed exactly the way the instructions called for. I called RF and they didn't seem to care at all. This could have caused a fire and they just said to call Shopatron. After 5 days of getting the run around I was able to return it through shopatrons website, because they will not answer the phone. Just wanted to warn you guys about this. In Sturgis this year the RF techs said this never happens. However other techs advised the RF amps get hot enough to melt wires.
Attached Images
File Type: jpg IMG_6786.JPG (54.8 KB, 150 views)
File Type: jpg IMG_6785.JPG (70.3 KB, 149 views)
VPshaq is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 09-04-2017, 06:27 PM
Newbie
 
leroydj's Avatar
 
Join Date: Sep 2017
Posts: 8
Thanks for the warning! I was thinking about getting this kit. Guess I will go with my gut and get either the Diamond or Arc audio,
leroydj is offline  
post #3 of 14 (permalink) Old 09-04-2017, 07:16 PM
Life Member
 
Swomack's Avatar
 
Join Date: Oct 2014
Location: Prosper, Texas
Posts: 6,228
Garage
Your First Post On This Great Forum.

And it's to rip on RF products.

Sounds like the amp was not properly set.

Thanks for the heads up on making sure the amp is properly installed and tuned.

Hope you get it figured out and why don't you say hi as a newbie verse ripping a product for you first post.

Many have that kit and many are happy with it.

Just my dime.

Welcome

Swomack


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Gallery / Click Below Link

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Swomack is offline  
 
post #4 of 14 (permalink) Old 09-04-2017, 07:23 PM
Grey beard
 
PSUUUUU's Avatar
 
Join Date: Jun 2017
Location: Pennsylvania
Posts: 1,220
Garage
Tell him Swo!
PSUUUUU is offline  
post #5 of 14 (permalink) Old 09-04-2017, 08:22 PM
Life Member
 
Swomack's Avatar
 
Join Date: Oct 2014
Location: Prosper, Texas
Posts: 6,228
Garage
Quote:
Originally Posted by PSUUUUU View Post
Tell him Swo!
Well Shit

175 Views and there was only one remark.

It's like come here and start a bitch session on RF before even posting a hello.

https://www.roadglide.org/44-new-members-welcome-area/

Sorry guys, I'm no to trying slam this new member but as a first post, I think just struck me wrong.

You audio guys could tell use what might have
happened.

Maybe the gain on the amp was turned to high.

???

Swomack
MightyWhitey likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Gallery / Click Below Link

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Swomack; 09-04-2017 at 08:59 PM.
Swomack is offline  
post #6 of 14 (permalink) Old 09-04-2017, 09:46 PM
Member
 
immo2896's Avatar
 
Join Date: Sep 2015
Location: alabama
Posts: 475
Garage
As a member of this forum that is no better or worse than anybody else, at least have an introduction post before a bitching post. Jus sayin....
MightyWhitey and Swomack like this.
immo2896 is offline  
post #7 of 14 (permalink) Old 09-04-2017, 10:07 PM
Member
 
RoadSpud's Avatar
 
Join Date: Jul 2017
Location: Arizona, USA
Posts: 514
Garage
It may just be the 18 year old single malt talkin' on Labor Day (and celebrating my new bike) but...

SWOMACK FOR PRESIDENT 2020!!!!
MightyWhitey and Swomack like this.
RoadSpud is offline  
post #8 of 14 (permalink) Old 09-05-2017, 07:46 AM
Hangaround
 
GusEmery's Avatar
 
Join Date: Mar 2016
Location: Savage MN
Posts: 177
Garage
Send a message via Skype™ to GusEmery
Quote:
Originally Posted by Swomack View Post
Your First Post On This Great Forum.

And it's to rip on RF products.

Sounds like the amp was not properly set.

Thanks for the heads up on making sure the amp is properly installed and tuned.

Hope you get it figured out and why don't you say hi as a newbie verse ripping a product for you first post.

Many have that kit and many are happy with it.

Just my dime.

Welcome

Swomack
I agree, you don't have to rip anyone, and companies aren't liable for damage to their product, only defects to the product you receive.

That being said, I've been putting stereos together for a LONG LONG time, and I've NEVER seen that happen before!

Secondly, not to hi-jack the thread; but Swomack, love the stand, I need one, where did you get it?

-G
GusEmery is offline  
post #9 of 14 (permalink) Old 09-05-2017, 07:50 AM
Life Member
 
Swomack's Avatar
 
Join Date: Oct 2014
Location: Prosper, Texas
Posts: 6,228
Garage
Quote:
Originally Posted by GusEmery View Post
I agree, you don't have to rip anyone, and companies aren't liable for damage to their product, only defects to the product you receive.

That being said, I've been putting stereos together for a LONG LONG time, and I've NEVER seen that happen before!

Secondly, not to hi-jack the thread; but Swomack, love the stand, I need one, where did you get it?

-G
Here you go.

https://www.lifts-and-stands.com/pro...ikegrab-stand/

Swomack


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My Gallery / Click Below Link

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Swomack is offline  
post #10 of 14 (permalink) Old 09-05-2017, 07:59 AM
Hangaround
 
GusEmery's Avatar
 
Join Date: Mar 2016
Location: Savage MN
Posts: 177
Garage
Send a message via Skype™ to GusEmery
Quote:
Originally Posted by Swomack View Post
Thanks Swomack!

-G
Swomack likes this.
GusEmery is offline  
Reply

Tags
audio install , radio , rockford fosgate

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rockford Fosgate PBR300X4 is here pasa Audio 82 11-07-2013 09:11 AM
Rockford Fosgate P1S652 6.5'' Coax Speakers DonJulio Classifieds Archive (3 months old+) 5 10-01-2011 08:46 PM
Rockford Fosgate Knife_edge Audio 11 09-30-2011 11:21 PM
Rockford Fosgate P1653 speakers ponyhair Audio 10 08-12-2011 09:44 AM
Rockford Fosgate Products jimmyo79 *General Road Glide Discussions/Pictures 6 12-24-2010 12:38 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome