Tested my audio system today on my ride. - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-04-2018, 01:44 PM Thread Starter
Member
 
Heavy Metal's Avatar
 
Join Date: Oct 2017
Posts: 417
Tested my audio system today on my ride.

I go to from 112.7db to 121.1db...

Test was done at 13 out of 17 and 16 out of 17 on volume.

Stock 6.5 radio
Biketronics BT4180.15RG amp.
Hertz Millie 1650.3 Legend, minus Hertz crossovers.
DS18 Pro-CFX 2 way crossovers.


Enclosed is a pics of how I mounted tweeters.

I have mine levelers but should I get it flashed and EQ zero’d out and setup for the next step( lid speakers, with goal of tourpack speaker and lower fairing pod speakers.)?


Has anyone else done this and what’s your results and what are you running?
Attached Images
File Type: jpeg CDAEE336-AD87-4E89-BB90-A5297FECB609_1517773372191.jpeg (381.0 KB, 66 views)
File Type: jpeg 0FC488D3-C801-41C5-A455-26C9A3F42C9C_1517773388409.jpeg (2.06 MB, 69 views)
File Type: jpeg D7E0C26E-4A4F-42BA-89A3-0F02EC9A5B40_1517773422871.jpeg (590.3 KB, 59 views)
Heavy Metal is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-04-2018, 03:11 PM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,022
Garage
Quote:
Originally Posted by Heavy Metal View Post
I go to from 112.7db to 121.1db...

Test was done at 13 out of 17 and 16 out of 17 on volume.

Stock 6.5 radio
Biketronics BT4180.15RG amp.
Hertz Millie 1650.3 Legend, minus Hertz crossovers.
DS18 Pro-CFX 2 way crossovers.


Enclosed is a pics of how I mounted tweeters.

I have mine levelers but should I get it flashed and EQ zero’d out and setup for the next step( lid speakers, with goal of tourpack speaker and lower fairing pod speakers.)?


Has anyone else done this and what’s your results and what are you running?
They say set the eq at 0 when tuning an amp. I don't play by those rules . I set the eq,then tune the amp. I think it sounds better this way.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is offline  
post #3 of 4 (permalink) Old 02-04-2018, 03:37 PM Thread Starter
Member
 
Heavy Metal's Avatar
 
Join Date: Oct 2017
Posts: 417
I only have line levelers in it, not yet flashed the bass is at 0 and tremble at 3 and 4 sounds okay one some tunes and a bit high on others as well.
Heavy Metal is offline  
 
post #4 of 4 (permalink) Old 02-05-2018, 08:24 AM
Member
 
bless0's Avatar
 
Join Date: Feb 2015
Location: Tampa, FL
Posts: 472
Garage
I mounted mine in the grills as well. I went with the BT355 line levelers and reset my head unit. I am still tuning the gains on the amp trying to find that perfect sound and volume. I sed the Rockford Fosgate T1652s component speakers. I had a tough time getting the 6.5" midranges in the speaker pods to sit flush and I barely had room inside the fairing for the Xovers.

I tried adding a pic but it just does not work.
Attached Images
File Type: jpg tweet.jpg (3.1 KB, 61 views)

Last edited by bless0; 02-05-2018 at 08:28 AM.
bless0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New TOY built and tested....... Mcrider996 General Off-Topic Discussions 11 12-06-2013 05:10 PM
What have you tested? Tackdriver General Off-Topic Discussions 13 07-21-2013 08:26 PM
way! anybody ride today? tell us about it? (cold ride today) jeffb928 *General Road Glide Discussions/Pictures 40 04-02-2012 10:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome