Radio signal - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-25-2018, 10:07 AM Thread Starter
Newbie
 
Join Date: Oct 2011
Posts: 49
Radio signal

Which amp is killing my radio signal? I'm running a Precision Power i1000.4 and Power Acoustik ma3000d. I've bought a Diamond 4v2 to replace the culprit.
pryda is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio station static and loss of signal Rasconzo Audio 2 07-30-2015 08:13 AM
Radio Turn Signal Interference jimmyray11349 Audio 1 12-10-2012 08:33 AM
LED turn signal radio noise? fltreagle *General Road Glide Discussions/Pictures 0 12-15-2011 07:16 PM
Kuryakyn front turn signal locate harness kimmer127 Lighting 2 12-06-2011 01:45 AM
run-brake-turn signal module ATrain Lighting 18 02-02-2011 11:37 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome