No sound coming from new lower speakers - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 5Likes
  • 1 Post By Rubimad
  • 1 Post By mastergunnera8
  • 2 Post By roadie13
  • 1 Post By macabra11
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 03-10-2018, 12:41 AM Thread Starter
Grey beard
 
Join Date: Jul 2016
Location: Boise, ID
Posts: 891
Garage
No sound coming from new lower speakers

I have a 2015 Road Glide Special and have been running a Biketronics Bt4180 with just fairing speakers hooked up. When I installed my BT equipment, I hooked up the rear line leveler (BT355) and ran speaker wires for future upgrade.

Well I just got lowers, installed the lower speakers, turned on the bike and there was no music coming from the new lowers. I can hear a faint white noise coming from them, and I even verified this by unplugging/plugging the speaker.

I pulled my fairing apart to check that all connections were solid and was hooked up right. It all looked right to me, and I knew the fairing speakers were working great, so I decided to swap the coax connections on the line levelers. Well then I had sound to the lowers and the white noise to the fairing speaks. I switched it back and buttoned everything up.

Could my LL be busted? Am I missing a step?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'15 FLTRXS - V&H Power Duals w/ Screamin' Eagle Street Cannons - Arlen Ness Big Sucker - BT4180.14 w/Arc Moto 602v2 and Polk MM652 - Le Pera Maverick Daddy Long Legs - Advan Lowers - Freedom Shield 15"
macabra11 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-10-2018, 04:26 AM
Member
 
Rubimad's Avatar
 
Join Date: Oct 2017
Location: Madrid (Spain)
Posts: 721
I am not an expert, but it seems you need to flash the boom audio (e.g. to change from 2 to 4 speakers in its coinfig). As far as I now, it can only be done by an HD dealer. Probably there are other solutions without flashing it, but I don't know them. Good luck.
mastergunnera8 likes this.
Rubimad is offline  
post #3 of 8 (permalink) Old 03-10-2018, 05:24 AM
Life Member
 
mastergunnera8's Avatar
 
Join Date: Dec 2011
Location: Northern Virginia
Posts: 1,656
Quote:
Originally Posted by Rubimad View Post
I am not an expert, but it seems you need to flash the boom audio (e.g. to change from 2 to 4 speakers in its coinfig). As far as I now, it can only be done by an HD dealer. Probably there are other solutions without flashing it, but I don't know them. Good luck.
Im with Rubimad....the 6.5 has to have the rears enabled with the flash...The other option, especially if the "rear" sound to the lowers isnt pushing like you want is to consider bridging the amp and running all 4 off 2 channels..again, I have no idea if you can do that with that amp, or if you have the right speakers to do it with..Good Luck!!! Ride safe!!
Rubimad likes this.

If you love your freedom, thank a Vet!!
2016 RGU Superior Blue...with a bunch of stuff..
mastergunnera8 is offline  
 
post #4 of 8 (permalink) Old 03-10-2018, 06:03 AM
Member
 
Join Date: Aug 2013
Location: Upstate NY
Posts: 748
+3 has to be flashed OR split the signal from the front line leveler to both F and R inputs of amp using RCA Y connectors. You wonít have fade but will get you 4 channels and you really donít need fade for lowers anyways. Be aware some dealers are giving people grief about flashing aftermarket systems.


Sent from my iPhone using Tapatalk
mastergunnera8 and Rubimad like this.

Freedom isn't free, remember to thank a vet.
2018 CVO RG lava orange, 117 Stage 3, 14" F47 and a few chrome extras. Boom crap gone.
2016 RG Special Cosmic Blue, 120ST with Dragos 2:1 and TTS tuner, FBI drop seat kit and JNR air ride. Stock audio long gone.
roadie13 is offline  
post #5 of 8 (permalink) Old 03-10-2018, 11:14 AM
Life Member
 
BH#103's Avatar
 
Join Date: Jun 2012
Location: Illinois
Posts: 1,761
Do what @roadie13 suggests by splitting the signal. At least that is what I would do. I am running your same set up except with the 2180 amp and I just bridged it. You are going to dig the new noise your bike makes running four speakers. I had heard not too long ago, at least around these parts, that dealers are steering away from flashing infotainments unless it's for the Boom installations. Good luck, let us know how you prevail.

2019 Silver Flux/Black Fuse FLTRU
"SLIVER"
BH#103 is offline  
post #6 of 8 (permalink) Old 03-10-2018, 01:36 PM
Prospect
 
Majaste's Avatar
 
Join Date: Feb 2017
Location: San Antonio, Texas
Posts: 242
Garage
I wrote the wrong response... Agree with the above posts...

Sent from my SAMSUNG-SM-G935A using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Majaste
Retired Air Force Munitions (1992-2015)

Last edited by Majaste; 03-10-2018 at 02:40 PM.
Majaste is offline  
post #7 of 8 (permalink) Old 03-11-2018, 11:11 AM Thread Starter
Grey beard
 
Join Date: Jul 2016
Location: Boise, ID
Posts: 891
Garage
Thanks for all the help and suggestions guys. For the sake of time and cost, I just ran out and picked up a couple RCA Y splitters and got everything working in no time! Went for a short ride with some buddies yesterday, and everything sounded good! Where I noticed it most was when I was riding with my face shield closed/ The wind was blocked, but the sound seemed to penetrate clearer because of that. With just the fairing speakers, I did not have that same experience.

If I ever got the notion to add TP pods, I can go get the dealer flash.
mastergunnera8 likes this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'15 FLTRXS - V&H Power Duals w/ Screamin' Eagle Street Cannons - Arlen Ness Big Sucker - BT4180.14 w/Arc Moto 602v2 and Polk MM652 - Le Pera Maverick Daddy Long Legs - Advan Lowers - Freedom Shield 15"
macabra11 is offline  
post #8 of 8 (permalink) Old 03-11-2018, 06:14 PM
Prospect
 
Majaste's Avatar
 
Join Date: Feb 2017
Location: San Antonio, Texas
Posts: 242
Garage
This helped me out as well since I have the speaker pods and lowers with no speakers (yet)... I was doing research myself and came to the same conclusion that the others came to. I simply haven't had time to actually finish it. You verified my research. Appreciate it...

Sent from my SAMSUNG-SM-G935A using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Majaste
Retired Air Force Munitions (1992-2015)
Majaste is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
slack sound coming from my primary? mydime Engine Related 7 04-19-2017 11:16 AM
No Sound from Speakers EODHOG Audio 15 03-10-2016 11:03 PM
Lower Fairing speakers or Inner Fairings speakers. Looking to "thicken" my sound a bi Tvbird Audio 14 07-24-2014 10:55 PM
No sound to rear speakers ZAKMANDO Audio 14 04-08-2013 08:49 AM
J&M Rokker 7.25 Speakers/No Sound bane1240 Audio 11 02-14-2013 07:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome