Thumb controls not working - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 1Likes
  • 1 Post By HD-RG-SD
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-12-2018, 09:18 AM Thread Starter
Newbie
 
Join Date: Jan 2018
Location: SE Georgia
Posts: 47
Post Thumb controls not working

Hey guys, need some tech savvy guru help..... I have a (Jenson HD1BT525 head unit with J&M Amp and speakers) in my 2011 SG. On my last ride I had no control or response from my thumb controls nor the head unit controls for adjusting volume or channels.

I had just ordered a new head unit (Aquotic AV AQ-MP-5UBT-HS) to install on my 08 RG, so I changed out the head unit thinking there was an issue with it. Upon initial install, I initially had operational control via the thumb switches but then the same issue occurred where I couldn't control anything via the thumb switches.

When I raise or lower the channel/mode switch, the volume control shows on the face of the deck but can't raise nor lower. I was able to raise the volume via the head unit control but as soon as I try adjusting via the thumb switch the volume level would decline incrementally from XX volume level to 0 and then no control.

Obviously it's not the head unit, as the same issue occurred with both installed and newly installed units, so do I possible have a short in the wiring somewhere within the handle bars or are my thumb switches the issue?

*************** UPDATE 3-13-2018***************

Out tinkering with the bike radio trying to figure out this issue as I didn't want to start "unbundling wiring harnesses", got to thinking that if it were to be a short it would have given indictors (cutting in & out or on & off). I pulled apart the thumb control housings and there was no chaffing to indicate a short nor at the bottom of the bars where the wires come out into the fairing. I began playing with the volume switch and started to get intermittent control, so bottom line I have a thumb switch that after 7 years is going out.

Hope this is informative for anyone in the future who experiences similar issue.
koryu2u likes this.

Life is not a journey to the grave with the intention of arriving safely in
a pretty and well-preserved body, but rather to skid in broadside,
thoroughly used up, totally worn out, and loudly proclaiming --WOW -- " What a ride!!!

Last edited by HD-RG-SD; 03-13-2018 at 05:37 AM.
HD-RG-SD is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-12-2018, 09:38 AM
Life Member
 
Big_gary's Avatar
 
Join Date: Dec 2010
Location: GA.
Posts: 8,021
Garage
Could be either. Start by unbundling the wires under the fairing.

2010 FLTRX , Stage 1, 13" Madstad, Mono tubes, SuperShox, Heritage style bars. Alpine CDE-HD149BT,Soundstream Picasso Nano Series PN4.520 , 5X7 and 6.5 Infinity Kappa speakers
If I have to explain ,you wouldn't under stand anyway.
Big_gary is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Neutral light on cruise not working and gear indicator not showing Xman247 Tools and Garages 7 08-11-2018 11:09 AM
Thumb controls not working Gixxere Audio 6 03-13-2017 11:19 PM
Rule of thumb on windshield height? powergod Windshields 12 09-23-2011 01:41 AM
right handlebar controls and radio not working (02 e/glide classic convert r/glide) criio1 Troubleshooting for Road Glides 1 07-16-2011 05:34 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome