Bikes Charging system Vs. High End stereos - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-20-2018, 09:56 PM Thread Starter
Grey beard
 
Taz_FL's Avatar
 
Join Date: Feb 2015
Location: Jacksonville, Florida
Posts: 1,096
Garage
Bikes Charging system Vs. High End stereos

I'm curious. I see alot of posts on here about installing these 100, 200, 300 ETC.. watt amps and upgrading speakers. If I'm not mistaken the stock charging system on a harley puts out something like 35 to 45 amps. Do any of you guys that have upgraded your systems have any issues with the power drain on the bikes system?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Taz_FL is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-20-2018, 10:01 PM
Prospect
 
Cdan19's Avatar
 
Join Date: Apr 2017
Location: Illinois / I80 & I55
Posts: 279
Garage
I haven't as of yet. System was put in by stereo shop so I trust they know what doing. That being said it was installed in August 2017, so as of rt now no issues what so ever, except crisp load ass music at 70 plus mph.
Cdan19 is offline  
post #3 of 9 (permalink) Old 03-21-2018, 03:16 AM
Grey beard
 
Stick_FSMC's Avatar
 
Join Date: Mar 2012
Location: Sacramento Valley, CA
Posts: 924
Garage
I have the J&M 500w 4 channel amp in my 2012. I put it in 6 years and 76k miles ago. No troubles.
Stick_FSMC is offline  
 
post #4 of 9 (permalink) Old 03-21-2018, 07:31 AM
Grey beard
 
Brewiz's Avatar
 
Join Date: Jun 2011
Location: Stockbridge, Ga
Posts: 1,223
Garage
2 400 watt amps here and have had them for years, 80,000 miles and original stator. I think it comes down to what class of amp you use and if it is designed for the motorcycle world.

2011 FLTRU Vivid Black Wild 1's WO502, Jackpot Headers/Jackpot Slip-ons,Ventilator S/E Breather, PV, Pro Twin Performance 113", Alpine 149BT W/ Ipod , 2 MMats MD4110's , HAT Clarus 6.5's /Legatia L1V2 tweeters & MMats PA601 up front and HAT Imagines in TourPak Pods.

Last edited by Brewiz; 03-21-2018 at 08:53 AM.
Brewiz is offline  
post #5 of 9 (permalink) Old 03-21-2018, 08:01 AM
Hangaround
 
Hawkeye1's Avatar
 
Join Date: Jun 2016
Location: Fredericksburg, VA
Posts: 153
Garage
Quote:
Originally Posted by Taz_FL View Post
I'm curious. I see alot of posts on here about installing these 100, 200, 300 ETC.. watt amps and upgrading speakers. If I'm not mistaken the stock charging system on a harley puts out something like 35 to 45 amps. Do any of you guys that have upgraded your systems have any issues with the power drain on the bikes system?
The 2015 RGS has a 50 amp stator. This were upgraded as standard when they made the new SE style compensator standard, I believe around 2011.

As for handling the power, its more than enough to handle the a high power setup. I have 2,000 watt Sound Stream 4 Channel, with 6 speakers, 2 Hella Powered Horns, Dakota Digital Gauges, Electric Water Pump, Electric Cooling Fans and going down the road producing 14.2 volts and at idle 12.9 volts.

You'll have no issues with a single amp install with 4 speakers!

2016 Road Glide Ultra ...And I promised my wife no more mods....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Hawkeye1 is offline  
post #6 of 9 (permalink) Old 03-21-2018, 08:39 AM
Life Member
 
bucketlisthd's Avatar
 
Join Date: Jun 2012
Location: W.MA.
Posts: 1,809
I have a Soundstream 520 watts amp in a 15 RGS with no charging issues

'15 Roadglide Special
'87 FXR 100"
'79 Goldwing cafe
bucketlisthd is online now  
post #7 of 9 (permalink) Old 03-21-2018, 09:11 AM
Life Member
 
wevsspot's Avatar
 
Join Date: May 2015
Location: God's Country
Posts: 1,740
Garage
Cerwin Vega B2 500W RMS 2-channel AMP on stock charging system no issues 2.5 years.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wevsspot is offline  
post #8 of 9 (permalink) Old 03-21-2018, 09:51 PM Thread Starter
Grey beard
 
Taz_FL's Avatar
 
Join Date: Feb 2015
Location: Jacksonville, Florida
Posts: 1,096
Garage
Thanks everyone for the feedback. Myself and one of my buds were talking about upgrading stereos but this was a concern that popped up.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Taz_FL is offline  
post #9 of 9 (permalink) Old 03-22-2018, 08:12 AM
Life Member
 
wevsspot's Avatar
 
Join Date: May 2015
Location: God's Country
Posts: 1,740
Garage
Quote:
Originally Posted by Taz_FL View Post
Thanks everyone for the feedback. Myself and one of my buds were talking about upgrading stereos but this was a concern that popped up.
Shouldn't be an issue on the Rushmore bikes unless you do something crazy


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wevsspot is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HD High Output Charging System 09Sharknose Tech Area 3 08-25-2015 12:28 PM
Alpine Stereos CSM11 Audio 88 03-02-2014 06:53 PM
iPhone 4S - Charging/Not Charging dinggus Audio 8 11-01-2013 08:25 AM
Double din stereos & ABS inner fairings? Papi63 Audio 11 09-04-2013 02:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome