Boom Audio II Right Speaker issue - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 2Likes
  • 2 Post By Ohiobellboy
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-17-2018, 06:26 PM Thread Starter
Newbie
 
Join Date: Jun 2015
Location: Florida
Posts: 2
Boom Audio II Right Speaker issue

I am hoping someone can help me. I have a 2015 RGS with Boom audio stage II dealer installed when I bought the bike. I haven't had any issues with the stereo since. Then the other day I got on the bike and noticed only the left speaker seemed to be putting out any sound. I got home and pulled the nose of the fairing off just to check for loose wires but found nothing loose but did notice that the right speaker was barely working but definitely not as loud as the left one. Has anyone else had this issue?
Hiker2112 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-17-2018, 08:21 PM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,702
Quote:
Originally Posted by Hiker2112 View Post
I am hoping someone can help me. I have a 2015 RGS with Boom audio stage II dealer installed when I bought the bike. I haven't had any issues with the stereo since. Then the other day I got on the bike and noticed only the left speaker seemed to be putting out any sound. I got home and pulled the nose of the fairing off just to check for loose wires but found nothing loose but did notice that the right speaker was barely working but definitely not as loud as the left one. Has anyone else had this issue?
Can you hear anything out of the tweeters? Did you try swapping the speakers from side to side to see if it's the speaker or the amp? If the trouble stays with the speaker, it's the speaker. If the trouble stays on the right side, then it's the amp.
Bruce00 and eddienelson like this.

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is online now  
post #3 of 6 (permalink) Old 04-19-2018, 01:41 AM
Grey beard
 
Bevis's Avatar
 
Join Date: Mar 2016
Location: SW Fl
Posts: 873
Garage
no Boom II, but my right speaker rattled this morning like it was blown and then quit producing sound. tried it on the left still no sound.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2016 Velocity Red Road Glide Special

"Don't pass up a beer, a buck or a titty fk, May you never run out of luck" reds4
Bevis is offline  
 
post #4 of 6 (permalink) Old 04-19-2018, 03:18 AM
Hangaround
 
Join Date: Mar 2018
Posts: 108
Garage
Quote:
Originally Posted by Hiker2112 View Post
I am hoping someone can help me. I have a 2015 RGS with Boom audio stage II dealer installed when I bought the bike. I haven't had any issues with the stereo since. Then the other day I got on the bike and noticed only the left speaker seemed to be putting out any sound. I got home and pulled the nose of the fairing off just to check for loose wires but found nothing loose but did notice that the right speaker was barely working but definitely not as loud as the left one. Has anyone else had this issue?


Shoot me a PM and provide your email and the make model of your bike and I will see if I have that manual. Iíve pretty much got everything from 1925 current. They arenít hard to diagnose when you have a Harley manual.


Sent from my iPad using Tapatalk
Jeff6146 is offline  
post #5 of 6 (permalink) Old 04-19-2018, 09:53 PM Thread Starter
Newbie
 
Join Date: Jun 2015
Location: Florida
Posts: 2
Update:

Update... Took it in to the dealer today.I was hoping it was a speaker but it was not. It turned out to be the amp of course. The service tech told me that the early boom audio amps (2014-2015) had some minor bugs but that he thought the newer amps were better. so they installed a new amp and it is working like a champ. Thanks for all the help and tips on this issue.
Hiker2112 is offline  
post #6 of 6 (permalink) Old 04-19-2018, 11:54 PM
Grey beard
 
Bruce00's Avatar
 
Join Date: Jan 2012
Location: Dirty Jersey
Posts: 1,129
Garage
Quote:
Originally Posted by Hiker2112 View Post
Update... Took it in to the dealer today.I was hoping it was a speaker but it was not. It turned out to be the amp of course. The service tech told me that the early boom audio amps (2014-2015) had some minor bugs but that he thought the newer amps were better. so they installed a new amp and it is working like a champ. Thanks for all the help and tips on this issue.
Oh great.....LOL I too, had the Boom upgrade on my 15 before I took delivery. Only problems, so far, is blowing left side speaker in my lower fairing. Extended warranty takes care of it, with me paying $50 deductible. Next time, Iam thinking I'll go aftermarket speakers

2015 RoadGlide Special
Tuned by Jamie @ Fuel Moto w/Rinehart 2>1
Bruce00 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boom II audio upgrade 40discokid Audio 6 10-06-2017 01:12 PM
15 RGS Boom 2 Rt Speaker Went BOOM! 1st_HD_Glide Audio 3 05-28-2017 05:11 PM
Right place. Right time. RFG7680 *General Road Glide Discussions/Pictures 10 09-24-2016 10:45 PM
Boom!ô Audio High Performance Boom!ô Bagger Road Glideģ Fairing Speakers longrides Classifieds Archive (3 months old+) 1 11-14-2011 07:01 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome