iPod Interface problem? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-17-2018, 06:37 PM Thread Starter
Hangaround
 
Witt19's Avatar
 
Join Date: Dec 2011
Location: Aberdeen/MD/USA
Posts: 112
iPod Interface problem?

So I was heading towards purchasing the Alpine CDE-HD149BT and I went back to mess with the stock radio and iPod Interface on my 2011 FLTRU. I can get the iPod working in the saddlebag by actually picking what I want to listen to from the iPod (not very useful when riding). So the problem is I have no visual of the band or song names and no control to change it via the handlebar controls. The softkeys still read Artist, Playlist and etc but have no function when I push them. I have checked and the firmware is up to date. I am now thinking it could be the iPod Interface itself. Anybody have this issue before I purchase the Alpine radio and just move on?

Thanks again
Witt19 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-18-2018, 06:51 AM
Prospect
 
Root76's Avatar
 
Join Date: Aug 2015
Location: SW Virginia
Posts: 214
Garage
If you're talking about the HDPDPLUSIII interface, I took mine out because it was just a waste of space. Nothing appeared on the screen and the hand controls seemed useless. Hell, I don't think it even charged the Ipod that well. If I use the Ipod now, I just plug it in the front AUX input. I did solder a rear AUX input on the back of the stock radio (for GPS). Move on!

Midnight Pearl 2013 CFR pipes Khrome Werks handelbars
Root76 is offline  
post #3 of 6 (permalink) Old 04-18-2018, 05:30 PM
Grey beard
 
thedude's Avatar
 
Join Date: Oct 2009
Location: Neponset IL
Posts: 908
Move on. The HD interface is complete junk. I will never purchase another HD audio product because of this thing that basically does nothing but aggrivate the owner. I actually had good luck with the first version of the HDPDPLUS but I left it in the 11 when I traded it. I purchased the HD version for my 13 thinking it would be better but that was a big mistake.
thedude is offline  
 
post #4 of 6 (permalink) Old 04-18-2018, 06:13 PM Thread Starter
Hangaround
 
Witt19's Avatar
 
Join Date: Dec 2011
Location: Aberdeen/MD/USA
Posts: 112
Thanks, I figured I would be moving on, just needed to put the nail in the coffin from others experience.
Witt19 is offline  
post #5 of 6 (permalink) Old 04-25-2018, 11:58 AM
Newbie
 
Join Date: Apr 2018
Posts: 2
100 % agree it is a garbage component, I installed a marine Bluetooth dongle and lovin it .
Rammertime is offline  
post #6 of 6 (permalink) Old 04-25-2018, 12:21 PM
Member
 
chromedome's Avatar
 
Join Date: Jun 2012
Location: The OC
Posts: 743
Garage
I had one of those "HPPD...POS" things too. Took it out 'cause it crapped the bed.
Waste of money.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Road Glide Ultra (SOLD) & 2015 BMW R1200RT
chromedome is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ipod Nano and/or HD iPod Interface wingman05 Audio 29 09-17-2014 07:48 AM
Replacement iPod cable from Boom Audio iPod interface kit McGruder Audio 7 04-21-2014 05:08 AM
strange problem with ipod interface skratch Audio 3 04-19-2014 03:00 PM
Ipod HD. interface needed if one uses J&M NEW Ipod interface??? hogger Audio 2 10-22-2013 02:28 PM
Boom!™ Audio iPod® Interface? Not_A_CVO Audio 30 04-22-2012 09:21 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome