On my 2015 RGS the radio goes off about every 10 seconds rhen back on, the off. I har - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-14-2019, 12:49 PM Thread Starter
Hangaround
 
Hopalong48's Avatar
 
Join Date: Nov 2018
Posts: 111
On my 2015 RGS the radio goes off about every 10 seconds rhen back on, the off. I har

Has anyone had a similar experiemce?

Sent from my SAMSUNG-SM-G891A using Tapatalk
Hopalong48 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-14-2019, 02:57 PM
Administrator
 
HUTMO's Avatar
 
Join Date: Feb 2010
Location: Pittsburgh
Posts: 1,801
Garage
Check to see if your CB is turned off. That will do it.

HUTMO


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HUTMO is offline  
post #3 of 8 (permalink) Old 05-14-2019, 03:01 PM
Life Member
 
wevsspot's Avatar
 
Join Date: May 2015
Location: God's Country
Posts: 1,740
Garage
Not me or anyone that I personally know of. The same Rushmore radios are used on the both the Street Glides and the Road Glides, so there's a lot of them out there and I ride with a bunch of people on Rushmore touring bikes with the 4.3 or 6.5

Guess first step is to pull the fairing and ensure that the main harness plug hasn't worked itself loose or have any corroded connections. Then the fuses.

When you say "goes off" do you mean the screen goes blank or you appear to lose all power?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wevsspot is offline  
 
post #4 of 8 (permalink) Old 05-14-2019, 03:37 PM Thread Starter
Hangaround
 
Hopalong48's Avatar
 
Join Date: Nov 2018
Posts: 111
The radio just quits playing, I have the 6.5 and no CB. The screen stays on.

Sent from my SAMSUNG-SM-G891A using Tapatalk
Hopalong48 is offline  
post #5 of 8 (permalink) Old 05-14-2019, 04:37 PM
Grey beard
 
Join Date: Oct 2016
Location: St. Paul, Mn.
Posts: 1,318
Garage
Do you use bluetooth? Someone had a issue last year that their phone was connected with bluetooth for phone calls and the radio didn't like it. I think he plugged it in to the USB to fix. Or maybe it was the other way around? Something to look into anyway.

Sent from my SM-G930V using Tapatalk

" 4 Wheels move the body, 2 Wheels move the soul"

2015 Road Glide Special "Amber Whiskey"
Buzzy is offline  
post #6 of 8 (permalink) Old 05-14-2019, 04:48 PM
Grey beard
 
UT_Larry's Avatar
 
Join Date: Sep 2015
Location: West Valley City, Utah
Posts: 925
Garage
I did when I had a full 64 gig thumb drive installed. No problems after I changed to an 8 gig.

2015 FLTRX Road Glide. Vivid Black.
UT_Larry is offline  
post #7 of 8 (permalink) Old 05-14-2019, 05:16 PM Thread Starter
Hangaround
 
Hopalong48's Avatar
 
Join Date: Nov 2018
Posts: 111
No, I hardly use it at all. I just turned it on yesterday and the radio was messing up so I turned it back off. I had my scoot in for the clutch recall in late oct or Nov and they said they did the update on the Boom system. I dont know if that was the Maps or what. I have to go back to the dealership in a day ir two but I feel more comfortable having some info beforehand in case they want me to bend over. I bought the bike used with 3k on it last year and I didn't get the manual so I probably need to download it and read the whole thing. I appreciate all the feedback everyone is very helpful.

Sent from my SAMSUNG-SM-G891A using Tapatalk
Hopalong48 is offline  
post #8 of 8 (permalink) Old 05-14-2019, 05:35 PM
Prospect
 
Erilflynn's Avatar
 
Join Date: Nov 2018
Location: Old Bridge, NJ
Posts: 239
Quote:
Originally Posted by Hopalong48 View Post
No, I hardly use it at all. I just turned it on yesterday and the radio was messing up so I turned it back off. I had my scoot in for the clutch recall in late oct or Nov and they said they did the update on the Boom system. I dont know if that was the Maps or what. I have to go back to the dealership in a day ir two but I feel more comfortable having some info beforehand in case they want me to bend over. I bought the bike used with 3k on it last year and I didn't get the manual so I probably need to download it and read the whole thing. I appreciate all the feedback everyone is very helpful.

Sent from my SAMSUNG-SM-G891A using Tapatalk
The dreaded update. Have them flash you back to previous version.

2019 Road Glide
2016 Street Glide Special (Gone)
2015 Kawasaki 1700 Voyager (Gone)
Erilflynn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HK Radio software update cyclotron Tech Area 7 05-02-2018 12:03 AM
Old Sirius Radio antennae will it work 2015 RGS bmoore951 Audio 1 11-01-2015 07:27 AM
Harley Radio Flash Nightmare is OVER ! JMJOHN J&M 0 09-11-2015 07:44 PM
Radio cuts out on engine start? dbbarton00 Troubleshooting for Road Glides 4 02-18-2012 08:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome