Absolutely frustrated - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 5Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 41 (permalink) Old 05-22-2019, 07:09 PM Thread Starter
Newbie
 
Doc_FYF's Avatar
 
Join Date: Mar 2019
Posts: 22
Absolutely frustrated

First time posting so be gentle.

Over winter here in Canada I installed Cerwin Vega B52 amp (no intentions to add any other speakers aside from fairing), bt355, bike Tronics remote wire adapter and had it flashed by the dealer for a 4 speaker 0amp setup. I've gone through 2 sets of infinity Kappa 62.ix and now just blew one of my JL audios 609 I got to replace the Kappas. I can not for the life of me figure this issue out and I'm about ready to light the thing on fire.

I've gone over the wiring everytime and double checked all the amp settings. For some reason though they always blow on the highway

I can't keep sinking coin into speakers so if anyone has any ideas or suggestions I'm open..

2017 road glide special
Doc_FYF is offline  
Sponsored Links
Advertisement
 
post #2 of 41 (permalink) Old 05-22-2019, 07:26 PM
Member
 
Join Date: Aug 2013
Location: Upstate NY
Posts: 752
Absolutely frustrated

Welcome to the forum.

How did you set your gains on the amp?

What are your crossover settings?

Default settings on the BT 355 or did you tweak?

Key word and tricky phrase - they always blow on the highway..........If your AVC is on, turn it off and promise to never use it again. If I had a dollar for everyone that uses it and smoked a set of speakers................


Sent from my iPhone using Tapatalk

Freedom isn't free, remember to thank a vet.
2018 CVO RG lava orange, 117 Stage 3, 14" F47 and a few chrome extras. Boom crap gone.
2016 RG Special Cosmic Blue, 120ST with Dragos 2:1 and TTS tuner, FBI drop seat kit and JNR air ride. Stock audio long gone.

Last edited by roadie13; 05-22-2019 at 07:28 PM.
roadie13 is offline  
post #3 of 41 (permalink) Old 05-22-2019, 07:41 PM Thread Starter
Newbie
 
Doc_FYF's Avatar
 
Join Date: Mar 2019
Posts: 22
I was sent this for setting the amp.

"Tuning the amp

First make sure all dials are turned all the way counter clockwise. That's going to end you in the 7 o'clock position.

All steps from here will refer to the time on the clock for an easy reference.

Sens dials should all be at 11 o'clock, that's the first S in Sens, front and rear on 4 channels amps.

The Freq dial should be at the following;

6.5 set to 1 o'clock that's the Q in Freq

6x9 set to 12 o'clock that's straight up and down.

Horns and tweeters turn the dial all the way til it stops clockwise

8s, depending on the 8 should be between 9 and 12 o'clock

All switches should be on HP"

That's how I set it. Bt355 I didn't touch the settings

As for AVC I believe it was off if I'm not mistaken I had to leave the garage before I burnt it to the ground

Now I have to get replacement speakers again and thinking.of going this route

Hertz Mille Pro 6.5" 200 Watts Coaxial
Doc_FYF is offline  
 
post #4 of 41 (permalink) Old 05-22-2019, 07:56 PM
Life Member
 
mastergunnera8's Avatar
 
Join Date: Dec 2011
Location: Northern Virginia
Posts: 1,665
Quote:
Originally Posted by Doc_iffi View Post
I was sent this for setting the amp.

"Tuning the amp

First make sure all dials are turned all the way counter clockwise. That's going to end you in the 7 o'clock position.

All steps from here will refer to the time on the clock for an easy reference.

Sens dials should all be at 11 o'clock, that's the first S in Sens, front and rear on 4 channels amps.

The Freq dial should be at the following;

6.5 set to 1 o'clock that's the Q in Freq

6x9 set to 12 o'clock that's straight up and down.

Horns and tweeters turn the dial all the way til it stops clockwise

8s, depending on the 8 should be between 9 and 12 o'clock

All switches should be on HP"

That's how I set it. Bt355 I didn't touch the settings

As for AVC I believe it was off if I'm not mistaken I had to leave the garage before I burnt it to the ground

Now I have to get replacement speakers again and thinking.of going this route

Hertz Mille Pro 6.5" 200 Watts Coaxial
1st off welcome to the forum..secondly IMHO check out a full biketronics system..lifetime warranty also...there are a couple setups floating around the forums used...still has warranty...That is a good amp..but just sayin...good luck!!!

If you love your freedom, thank a Vet!!
2016 RGU Superior Blue...with a bunch of stuff..
mastergunnera8 is offline  
post #5 of 41 (permalink) Old 05-22-2019, 08:01 PM Thread Starter
Newbie
 
Doc_FYF's Avatar
 
Join Date: Mar 2019
Posts: 22
I appreciate that I just can't justify that price at the moment being Canadian sometimes sucks for aftermarket. Granted I probably.would have done it knowing I'd go through the set of speakers but thankfully 2 of them the company returned and refunded . I appreciate the suggestion though
Doc_FYF is offline  
post #6 of 41 (permalink) Old 05-22-2019, 08:10 PM
Member
 
Join Date: Aug 2013
Location: Upstate NY
Posts: 752
Thereís nothing in your setup that screams let the smoke out to me. Tuning should always be as specific as possible to a speaker, but nothing you stated is outrageous.

If you have a meter, check out the tuning thread in the audio stickies of the other forum or take a look at YouTube, tons of info.

My moneyís still on the AVC as the root of all evil. The stock head unit will distort at volumes above 14/17 depending on the source, so Iím assuming you kept it at or below that. Iím also assuming you tuned with the bike running.


Sent from my iPhone using Tapatalk

Freedom isn't free, remember to thank a vet.
2018 CVO RG lava orange, 117 Stage 3, 14" F47 and a few chrome extras. Boom crap gone.
2016 RG Special Cosmic Blue, 120ST with Dragos 2:1 and TTS tuner, FBI drop seat kit and JNR air ride. Stock audio long gone.
roadie13 is offline  
post #7 of 41 (permalink) Old 05-22-2019, 08:14 PM Thread Starter
Newbie
 
Doc_FYF's Avatar
 
Join Date: Mar 2019
Posts: 22
Yes was tuned with bike running, and at level 14/17. Maybe I didn't fully turn the AVC off.not sure once.i calm down I'll be going back out to check because I swear i turned it off. Next speakers will be the
Hertz Mille Pro 6.5" any feed back on those? And this time.ill use the dmm to fine tune the voltage
Doc_FYF is offline  
post #8 of 41 (permalink) Old 05-22-2019, 08:33 PM
Member
 
Join Date: Aug 2013
Location: Upstate NY
Posts: 752
Are you looking at the 165.3 or 1650.3? They are very different speakers. I run the 1650.3 up front in both bikes so Iím a little biased. The new DB Motos are also getting good initial reviews as are the upper end beymas.


Sent from my iPhone using Tapatalk

Freedom isn't free, remember to thank a vet.
2018 CVO RG lava orange, 117 Stage 3, 14" F47 and a few chrome extras. Boom crap gone.
2016 RG Special Cosmic Blue, 120ST with Dragos 2:1 and TTS tuner, FBI drop seat kit and JNR air ride. Stock audio long gone.
roadie13 is offline  
post #9 of 41 (permalink) Old 05-22-2019, 08:37 PM
Life Member
 
madmat's Avatar
 
Join Date: Jun 2012
Location: Mass
Posts: 4,428
Garage
Quote:
Originally Posted by Doc_iffi View Post
Yes was tuned with bike running, and at level 14/17. Maybe I didn't fully turn the AVC off.not sure once.i calm down I'll be going back out to check because I swear i turned it off. Next speakers will be the
Hertz Mille Pro 6.5" any feed back on those? And this time.ill use the dmm to fine tune the voltage
Welcome to the forum from Mass!

Good luck dialing it in.

The hertz mille pro's rock! I have them with the arc audio 600/4, great sound.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

18 RGS Bonneville Salt Pearl
madmat is offline  
post #10 of 41 (permalink) Old 05-22-2019, 08:49 PM Thread Starter
Newbie
 
Doc_FYF's Avatar
 
Join Date: Mar 2019
Posts: 22
I'm looking at the 165.3 trying to stay budget friendly since I just bought a.new Simpson mod bandit and well I'll probably.be divorced soon if I keep it.up
Doc_FYF is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Frustrated Bike running Erratically Woodman Troubleshooting for Road Glides 17 06-07-2017 10:14 AM
SO FRUSTRATED!!! Need help with front wheel allignment Steelerdude1 *General Road Glide Discussions/Pictures 12 07-22-2015 05:36 PM
Drago's S/C/S 4's Installed.....ABSOLUTELY SICK,...pics Nevadasun Intake and Exhaust 21 01-22-2012 11:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome