Front Right Speaker Not Working - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 7Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 07-03-2019, 07:13 PM Thread Starter
Newbie
 
Join Date: Jul 2019
Posts: 1
Cool Front Right Speaker Not Working

I have a 2016 Road Glide Ultra CVO and the front right speaker is not working.
Both rear speakers are working. I flopped the two front speakers and the right is still the issue.
Took the fairing off, checked for obvious wiring issues which was I did not find.
I reset everything to factory and upgraded the system.

Could this be a radio Boom issue or an amp issue?
Thinking of upgrading the amp and speakers to Soundz or Rokker but don't want to invest if I have a bad head unit.

Any way to diagnose the radio other than the normal error codes?
Anyone else have this issue?

Thank you!
Keith Baldwin is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-03-2019, 08:17 PM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,615
I have the '15 version of that bike and had the same thing happen. Mine was the amp. I did the same trouble shooting methods you did.

Sent from my XT1710-02 using Tapatalk

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is online now  
post #3 of 14 (permalink) Old 07-03-2019, 09:13 PM
Grey beard
 
Spazz's Avatar
 
Join Date: Aug 2015
Location: Reno, NV
Posts: 1,195
Garage
What he said...Your amp has a dead channel.



Sent from my SM-G975U using Tapatalk

2015 RGS 120ST | D&D Boss Boarzilla | 4.5" Topshop Ass | Soundz SS4.100 amp, HD-DSP ,(4) Carbon 65's and Iron 69.2's
RENO BAGGER AUDIO
Spazz is offline  
 
post #4 of 14 (permalink) Old 07-07-2019, 04:42 PM
Hangaround
 
z73421's Avatar
 
Join Date: Aug 2012
Location: Twinsburg, OH
Posts: 144
Angry

Interesting, My right speaker stopped working this week on my 2015. I verified that it is not the speaker by swapping them. I took the fairing off and I do not see an amp which is surprising because the music is quite loud. I bought the bike used and it has the Boom Stage I front speakers. If it had an amp where would it be? There doesn't seem to be a lot of space in the faring for an amp.
z73421 is offline  
post #5 of 14 (permalink) Old 07-07-2019, 05:10 PM
Grey beard
 
Join Date: Jan 2015
Location: Pensacola Fl
Posts: 1,146
Garage
Follow your speaker wires. They either go to a amp or your HU
duglauraflht likes this.

2009 Road Glide. 16 in Vindikta Wild Cats. Aquatic AV, Stinger 700X4 to MMatts, Audiopipe horns.
6900pros in the lids w/ sspn.4 1000d, tuned with DD Audio DSI-2. S&S 106, lifters, push rods and AC. Drago 2. CycleRama 575. Progressive monotones -1in. 12in. HD adjustable rear shocks. Painted inner fairing. Tuned with TTS. Blacked out!
phillyfan1 is offline  
post #6 of 14 (permalink) Old 07-08-2019, 05:45 AM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,615
Quote:
Originally Posted by z73421 View Post
Interesting, My right speaker stopped working this week on my 2015. I verified that it is not the speaker by swapping them. I took the fairing off and I do not see an amp which is surprising because the music is quite loud. I bought the bike used and it has the Boom Stage I front speakers. If it had an amp where would it be? There doesn't seem to be a lot of space in the faring for an amp.
If it has a stock one, it's under the radio.

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is online now  
post #7 of 14 (permalink) Old 07-08-2019, 09:23 AM
Grey beard
 
Spazz's Avatar
 
Join Date: Aug 2015
Location: Reno, NV
Posts: 1,195
Garage
Quote:
Originally Posted by z73421 View Post
Interesting, My right speaker stopped working this week on my 2015. I verified that it is not the speaker by swapping them. I took the fairing off and I do not see an amp which is surprising because the music is quite loud. I bought the bike used and it has the Boom Stage I front speakers. If it had an amp where would it be? There doesn't seem to be a lot of space in the faring for an amp.
Boom Stage I does not have a stock amp. Stage II 2 speaker system will an amp located under the radio... 4 speaker system will have amp under radio and amp in left side saddle bag

Sent from my SM-G975U using Tapatalk

2015 RGS 120ST | D&D Boss Boarzilla | 4.5" Topshop Ass | Soundz SS4.100 amp, HD-DSP ,(4) Carbon 65's and Iron 69.2's
RENO BAGGER AUDIO
Spazz is offline  
post #8 of 14 (permalink) Old 07-21-2019, 02:54 PM
JMJOHN
 
JMJOHN's Avatar
 
Join Date: Oct 2010
Location: Tucson AZ
Posts: 972
Spazz ,,,,,,

I believe the BOOM I system in the 2016 CVO RoadGlide Ultra DOES have a Harley amp mounted directly UNDER the radio ,,,,,,

that is the amp we remove each time when installing one of our plug-n-play ROKKER systems for the 16RU like we show here https://www.jmcorp.com/ProductDetail...00SP4-15RU-CVO ,,,

we do a lot of these at the shows and include installation and proper radio flash so that all the radio functions of front/rear fade, bass, treble and AVC are active with the 700w ROKKER amplifier,,,,

JMJOHN ----
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JMJOHN is offline  
post #9 of 14 (permalink) Old 07-21-2019, 05:50 PM
Member
 
Join Date: Aug 2013
Location: Upstate NY
Posts: 735
Dang, I feel sorry for that fella. Hopefully he's got an understanding wife when he figures out he's 0 for 2 and installs a third system. Talk about jumping out of the overrated expensive frying pan into the fire.
Ohiobellboy and duglauraflht like this.

Freedom isn't free, remember to thank a vet.
2018 CVO RG lava orange, 117 Stage 3, 14" F47 and a few chrome extras. Boom crap gone.
2016 RG Special Cosmic Blue, 120ST with Dragos 2:1 and TTS tuner, FBI drop seat kit and JNR air ride. Stock audio long gone.
roadie13 is offline  
post #10 of 14 (permalink) Old 07-21-2019, 08:39 PM
Life Member
 
Ohiobellboy's Avatar
 
Join Date: Nov 2012
Location: Canton, oHIo
Posts: 4,615
Quote:
Originally Posted by Spazz View Post
Boom Stage I does not have a stock amp. Stage II 2 speaker system will an amp located under the radio... 4 speaker system will have amp under radio and amp in left side saddle bag

Sent from my SM-G975U using Tapatalk
CVO RGU has the 1 amp under the radio and is considered the Stage 1 with the Stage 1 speakers. Here's a pix I just took today. Look for the black right under the radio. It's actually mounted fins down.

It's in there somewhere, I promise. Lol

Sent from my XT1710-02 using Tapatalk

A.K.A OBB
Check out the Ohio Glide Riders community page:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ohiobellboy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome