Tinny/anemic sound with amp - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 4Likes
  • 2 Post By eggwhite93
  • 1 Post By Mike U
  • 1 Post By eggwhite93
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 09-21-2019, 04:11 PM Thread Starter
Hangaround
 
Cagey's Avatar
 
Join Date: Mar 2017
Location: NH / USA
Posts: 112
Garage
Tinny/anemic sound with amp

So I was out riding today and noticed that I couldn't hear my music as well as I normally could. When I got off the highway and could get a better listen, the sound was definitely "off". Not nearly as loud and very anemic sounding (like the amp wasn't pushing anything). No distortion though.

I got home and currently have everything torn apart. I have a blue light on the amp, so that doesn't seem to be the issue and all the fuses are good. Any ideas what the issue could be or what the next step I should take?

Here's my current set-up (also in signature):
Arc Audio 602 speakers
RF TM400x2ad amp
BT355 line leveler

I've got a big ride coming up and need to get this sorted out ASAP.

Thanks!

2017 FLTRXS - Road Glide Special (Olive Gold): Cycle-Rama CR-460 cam, Fuel Moto Jackpot 2-1-2 head pipe, SE Street Cannons mufflers, SE Ventilator air cleaner, Dynojet Power Vision, Freedom Shields 10" Sport Touring, Rockford TM400x2ad amp w/ BT line leveler, Arc 602 speakers.
Cagey is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 09-21-2019, 04:51 PM
Grey beard
 
Join Date: Jan 2015
Location: Pensacola Fl
Posts: 1,305
Garage
I don't have any of that equipment, but here are a few things to look for.
Power too amp?
Does amp have "protect mode" if so is it in that mode?
Does it happen in all HU selections, radio, usb?
LL connections good?
Do you have another amp you can connect to rule the RF out? Same for speakers

Start with the simplest things, connections, and go from there. Don't know if that helped, but its all I got. No experience with that HU, LL or that amp

Mike U pulled the main fuse to reset everything and it worked, but he doesn't have a Rushmore. His thread is here
https://www.roadglide.org/3-%2Agener...ys-repair.html

2009 Road Glide. 16 in Vindikta Wild Cats. Aquatic AV, Stinger 700X4 to MMats PA 601, Audiopipe horns.
Ground Zero 7X10 in the lids w/ sspn.4 1000d, tuned with DD Audio DSI-2. S&S 106, lifters, push rods and AC. Drago 2. CycleRama 575. Progressive monotones -1in. 12in. HD adjustable rear shocks. Painted inner fairing. Tuned with TTS. Blacked out!
phillyfan1 is online now  
post #3 of 10 (permalink) Old 09-21-2019, 06:48 PM Thread Starter
Hangaround
 
Cagey's Avatar
 
Join Date: Mar 2017
Location: NH / USA
Posts: 112
Garage
Quote:
Originally Posted by phillyfan1 View Post
I don't have any of that equipment, but here are a few things to look for.
Power too amp?
Does amp have "protect mode" if so is it in that mode?
Does it happen in all HU selections, radio, usb?
LL connections good?
Do you have another amp you can connect to rule the RF out? Same for speakers

Start with the simplest things, connections, and go from there. Don't know if that helped, but its all I got. No experience with that HU, LL or that amp

Mike U pulled the main fuse to reset everything and it worked, but he doesn't have a Rushmore. His thread is here
https://www.roadglide.org/3-%2Agener...ys-repair.html
Thanks for responding.

Amp has power and is not in protect mode. The problem exists with tuner, USB, and Bluetooth. All connections are good. Ground is good. Power is good. Pulled the main fuse just to be sure.

I bypassed the line leveler entirely and had the same issue. I played with the gain and the other amp settings with no luck.

I finally took the amp off and played the music straight through the HU and the sound quality sounded just as tinny, but not as loud. So I'm not entirely sure what that means now.

2017 FLTRXS - Road Glide Special (Olive Gold): Cycle-Rama CR-460 cam, Fuel Moto Jackpot 2-1-2 head pipe, SE Street Cannons mufflers, SE Ventilator air cleaner, Dynojet Power Vision, Freedom Shields 10" Sport Touring, Rockford TM400x2ad amp w/ BT line leveler, Arc 602 speakers.
Cagey is offline  
 
post #4 of 10 (permalink) Old 09-21-2019, 07:12 PM
Hangaround
 
lonestardiver's Avatar
 
Join Date: Feb 2017
Posts: 120
Can you try different speakers ?
Can you drive the bikes speakers from a different source ?

Attempting to determine if it is the head unit or the speakers.
lonestardiver is offline  
post #5 of 10 (permalink) Old 09-21-2019, 07:16 PM
Life Member
 
Mike U's Avatar
 
Join Date: Aug 2012
Location: New York
Posts: 6,098
Is it possible that the speakers are blown?
Like was previously advised do you have speakers that you can try to see if that is the problem?
Best of Luck.
Hope everything works out for you.
Mike U.


Sent from my iPhone using Tapatalk

USMC 1975-1977
Semper Fi!
Nothing else matters!
Mike U is online now  
post #6 of 10 (permalink) Old 09-21-2019, 07:56 PM Thread Starter
Hangaround
 
Cagey's Avatar
 
Join Date: Mar 2017
Location: NH / USA
Posts: 112
Garage
It looks like it is the speakers. I was able to dig up the OEM speakers and swapped them out. The OEM speakers were loud and clear, even without the amp hooked up. So I'm guessing the speakers blew - I just wasn't expecting them to sound like that when they did apparently.

Now I just need to find a replacement pair by Friday.

2017 FLTRXS - Road Glide Special (Olive Gold): Cycle-Rama CR-460 cam, Fuel Moto Jackpot 2-1-2 head pipe, SE Street Cannons mufflers, SE Ventilator air cleaner, Dynojet Power Vision, Freedom Shields 10" Sport Touring, Rockford TM400x2ad amp w/ BT line leveler, Arc 602 speakers.
Cagey is offline  
post #7 of 10 (permalink) Old 09-21-2019, 09:05 PM
Hangaround
 
Join Date: Feb 2017
Posts: 117
See if you can find some MMats PA601CX that can be shipped to you in a hurry. Those will rip on that amp. You will have to modify the pods too though.
Mike U and Cagey like this.

MMats fanboy
eggwhite93 is offline  
post #8 of 10 (permalink) Old 09-21-2019, 09:09 PM
Life Member
 
Mike U's Avatar
 
Join Date: Aug 2012
Location: New York
Posts: 6,098
What eggwhite said.
Those MMats are getting great reviews and won’t break the bank either.
Mike U.


Sent from my iPhone using Tapatalk
Cagey likes this.

USMC 1975-1977
Semper Fi!
Nothing else matters!
Mike U is online now  
post #9 of 10 (permalink) Old 09-22-2019, 05:36 AM Thread Starter
Hangaround
 
Cagey's Avatar
 
Join Date: Mar 2017
Location: NH / USA
Posts: 112
Garage
Quote:
Originally Posted by eggwhite93 View Post
See if you can find some MMats PA601CX that can be shipped to you in a hurry. Those will rip on that amp. You will have to modify the pods too though.
Modify the pods how? Are they not deep enough to accommodate the speakers? I just ordered some Polk MM652's before seeing this, but if they don't work out I'll definitely check out the MMats. I know the Polks will be a step down from the 602s but since the 602s lasted less than three seasons, I'm not willing to risk that kind of money again.

Anyone know how good Arc's customer service is? I know the speakers are out of warranty, but figured I'd contact them anyway to see what they can do for me.

2017 FLTRXS - Road Glide Special (Olive Gold): Cycle-Rama CR-460 cam, Fuel Moto Jackpot 2-1-2 head pipe, SE Street Cannons mufflers, SE Ventilator air cleaner, Dynojet Power Vision, Freedom Shields 10" Sport Touring, Rockford TM400x2ad amp w/ BT line leveler, Arc 602 speakers.

Last edited by Cagey; 09-23-2019 at 06:46 AM.
Cagey is offline  
post #10 of 10 (permalink) Old 09-22-2019, 08:47 AM
Hangaround
 
Join Date: Feb 2017
Posts: 117
Yes the magnet is a bit too big. You have to cut a hole on the speaker pods.
Cagey likes this.

MMats fanboy
eggwhite93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome