Battery died, now speakers not working!!!!!! - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 02-11-2011, 04:47 PM Thread Starter
Newbie
 
Join Date: Jan 2011
Posts: 14
Battery died, now speakers not working!!!!!!

I have a 2004 RG that was in storage for 6 months. The battery went dead so i put it on the trickel charger over night and now it fires up no problem. The issue i do have is with my radio. All the lights on it work and it will spin a cd how ever nothing comes out of the speakers. i flip the speaker switch back and forth still nothing. Any ideas?? just about to do an upgrade to a sony head unit and some 6 1/2 but not there yet. so far the radio and speakers are stock.
schnid72 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 02-11-2011, 06:17 PM
Admin
 
BillyBob's Avatar
 
Join Date: Sep 2009
Location: Mississippi
Posts: 4,274
Could be A fuse??

2010 FLTRX Red / The First Roadglide / "There's no Ride like a Glide"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyBob is offline  
post #3 of 12 (permalink) Old 02-11-2011, 06:49 PM
Life Member
 
Peewee's Avatar
 
Join Date: May 2010
Location: Augusta, Georgia
Posts: 1,961
BigDaveOnBass had a similar problem in that only one speaker died. He picked up a used stock headunit from a member and now he has no problems


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"Know Thyself"

Drinking beer and thinking about Shark Week!
Peewee is offline  
 
post #4 of 12 (permalink) Old 02-11-2011, 07:05 PM
Grey beard
 
Sincecrazy's Avatar
 
Join Date: Feb 2010
Location: Warrior River, AL
Posts: 1,100
That doesnt make much sense. Have you tried disconnecting the battery? Other than that I would remove the speaker switch and see if its working.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Time - it devours the body while it develops the mind.
Sincecrazy is offline  
post #5 of 12 (permalink) Old 02-11-2011, 07:54 PM Thread Starter
Newbie
 
Join Date: Jan 2011
Posts: 14
The light switch lights up when i switch it on and what not, i know its a wierd thing to have happen. i am thinking the head unit finally died. what do you'll think?
schnid72 is offline  
post #6 of 12 (permalink) Old 02-11-2011, 07:55 PM Thread Starter
Newbie
 
Join Date: Jan 2011
Posts: 14
checked all the fuses also. i will try disconnecting the battery to see if that clears it. post back when its done.
schnid72 is offline  
post #7 of 12 (permalink) Old 02-11-2011, 08:09 PM Thread Starter
Newbie
 
Join Date: Jan 2011
Posts: 14
ok disconnecting the battery did not work. any other ideas?
schnid72 is offline  
post #8 of 12 (permalink) Old 02-11-2011, 08:38 PM
Grey beard
 
Join Date: May 2010
Posts: 1,480
Try This

Pull main fuse, disconnect bat, Bring to full charge, connect main fuse then reset all clock and all other functions. good luck
Frodoe is offline  
post #9 of 12 (permalink) Old 02-12-2011, 05:23 AM
Life Member
 
Peewee's Avatar
 
Join Date: May 2010
Location: Augusta, Georgia
Posts: 1,961
I'm thinking your head unit has given up the fight. However, you might want to pm BigDaveOnBass. He might have some suggestions for you to check seeing how he had a similar issue.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
"Know Thyself"

Drinking beer and thinking about Shark Week!
Peewee is offline  
post #10 of 12 (permalink) Old 02-12-2011, 06:39 AM
Grey beard
 
Sincecrazy's Avatar
 
Join Date: Feb 2010
Location: Warrior River, AL
Posts: 1,100
Sounds like your going to have to remove the outer fairing to check wiring and speakers. So either the mute function is on, the speaker switch doesnt work, or the radio has lost output function, unless the speakers are bad. Again, there doesnt seem to be much that makes sense with this. Other than that you may want to try ironcross audio for repair, should you decide to retain the factory radio.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Time - it devours the body while it develops the mind.

Last edited by Sincecrazy; 02-12-2011 at 06:42 AM.
Sincecrazy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Neutral light on cruise not working and gear indicator not showing Xman247 Tools and Garages 7 08-11-2018 11:09 AM
2012 RGU: Coughed, died and now wont turn over vmaxerg Engine Related 8 02-21-2018 11:57 PM
Battery died - less than 200mi on FLHXS rcolemanreed Troubleshooting for Road Glides 2 05-27-2017 10:21 PM
Battery tender leads not working... NCRG12 Troubleshooting for Road Glides 6 08-18-2013 12:10 PM
HEAVY HEAVY rains now speakers are not working well rob883 Audio 6 06-18-2013 01:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome