Stereo Face Blank - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 08-06-2013, 09:04 PM Thread Starter
Member
 
CSM11's Avatar
 
Join Date: Feb 2011
Location: Middle TN
Posts: 410
Stereo Face Blank

Any suggestions on what could be wrong, I have pulled fairing and checked all seems good, it just goes blank and just started about a week ago. Radio still plays just the screen is blank.
CSM11 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 08-06-2013, 09:39 PM
Life Member
 
93-331-29psi's Avatar
 
Join Date: Jan 2012
Location: Chesapeake VA
Posts: 3,737
Seems like a known and repetitive issue. I have a buddy with a '13 CVO UC that does the same thing. He had it replaced once already.


Sent from Motorcycle.com App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'12 Candy Colbalt Twilight Blue FLTRXSE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
93-331-29psi is offline  
post #3 of 9 (permalink) Old 08-13-2013, 09:51 PM
Newbie
 
Join Date: May 2013
Location: Frederick, MD
Posts: 36
My screen just went blank also, iron cross must have a good amount of business. The HK radio seems like cheap crap!
stic2it is offline  
 
post #4 of 9 (permalink) Old 08-13-2013, 09:54 PM
Life Member
 
Triplej's Avatar
 
Join Date: Oct 2011
Location: Nevada, TX
Posts: 5,434
Mine did it this afternoon following a hardy washing at the local coin op car wash. Let her dry for awhile and all is good again. Good thing I use my Iphone and Pandora for my music listening pleasure.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Triplej is offline  
post #5 of 9 (permalink) Old 08-13-2013, 10:49 PM
Life Member
 
Screamin''s Avatar
 
Join Date: Mar 2010
Location: Central New Jersey
Posts: 1,509
Mine used to do it. I would tap the display with my fingertips and it would come back on. If you are still in warranty, I would see the dealer. Out of warranty? Contact Iron Cross Audio. I think the fix is about $250 and they'll go through the radio and update with any new patches. They did mine and all is well thus far. Good luck

2009 FLTR
Screamin' is offline  
post #6 of 9 (permalink) Old 08-13-2013, 11:15 PM
Life Member
 
rlaf75's Avatar
 
Join Date: Sep 2011
Location: East Hartford CT
Posts: 7,177
Yup mine does it too. Radio still plays but no screen from time to time. Right now though i dont see it as an issue cuz when it does finally take shitter im gonna go aftermarket like a good majority of our RG members seem to do.

09 Mirage Orange Pearl

Some people just need a high-five. In the head. With a chair
rlaf75 is offline  
post #7 of 9 (permalink) Old 08-14-2013, 09:07 AM
Life Member
 
DED HD's Avatar
 
Join Date: Jun 2010
Location: Iowa City
Posts: 4,022
Happened to my 06, 3 times. Pretty common on the HK head units.
Should be replaced under warranty.

'10 Red Custom:
check out my build thread for pix and mods
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DED HD is offline  
post #8 of 9 (permalink) Old 08-14-2013, 09:13 AM
Grey beard
 
RGUrider's Avatar
 
Join Date: Aug 2011
Location: Murfreesboro TN by way of Freeburg IL, Naples Italy, Oscoda MI, Ramstein AB GE, and Dover PA
Posts: 875
Garage
Quote:
Originally Posted by DED HD View Post
Happened to my 06, 3 times. Pretty common on the HK head units.
Should be replaced under warranty.
MOCO\HK uses refurbed units for warranty, at least that was my experience. Had mine replaced for intermittent screen blanking a few months ago. After getting the refurbed unit I replaced with a Sony HU. HK's in a box on the shelf. My opinion is the HK is an inferior HU, but it does have the HD logo Maybe thats why they cost so much.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 RGU/Black - Rinehart True Duals, SERT, K&N Filter, RF PBR300X2,
Hawgwired ZX's, Pioneer G1644R, J&M Hidden Antenna, Sony HU
RGUrider is offline  
post #9 of 9 (permalink) Old 08-14-2013, 05:44 PM Thread Starter
Member
 
CSM11's Avatar
 
Join Date: Feb 2011
Location: Middle TN
Posts: 410
Now my faceplate won't light up at night, have an apt for Sat morning. Still under warranty, but will replace with aftermarket once my warranty is up in Apr 14
CSM11 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Drawn to This Blank Canvas SteadyEddie General Off-Topic Discussions 25 11-06-2016 08:11 AM
MY RG is a blank canvess, what should I do?? maddogz Aftermarket Accessories 5 08-05-2015 10:04 PM
Factory Radio Screen Blank Scully Audio 7 06-25-2015 07:47 PM
Stock Head Unit - Shows blank dinggus Audio 10 12-29-2013 11:33 AM
Radio display is blank? McLuvin Troubleshooting for Road Glides 0 06-24-2013 08:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome