Trouble with my Iron Cross iPod Interface. - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 08-14-2013, 03:23 AM Thread Starter
Newbie
 
Join Date: May 2013
Posts: 11
Angry Trouble with my Iron Cross iPod Interface.

Last week I received the HDPDPLUS2 iPod interface that I ordered directly from Iron Cross. I installed it over the weekend and to my dismay it does not appear to be working. The factory Harmon Kardon head unit does not recognize it and Iíve tried two different iPhones and an iPod, no luck with either and none of them are charging. I have checked and confirmed the following;

ē Iím certain that the T connectors are properly connected to the wires associated with pins 19 and 20 on the 23 pin wire harness, I confirmed proper connection with a low voltage circuit tester.
ē The current radio software version is V8.250
ē Iíve tried by connecting to both the saddle bag extension (long) cable and the glove box (short) cable that comes with the standard HDPDPLUS2.
ē Iíve connecting before and after turning the radio on and disconnecting and connecting while the radio is onÖnothing happens.

One strange thing Iíve noticed is that with the ignition turned off, when Iíve unplugged the 35 pin HDPDPLUS2 harness the iPhone that was plugged in at the time lit up (recognizing something) when messing around with the harness I noticed that if I lightly wiggle the connector (without it being fully inserted or clicked in) the charging symbol (on the iPhone) momentarily displays and then disappears. I can replicate this often but cannot hold the connector in such a way as to keep the charging symbol on. I have not however been able to replicate this with the ignition and thus the radio powered up.

I donít expect that the issue is with the HK head unit so it appears to me that I may have received a faulty iPod Interface.
Is there anyone out there with similar experience? I was really looking forward to having my old iPhone loaded up with music and connected to my audio system, Iíll take any input I can get.
yycfltrx is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 08-14-2013, 07:19 AM
Life Member
 
skratch's Avatar
 
Join Date: Mar 2010
Location: louisiana
Posts: 3,885
did you call them for some assistance? i believe i would start there.

I understand the concept of reality, but find it too confining for a way of life.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
skratch is offline  
post #3 of 8 (permalink) Old 08-14-2013, 08:00 AM
Member
 
Join Date: Apr 2010
Posts: 559
Interface

Yes I'm having problems also,the guy who builds them sent me a cable,that didn't work,then my radio started to act up,got a new one worked for awhile then quit again, he sent me another unit but I haven't changed it yet. It's prolly your cable they told me there was a few bad ones.the customer service has been good, the problem is taking the fairing on and off to chase this.
Jerry W. is offline  
 
post #4 of 8 (permalink) Old 08-14-2013, 09:57 AM Thread Starter
Newbie
 
Join Date: May 2013
Posts: 11
Yes, I sent Iron Cross an email detailing the problem and they responded very quickly indicating that they are sending me another unit (no questions asked). I'm very impressed by their customer service, a little annoyed about the unit not working out of the box, having to wait for my new toy, and most of all having to open and button up my fairing and then remove it again when the new one comes but I guess shit happens. Thumbs up for Iron Cross's service though!
yycfltrx is offline  
post #5 of 8 (permalink) Old 08-14-2013, 10:29 AM
Member
 
ammojeff's Avatar
 
Join Date: May 2013
Location: Utah
Posts: 690
Haven't had any issues with mine. Shark Week was great having all my tunes at my finger tips. Hope you get your issues resolved.

Sent from Motorcycle.com Free App

AMMO: Giving the enemy the opportunity to die for their country

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ammojeff is offline  
post #6 of 8 (permalink) Old 08-14-2013, 10:37 AM
Member
 
Shemp's Avatar
 
Join Date: Dec 2011
Location: Northern Colorado
Posts: 712
As with anything, people included, you may not know it's bad until you try to use it. Glad iron cross is taking care of the problem. Love the interface and haven't had any issues with mine.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 RGU Merlot/Sunglo, Daymakers, 13" Madstad dark grey windshield, LED tourpac lights, SE RT/SE AC, Bassani Road Rage 2/1 pipes, Wild 1 10" mini apes, Street Glide fascia.
Miles of twisting mountain roads with no guardrails!
Shemp is offline  
post #7 of 8 (permalink) Old 08-17-2013, 03:37 PM
Grey beard
 
ERod62's Avatar
 
Join Date: Aug 2013
Location: Florida
Posts: 967
Many ones work but other have issues. Did my homework before buying my end up with the HD unit just because don't like to do the same work twice.
Hat off to Iron Cross customer service. From every reported issue they were taking care.
Hope next one work for you...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2012 Custom TTS tuner, Vance & Hines Power Duals with Hi Output, 57H Cam, J&M Amp and Speakers many others...
ERod62 is offline  
post #8 of 8 (permalink) Old 07-22-2014, 07:27 PM
Hangaround
 
z73421's Avatar
 
Join Date: Aug 2012
Location: Twinsburg, OH
Posts: 144
My story is not so good. Although Iron Audio was quick to respond all that customer service does not help if the problem is not resolved. I had the unit installed for nearly a year and then it stopped working. The HK would not recognize the unit. Sent it to Iron Cross and they said there was no problem with the unit and sent it back with a new cable. I reinstalled the unit and now it is recognized but quits after 30-60 seconds. What a PITA dealing with the fairing.

#sigh - It was so nice when it worked.
z73421 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
iPod interface Harley vs Iron Cross???? Steelerdude1 *General Road Glide Discussions/Pictures 5 09-25-2014 09:52 AM
2012 Harmon Kardon radio and Iron Cross Audio iPod HDD Plus pointblankokc Parts for Sale 5 06-25-2014 07:15 PM
Ipod HD. interface needed if one uses J&M NEW Ipod interface??? hogger Audio 2 10-22-2013 02:28 PM
Iphone 5 and Iron Cross Ipod Interface? adam_twenty6 Audio 1 09-18-2013 10:53 AM
HD iPod Interface or Iron Cross? Keets Audio 14 07-11-2013 02:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome