6.5's that can handle pbr300x4 - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 09-30-2013, 09:18 AM Thread Starter
Newbie
 
Join Date: Apr 2011
Posts: 26
6.5's that can handle pbr300x4

I currently have a pair of Polk Dxi 650's and a pair of infinity kappa's in my glide both are distorting at anything above half vol after a long 13 hr run with the music up loud (interstate) riding id like to find some that can take the abuse of the pbr300x4 amp ? Suggestions?

One set is behind the fairing and one set is in the CVO street glide lower speaker boxes

Thanks in advance.

2011 RGC, detach king tourpack 103 powerpack, direct link super tuner, big sucker air intake, gutted cat, V&H Monster Rounds, santee mini apes, 12"WV & 14"WV, sanchos wings, J&M 7.25 and much more to come!

im 6Ft tall with a 32 inseam

2009 FLHX red hot sunglo, blacked out,arlen ness big sucker, race tuner, bub7 exhaust, [email protected] 87hp 109tq wild one 12" bagger bars, heat deamons.SOLD

2005 FLSTF F.F. edition, chrome everyting, vance & hines short shots. remap, stage 1 air intake.SOLD
ffhd05 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-30-2013, 10:14 AM
Life Member
 
h-donut's Avatar
 
Join Date: Jul 2010
Location: Central KY
Posts: 3,638
ideas

1. another set of kappa's

2. migrate to the PBR300x2 with better software and features

3. hawg wired ZX

4. swap listening positions of the speakers

5. bass blockers on the polks

2010 FLTRX- r o a d g l i d e

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
h-donut is offline  
post #3 of 13 (permalink) Old 09-30-2013, 02:23 PM
Newbie
 
zuppy51's Avatar
 
Join Date: Sep 2009
Posts: 44
I'm running the T165 Fosgates with the PBR300x(4). They are perfectly matched at the RMS. They are broken in, with extremenly low distortion.
I think only at full volume with the very heavy bass do they distort.

I've run them at peak for hours on long rides, never a problem.

The reason for the 4 channel for me, is I have a tourpak. I routed a pair of leads with quick disconnect plugs to the rear of the bike. When I install the tour pak for long rides, I just plug them in. The amp is pre-set with the gain and frequency. It's amazing how well they sound.
zuppy51 is offline  
 
post #4 of 13 (permalink) Old 09-30-2013, 03:26 PM
Grey beard
 
rageglide's Avatar
 
Join Date: Dec 2011
Location: San Jose, Ca
Posts: 1,288
I killed a set of Hawg Wired 6.5's in short order with their 120watt amp, so I'm guessing they wouldn't hold up under those conditions with the pbr300 either...

2012 fltrx
rageglide is offline  
post #5 of 13 (permalink) Old 09-30-2013, 05:02 PM
Shark of the Month August 13
 
SIC_26's Avatar
 
Join Date: May 2012
Location: Northern SF BayArea
Posts: 3,319
I don't want to say I was "disappointed" with my ZXs but.......I did expect more from them. Everyone I ride with loved them though they were powered by a PBR 300x2

Good ain't cheap, cheap ain't good.......
West coast ANTI SW IV - CA spring ride.....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SIC_26 is offline  
post #6 of 13 (permalink) Old 09-30-2013, 05:10 PM
Member
 
CNMTurner's Avatar
 
Join Date: Oct 2011
Location: Millersville, MD
Posts: 671
Hey HHFD05

What head unit are you running?
Is it possible that you have the gain set too high on the amp?

On head unit, do you have bass bumped up.. I did and it was causing similar problems.. I now run it flat (bass and treble set around 0), I have the Stock HK head unit with PB3002

2010 FLTRX - Stage 4 SE 113 - MVA Heads, 10.5:1, SE266E cams, 58mm TB, 5.3 gr/s injectors, Polished and plated motor and trans and a few chrome extras. Fullsac DX Header and Freedom Performance Classic 4" Slip-ons. Titan II 6.5 speakers with RF PBR300x2, Monroe Airshocks
1996 Tail dragin' Fatboy

Last edited by CNMTurner; 09-30-2013 at 05:59 PM.
CNMTurner is offline  
post #7 of 13 (permalink) Old 09-30-2013, 05:19 PM
Shark of the Month August 13
 
SIC_26's Avatar
 
Join Date: May 2012
Location: Northern SF BayArea
Posts: 3,319
Quote:
Originally Posted by CNMTurner View Post
What head unit are you running?
Is it possible that you have the gain set too high on the amp?

On head unit, do you have bass bumped up.. I did and it was causing similar problems.. I now run it flat (bass and treble set around 0), I have the Stock HK head unit with PB3002
I was running the HK head unit with bass and treble turned down to 0, I just expected more outta it I guess.......had polks in the inner fairing and ZXs in stock location, each set of speakers with there own PBR 300x2 it was loud and clear and everyone within 3-4 bike could hear me, I just though/expected more Ol lady couldn't hear much when we were going down the road

I turned the volume up to the "E" and adjusted my gains from there.......til speakers clipped then backed it of a bit. Each amp separately

Said screw it this time LOL and not messing around with any of that stuff ITOLDU loaned me the money for my new setup he just doesn't know it yet

Good ain't cheap, cheap ain't good.......
West coast ANTI SW IV - CA spring ride.....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SIC_26 is offline  
post #8 of 13 (permalink) Old 09-30-2013, 05:23 PM
Life Member
 
stripclub's Avatar
 
Join Date: Apr 2013
Location: Warren, Ohio
Posts: 1,989
If you are running a factory head unit, set the gains on the amp with the volume on the head unit about 3/4 the way up for the max volume, and never take the volume past that. The factory head unit starts sending out a distorted signal any higher than that, so you are already putting a distorted signal into the amp, in return you are getting a amplified distorted output to the speakers. I am running six RF 6 1/2 in the fairing and lowers, two RF 5 1/4 in the tour-pak pods, two RF 1" tweeters with two RF crossovers in the fairing, and two RF300PBRX4 with the factory head unit and the gains set that way and sounds great without distorting.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
stripclub is offline  
post #9 of 13 (permalink) Old 09-30-2013, 05:31 PM
Shark of the Month August 13
 
SIC_26's Avatar
 
Join Date: May 2012
Location: Northern SF BayArea
Posts: 3,319
Yessir, that it's what I did. Like I said, it didn't sound bad. Was clear and loud, just expected more

High end speakers and better amp should do it this go around, spending the $$ and doing it once

To quote "hurt 'me with them Hertz"

Good ain't cheap, cheap ain't good.......
West coast ANTI SW IV - CA spring ride.....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SIC_26 is offline  
post #10 of 13 (permalink) Old 09-30-2013, 05:45 PM
Grey beard
 
rageglide's Avatar
 
Join Date: Dec 2011
Location: San Jose, Ca
Posts: 1,288
I'm fairly confident what killed my ZX's was me not disabling the HK's auto volume level and running volume above half way. I'm sure it had nothing to do with the mild mannered metal mix....

2012 fltrx
rageglide is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I Can't Wait I Can't Wait I Can't Wait......The Outdoors SteadyEddie General Off-Topic Discussions 15 05-19-2017 02:57 PM
Rockford Fosgate PBR300X4 is here pasa Audio 82 11-07-2013 09:11 AM
Install RF pbr300x4 amp? GLYDDN11 Aftermarket Accessories 2 01-29-2012 06:45 AM
Girl can handle Sharks DreamRider Videos 7 10-23-2011 07:00 PM
Fosgate PBR300X4 SGT_Rob Audio 1 09-10-2011 10:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome