Anyone running an ARC Audio amp @ 2 Ohm? - Road Glide Forums
Audio List your speakers and audio solutions for the roadglide.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-20-2013, 08:23 PM Thread Starter
Hangaround
 
Sedona103's Avatar
 
Join Date: Jul 2011
Location: So Cal
Posts: 178
Anyone running an ARC Audio amp @ 2 Ohm?

I am planning to run my Arc 125.2 to power 4 polk mm651um speakers and was wondering if anyone else had much luck doing so? I might have to step up to a 4 channel but was hoping not to.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 fltrx w/ 103.
My build thread.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sedona103 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-23-2013, 02:37 AM
Life Member
 
h-donut's Avatar
 
Join Date: Jul 2010
Location: Central KY
Posts: 3,638
well, the MM series polks are 2.7 ohm, so two pairs would make a nice wide 4ohm load wired in series

the 4ohm load is said to be much quieter on that amp.

other note: UM have fixed bezels and are harder to fit on bike and some huge assed magnets

the black MM651's with the tiny neo magnet's are the ones you want, think

wired in series is the scary one where you cross wire one positive on one speaker to the negative of the other speaker, then run the opposing leads, + and minus from the two separate speakers to the amp.

not scary, just one of those things, I always check the speaker load before just trying it out with a ohm meter

you do get a louder output wiring in parallel, usually, but depends on what you have in parts, in the case of the MM series, they're throw a 1ohm load and more than likely sound really good for about 10 minutes and then the amp would cook.

2010 FLTRX- r o a d g l i d e

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
h-donut is offline  
post #3 of 4 (permalink) Old 10-23-2013, 06:58 PM
Life Member
 
ITOLDU's Avatar
 
Join Date: Oct 2010
Location: Ft Worth
Posts: 1,870
I ran my arc like that before I added more speakers and more amps.

2006 Road Glide. S&S 124" 126/132 D&D Fatcat,
26" Evolution wheel 12 speaker-2 amp 1500watt stereo
Kandy Paint, Big Motor/Big Wheel/Big Sounds (tunes)
ITOLDU is offline  
 
post #4 of 4 (permalink) Old 10-23-2013, 07:21 PM Thread Starter
Hangaround
 
Sedona103's Avatar
 
Join Date: Jul 2011
Location: So Cal
Posts: 178
I might just have to pick up a new amp.

Sent from Motorcycle.com Free App


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2011 fltrx w/ 103.
My build thread.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sedona103 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Paralleling speakers 4 ohm 2 ohm using amp set up to parrallel Heavy Metal Audio 16 01-06-2018 06:09 PM
Arc 602 Speakers & 600.4 Arc Amp- anyone running bridged? scottrgs Audio 5 03-22-2017 07:06 AM
Speaker question 2 OHM or 4 OHM Ginee13 Audio 3 09-22-2015 05:53 AM
switching from 4 ohm to 2 ohm at a later date chevjerico Audio 3 05-15-2014 01:24 PM
4 ohm and 2 ohm speakers yamahoe72 Audio 7 04-13-2013 07:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome