2013 RGC ping after dyno - Road Glide Forums
Dyno Results Post your Dyno Results here. Let's see who is HOT!

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-29-2014, 09:18 AM Thread Starter
Hangaround
 
Join Date: Mar 2013
Posts: 55
2013 RGC ping after dyno

I just had the SE 255 cams installed, already had SE A/C, decat headers, rinehart slipons, and SE Racetuner. After the cams the bike was retuned. Runs great and HP around 95 and TQ 103. Bringing the bike home (a 200 mile ride one way) I noticed at interstate speed (75) and running the traditional 3000 rpm that on slight uphills the bike will ping. If you give it the onion it does not ping. Taking it back over to get it retuned this weekend? IS it the AFR or something with timing advance?
emt-p is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-29-2014, 01:49 PM
Life Member
 
moose1's Avatar
 
Join Date: Sep 2012
Location: Blanchard Oklahoma
Posts: 1,578
When mine did it after cams and the SERT I took it back and the just hooked it back up and changed the afrs at the point where I told them it was pinging it only took a few minutes

2012 FLTRU vivid black
moose1 is offline  
post #3 of 10 (permalink) Old 10-29-2014, 03:27 PM Thread Starter
Hangaround
 
Join Date: Mar 2013
Posts: 55
cams

Thanks I hope it doesnt take long really happy with the cams, just cant stand the ping, it sounded more front cylinder too.
emt-p is offline  
 
post #4 of 10 (permalink) Old 10-29-2014, 08:23 PM
Hangaround
 
harleytuner's Avatar
 
Join Date: Oct 2014
Location: Fredericksburg, Va.
Posts: 52
Sounds like spark knock from what you are describing. The timing is advanced to much.
harleytuner is offline  
post #5 of 10 (permalink) Old 10-30-2014, 09:22 AM Thread Starter
Hangaround
 
Join Date: Mar 2013
Posts: 55
retune

so from what both of you are saying I gather that they will not have to run the bike on the dyno, just go in with the computer and tuner and tweak the settings?
emt-p is offline  
post #6 of 10 (permalink) Old 10-30-2014, 10:42 AM
Grey beard
 
hd4cruzin's Avatar
 
Join Date: Oct 2011
Location: Santa Clarita, CA
Posts: 1,317
Should just hook up to ECM and tweak the settings. I had the same issue with my TTS and brought it back and they adjusted the timing in that area and all is good now. Took 10 minutes

2012 FLTRX BBP
Drago Diablo 2.5 107" 580 cam, Drago 2 pipe and TTS, 14.5" Madstad, Vindikta 12" Maruaders, Corbin Solo
6.5" H.A.T. speakers and Arc 125.2 amp
hd4cruzin is offline  
post #7 of 10 (permalink) Old 10-30-2014, 11:04 AM
Hangaround
 
harleytuner's Avatar
 
Join Date: Oct 2014
Location: Fredericksburg, Va.
Posts: 52
Quote:
Originally Posted by emt-p View Post
so from what both of you are saying I gather that they will not have to run the bike on the dyno, just go in with the computer and tuner and tweak the settings?
If they know what they are doing they should be able to just hook it up and pull a couple degrees of timing where your issues are.
harleytuner is offline  
post #8 of 10 (permalink) Old 10-31-2014, 12:17 PM Thread Starter
Hangaround
 
Join Date: Mar 2013
Posts: 55
Thanks!!! Will know tomorrow how much they know!
emt-p is offline  
post #9 of 10 (permalink) Old 11-11-2014, 10:50 AM
Hangaround
 
harleytuner's Avatar
 
Join Date: Oct 2014
Location: Fredericksburg, Va.
Posts: 52
Quote:
Originally Posted by emt-p View Post
Thanks!!! Will know tomorrow how much they know!
How did it turn out?
harleytuner is offline  
post #10 of 10 (permalink) Old 11-12-2014, 09:59 AM Thread Starter
Hangaround
 
Join Date: Mar 2013
Posts: 55
They retarded the timing 2 degrees, and was only able to get it to ping once on a 200 mile ride home. And I was trying pretty hard to get it to ping. Happy with the cams, just wondering if the tune still might be off a bit.
emt-p is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 RG with ping at WOT cookie114 Engine Related 13 01-14-2016 08:06 AM
TTS MasterTune Map to stop Ping and high heat 2011 RGU? Raiderse ECM/Fuel Management systems 15 05-10-2012 01:52 PM
ping... Ping... PING philmartin *General Road Glide Discussions/Pictures 20 07-25-2011 09:10 PM
Ping and Stutter whispanic Troubleshooting for Road Glides 10 05-23-2011 11:21 AM
Heard a "PING!" when riding today okcdoughboy *General Road Glide Discussions/Pictures 26 05-06-2011 11:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome