Installed my amp today-- - Road Glide Forums
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-17-2011, 05:24 PM Thread Starter
Admin
 
BillyBob's Avatar
 
Join Date: Sep 2009
Location: Mississippi
Posts: 4,274
Installed my amp today--

Installed my 250w amp today works great--about 50% louder than none amp with J&M speakers.

J&M what speakers is this amp rated for?

Bill

2010 FLTRX Red / The First Roadglide / "There's no Ride like a Glide"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyBob is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-20-2011, 01:31 PM Thread Starter
Admin
 
BillyBob's Avatar
 
Join Date: Sep 2009
Location: Mississippi
Posts: 4,274
Hmm but blew a speaker out today.
Not sure why. Need to give jm a Call.

Sent from the Droid using Tapatalk

2010 FLTRX Red / The First Roadglide / "There's no Ride like a Glide"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyBob is offline  
post #3 of 8 (permalink) Old 09-20-2011, 03:12 PM
Life Member
 
Shrug's Avatar
 
Join Date: Mar 2010
Location: Wills Point, Texas
Posts: 2,210
Garage
Send a message via Yahoo to Shrug
Quote:
Originally Posted by Theadmin View Post
Hmm but blew a speaker out today.
Not sure why. Need to give jm a Call.

I blew a J&M 7.25 with a HogTunes amp about a week after installing. Have a set of Hz 6.5s and an Arc amp in the stable awaiting installation. Need to get on that!



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Shrug - Scott Wilson
2010 FLTRX "Hester 2.0" -
Blue Knights Texas Chapter XLVI
Shrug is offline  
 
post #4 of 8 (permalink) Old 09-21-2011, 10:59 AM
Life Member
 
h-donut's Avatar
 
Join Date: Jul 2010
Location: Central KY
Posts: 3,638
not sure if this helps or not, but while installing my non-J&M amp, I had a couple instances of 'pop' ended up being those two unused positive wires up near the headlights, jumping through the speaker connectors.

the black paper tape put on at the factory had lost it's luster and fell off.

2010 FLTRX- r o a d g l i d e

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
h-donut is offline  
post #5 of 8 (permalink) Old 09-25-2011, 05:37 PM Thread Starter
Admin
 
BillyBob's Avatar
 
Join Date: Sep 2009
Location: Mississippi
Posts: 4,274
J &M has a speaker trade in program going so I'm trading the old blown one in for their new ROKKER Speakers. Hopefully Bobby will help me install the new ones



Sent from the Droid using Tapatalk

2010 FLTRX Red / The First Roadglide / "There's no Ride like a Glide"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyBob is offline  
post #6 of 8 (permalink) Old 09-25-2011, 07:45 PM
Life Member
 
jimmyray11349's Avatar
 
Join Date: Apr 2011
Location: The Woodlands, Texas
Posts: 2,608
I had Mobile One install my Elf mini 125x2. Only charged me $80 with wire. sounds great. about 100% louder than w/o amp. I also have the J&M 7.25. No problems after 1 month. Would like more bass tho.

2010 FLTRX Vivid Black.ABS-Security-Cruise
SE Pro Super Tuner, D&D Fat Cat 2-1 S&S 510 Cams

87hp 101tq
Contrast Chrome Agitators 19/18
Baggershield
Harley Hammock-Adj.Back Rest
King Tour Pac-Air Wing Rack(black)-Smoked LED-4 Pt.Dock-Black Latches & Hinges
Custom Dynamics LED's & Plazma Rods smoked front & rear with Magic Strobe
J&M 250w Fairing + Lower Rokkers
Saddlebag Bra
Hidden Multi-Color LEDs
Jagg Fan Assisted Oil Cooler
Kuryakyn Passenger detach. ArmRest & adj. pegs

jimmyray11349 is offline  
post #7 of 8 (permalink) Old 09-26-2011, 09:49 AM
Hangaround
 
texas glide's Avatar
 
Join Date: Jul 2011
Location: Richmond Texas
Posts: 113
Quote:
Originally Posted by Shrug View Post

I blew a J&M 7.25 with a HogTunes amp about a week after installing. Have a set of Hz 6.5s and an Arc amp in the stable awaiting installation. Need to get on that!
-

Were they the Rokker series ? I am running Hog Tunes now and was thinking of going to the J&M's and use my Hog Tunes amp.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[SIGPIC]2011 FLTRX Vivid Black
103" V&H Power Duals Slash Cut Rounds Ness Big Sucker2 PV WO 515
texas glide is offline  
post #8 of 8 (permalink) Old 09-27-2011, 04:54 PM Thread Starter
Admin
 
BillyBob's Avatar
 
Join Date: Sep 2009
Location: Mississippi
Posts: 4,274
Mine weren't but jm says they aren't suppose to blow.

Sent from the Droid using Tapatalk

2010 FLTRX Red / The First Roadglide / "There's no Ride like a Glide"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BillyBob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Supertrap Stouts installed today.... Roadglide AR Intake and Exhaust 4 04-10-2012 09:32 PM
way! anybody ride today? tell us about it? (cold ride today) jeffb928 *General Road Glide Discussions/Pictures 40 04-02-2012 10:19 PM
Installed my new Sancho's Wings today... Ma$$hole *General Road Glide Discussions/Pictures 1 07-31-2011 07:09 PM
Installed Fuelmoto system today juicedss ECM/Fuel Management systems 12 07-25-2011 07:57 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome