250 watt amp adjustments - Road Glide Forums
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-13-2012, 10:38 PM Thread Starter
Hangaround
 
craigv65's Avatar
 
Join Date: Jan 2012
Location: Milwaukee, Wisconsin
Posts: 71
250 watt amp adjustments

i have the 7.25 rokkers and the 250 watt amp. i installed everything the way it came. what are the settings for the amp that most are using?

2012 FLTRX
Roland Sands Design Contrast Cut line
Roland Sands Hang-Lo Seat
Roland Sands Glider Bars (TBD)
H-D Edge Cut line
FullSac X-Pipe B
CFR Exhaust (The BEST sounding I ever heard)
Tman TR-600sm cams
TTS Matertune
J&M 7.25 Rokkers with 250 watt amp
Progressive Mono Tube Suspension
craigv65 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-14-2012, 01:36 AM
Hangaround
 
Longrider's Avatar
 
Join Date: Nov 2010
Location: Columbia, SC
Posts: 101
They don't want you to touch the settings. I was told by John from J&M, if you remove the tape covering the screws to adjust it, it will void the warranty. My tape is gone.
Longrider is offline  
post #3 of 5 (permalink) Old 03-15-2012, 02:48 AM
Hangaround
 
Join Date: Feb 2012
Location: Pacifica Ca
Posts: 102
I have the same system (J&M 250 w/ 7.25's). I didnt need to amp-adjust mine as the bass didnt distort at all at max setting. In theory i shouldnt blow a speaker but time will tell.
Fog Shark is offline  
 
post #4 of 5 (permalink) Old 05-05-2012, 08:58 AM
Newbie
 
Join Date: Apr 2012
Location: North Carolina, Burlington
Posts: 16
J&M 250 watt amp is going into protect ?

Just installed 250 watt amp and rokker 7.25 speakers and amp is shutting down when I turn radio volume up about a third the way there is no info about the amp other than install instructions. I've double checked my work looks right
There is a two position switch that says preamp or speakers it was set to speakers from the factory. It being Saturday I can't call J&M. Its powers up just fine but when i bring the volume up to a point (not very loud) its just like you hit a mute button the fan on the amp comes on. Its like its going into protect or something. anybody ever have this sort of problem?
Sok Monkee is offline  
post #5 of 5 (permalink) Old 05-05-2012, 09:39 AM
JMJOHN
 
JMJOHN's Avatar
 
Join Date: Oct 2010
Location: Tucson AZ
Posts: 981
good amplifier adjustment video here http://www.youtube.com/watch?v=Y6C5MiRGq1Y&feature=plcp ,,,,,

JMJOHN ----
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JMJOHN is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
J&M 250 Watt Amp Eddie-Diesel Sold 14 03-16-2013 12:42 PM
J&M 250 watt amp, 7.25 speakers, adapters, bracket, and wiring SEUGOT1 Sold 10 02-25-2013 07:10 AM
J&m rocker 250 watt amp glide69 Audio 3 06-30-2012 01:15 PM
Adjusting a J&M 250 watt amp ironmark J&M 8 05-25-2012 11:10 AM
Fan noise from J&M 250 watt amp DED HD J&M 11 01-06-2012 09:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome