Road Glide Forums - Reply to Topic
ECM/Fuel Management systems ECM/Fuel Management systems For Road Glides

Thread: Tuner issues Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-21-2015 02:42 PM
Partsman Thank you Dozer. Will check that.
06-21-2015 07:21 AM
dozer23
heat sensor

Check the heat sensor located in front head, behind the horn.I had one go last year. And now know of at least 4 more people who had the same problem. undetectable by scanners and dyno.it drove me crazy on and off for a month.took the bike to see Dr.Dyno wile at amricade explained symptoms too thrilled Dr. (Not running well wile hot or under a load).and sure enough it was the sensor. Good luck!
06-19-2015 10:41 PM
Partsman Eagle that completely slipped my mind,,, I have true duels, mufflers and a k and n air filter. Strange thing is it ran all last year, 8 thousand miles in all, without a single problem
06-19-2015 09:40 PM
Eagle you dont list the mods you have but if its just air cleaner and slipons you could try without the tuner for a short ride , or ride with the tuner until it gets warm then remove it to see if thats the problem or there is something else.
06-19-2015 09:22 PM
Partsman
Tuner issues

Two years ago I put a Fuel Moto micro tuner on my 13 Road glide ultra.. Its run flawlessly until this past weekend... bike runs great until it warms up.. now please know Fuel moto has bent over backwards to take care of this, even today spending time on the phone with my lovely bride doing a new download.. Once again ran very well tonight until the motor got warm.. at that time it fall flat on its face off idle, backfires and misses, and will stall at idle with fuel pouring from the air filter... our issue is we are leaving on vacation this Thursday so im kind of in a pickle... Harley store half a mile from home can put on a Harley tuner for me tomorrow. Just wanted to make sure im not missing something here.. sorry for such a long post, just looking for some advice... happy riding

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome