Road Glide Forums - Reply to Topic
Tech Area For Tutorials and Instructional Materials

Thread: Primary and transmission fluid question ? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-22-2013 07:49 AM
mitchdm I run Red-Line Vtwin Primary in the Primary & Red-Line Vtwin Transmission in trany ~ any Heavy Gear Oil will work in Trany ~ Even ATF will work in Primary
06-22-2013 02:16 AM
rageglide
Quote:
Originally Posted by Loudog View Post
I have 03 road glide and I recently replace the inner primary and gaskets and the drive sprocket seal and still leaks can anybody help
Which is leaking, transmission or primary? Try different color fluids to determine which is leaking.

If the inner primary was removed, was the correct o-ring used? Was silicone used where needed? Was the inner primary seal replaced?

My '05 leaked transmission fluid always leaked from the shifter shaft seal...
06-21-2013 11:23 PM
Loudog I have 03 road glide and I recently replace the inner primary and gaskets and the drive sprocket seal and still leaks can anybody help


Sent from Motorcycle.com Free App
10-23-2012 11:00 AM
flhr95 Spectro in the Trans.
http://www.spectro-oils.com/heavy-du...nsmission-oil/
10-23-2012 09:54 AM
DJJ06 I've also ran Bel-Ray in my trans. For the reason listed above,an "old" biker once told me that's how you tell what's leaking by the color.---back when they all left spot's on the ground.
10-12-2012 08:27 PM
Road dawg Thanks for everyones input it was much appreciated !
10-03-2012 01:31 AM
rageglide
Quote:
Originally Posted by Loudog View Post
I have an 03 road glide and found a leak coming from the sprocket closes to the engine can any body have any ideas where that might be coming from?
Using different colored fluids helps isolate these kinda things. Trans will leak from the main seal and sector shaft. Primary can leave at the engine o-ring and also at the 4 trans mounting bolts. Inner mainshaft and of course Primary can leak all along the outer primary gasket...

Lots of places... so yer gonna have to crawl, wipe and look. With ATF in the primary I know when it's leaking, redline shockproof tranny oil leaves a pink spot...
10-02-2012 09:42 PM
Loudog I have an 03 road glide and found a leak coming from the sprocket closes to the engine can any body have any ideas where that might be coming from?


Sent from my iPhone using MO Free
10-01-2012 09:07 PM
Torquey
Quote:
Originally Posted by torqu View Post
Why would you want to run a full synthetic in the primary? You need some kind of friction between the disc. I thought the only reason there was any oil in the primary was to lubricate the sprockets and chain. I dont run synthetic in my primary for those reasons. I run a primary oil made by Spectro.
Perhaps, but on my FatBoy, the clutch was buttery smooth and precise with Amsoil. With my new Glide, I am going to try the dedicated RedLine Primary fluid. Both are fully synthetic.
10-01-2012 08:31 PM
torqu Why would you want to run a full synthetic in the primary? You need some kind of friction between the disc. I thought the only reason there was any oil in the primary was to lubricate the sprockets and chain. I dont run synthetic in my primary for those reasons. I run a primary oil made by Spectro.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome