Road Glide Forums - Reply to Topic
Tech Area For Tutorials and Instructional Materials

Thread: Front brake issue on 2016 roadglide Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Road Glide Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-11-2018 06:58 AM
aviscomi
Quote:
Originally Posted by Sheinen View Post
i did have my bars off.
There's your answer.
12-11-2018 02:26 AM
Sheinen i did have my bars off.
12-11-2018 12:35 AM
BigBlockBobby I agree with USMCEOD.
12-10-2018 09:35 PM
USMCEOD It's likely to be the switch. Assuming both bulbs are good of course. Have you done any mods recently that might have damaged the switch like new handlebars, grips, etc. It's easy to damage the switch when changing things up in that area.
12-10-2018 08:41 PM
Sheinen
Front brake issue on 2016 roadglide

Need help I recently have had my front brake stop activating the brake light? The rear works fine but my front doesn’t work at all. Could this be the switch?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome